<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1"><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Lato"] },classes:false, events:false, timeout:1500};</script><link rel="profile" href="http://gmpg.org/xfn/11" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script> <link media="all" href="https://vitux.com/wp-content/cache/autoptimize/css/autoptimize_1771e83e8fc5e2448d7af542c0ad6b66.css" rel="stylesheet" /><title>Automatically Empty Trash on Debian through Autotrash CLI</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Automatically Empty Trash on Debian through Autotrash CLI" /><meta property="og:description" content="When we delete a file or folder from our system, it is moved to the Recycle Bin (Linux) or the Trash (Windows). Again and again, we have to get rid of these mostly useless files and folders that are in" /><meta property="og:url" content="https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/" /><meta property="og:site_name" content="VITUX" /><meta property="article:publisher" content="https://www.facebook.com/vituxcom/" /><meta property="article:published_time" content="2020-05-20T16:26:10+00:00" /><meta property="og:image" content="https://vitux.com/wp-content/uploads/debian-autotrash-cli.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="512" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@vituxcom" /><meta name="twitter:site" content="@vituxcom" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","potentialAction":[{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/#primaryimage","inLanguage":"en-US","url":"https://vitux.com/wp-content/uploads/debian-autotrash-cli.jpg","width":1024,"height":512,"caption":"Debian Autotrash Utility"},{"@type":"WebPage","@id":"https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/#webpage","url":"https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/","name":"Automatically Empty Trash on Debian through Autotrash CLI","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/#primaryimage"},"datePublished":"2020-05-20T16:26:10+00:00","dateModified":"2020-05-20T16:26:10+00:00","author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/"]}]},{"@type":["Person"],"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar"}]}</script> <link rel="amphtml" href="https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/amp/" /><meta name="generator" content="AMP for WP 1.0.50" /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" /><link rel='stylesheet' id='a3a3_lazy_load-css' href='//vitux.com/wp-content/uploads/sass/a3_lazy_load.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"9183","token":"85c4b2c5f1","debug":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1589991367/out/header-5164b3ccf92958302ee1014c2cd8dce27bccbfa6.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://vitux.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.1" /><link rel='shortlink' href='https://vitux.com/?p=9183' /><link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fautomatically-empty-trash-on-debian-through-autotrash-cli%2F" /><link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fautomatically-empty-trash-on-debian-through-autotrash-cli%2F&#038;format=xml" /> <script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script> <script src="https://code.jquery.com/jquery-3.5.0.js"></script><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-9183 single-format-standard  better-responsive-menu">
<div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a><header id="masthead" class="site-header clearfix spacious-header-display-one"><div id="header-text-nav-container" class=""><div class="inner-wrap" id="spacious-header-display-one"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class=""><h3 id="site-title"> <a href="https://vitux.com/" title="VITUX" rel="home">VITUX</a></h3><p id="site-description">Linux Compendium</p> </div></div><div id="header-right-section"><div class="header-action"></div><nav id="site-navigation" class="main-navigation clearfix   " role="navigation"><p class="menu-toggle">Menu</p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li><li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li><li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li><li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li><li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li></ul></div></nav></div></div></div></div><div class="header-post-title-container clearfix"><div class="inner-wrap"><div class="post-title-wrapper"><h1 class="header-post-title-class">Automatically Empty Trash on Debian through Autotrash CLI</h1></div></div></div></header><div id="main" class="clearfix"><div class="inner-wrap"><div id="primary"><div id="content" class="clearfix"><article id="post-9183" class="post-9183 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-linux category-shell"><div class="entry-content clearfix"><p>When we delete a file or folder from our system, it is moved to the Recycle Bin (Linux) or the Trash (Windows). Again and again, we have to get rid of these mostly useless files and folders that are in our system crash to make room for other important data. If you want to set your Debian to automatically take care of the system trash over a period of time, you can use the command-line utility called Autotrash.</p><p>Autotrash is a utility that searches a trash folder on FreeDesktop.org for information about its contents and then deletes part of the trash depending on the options you specify.</p><p>This article explains how to install the Autotrash utility, find help, and use it. We&#8217;ll explain the procedure with some examples that will help you understand the widely used features of this utility.</p><p>We have run the commands and procedures mentioned in this article on a Debian 10 Buster system.</p><h2>Install Autotrash through the Debian Terminal</h2><p>We will install the Autotrash CLI through the Terminal application. You can launch the Terminal through the Application Launcher search as follows:</p><p><img class="lazy lazy-hidden aligncenter wp-image-9184" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/11/word-image-218.png" alt="Debian Terminal" width="224" height="209" /><noscript><img class="aligncenter wp-image-9184" src="https://vitux.com/wp-content/uploads/2019/11/word-image-218.png" alt="Debian Terminal" width="224" height="209" /></noscript></p><p>Please note that only an authorized user( root or sudo) can add/update, remove and configure software on a Debian system.</p><h3>Step1: Update your system’s repository Index</h3><p>In order to install the latest version of the software available in Debian’s online repositories, your system’s repository index needs to be up-to-date.</p><p>Run the following command as sudo in order to update your system’s local repository index with that of the Internet.</p><pre>$ sudo apt-get update</pre><p><img class="lazy lazy-hidden aligncenter wp-image-9185" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/11/word-image-219.png" alt="Update packages" width="563" height="218" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-219.png 563w, https://vitux.com/wp-content/uploads/2019/11/word-image-219-300x116.png 300w" sizes="(max-width: 563px) 100vw, 563px" /><noscript><img class="aligncenter wp-image-9185" src="https://vitux.com/wp-content/uploads/2019/11/word-image-219.png" alt="Update packages" width="563" height="218" srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-219.png 563w, https://vitux.com/wp-content/uploads/2019/11/word-image-219-300x116.png 300w" sizes="(max-width: 563px) 100vw, 563px" /></noscript></p><p>The system might ask you for the password for sudo. Enter the password and your repository index will be updated.</p><h3>Step 2: Install the Autotrash CLI</h3><p>Now, you can install the autotrash utility by running the following command as sudo in your Terminal application:</p><pre>$ sudo apt-get install autotrash</pre><p><img class="lazy lazy-hidden aligncenter wp-image-9186" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/11/word-image-220.png" alt="Install the Autotrash CLI" width="655" height="303" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-220.png 655w, https://vitux.com/wp-content/uploads/2019/11/word-image-220-300x139.png 300w" sizes="(max-width: 655px) 100vw, 655px" /><noscript><img class="aligncenter wp-image-9186" src="https://vitux.com/wp-content/uploads/2019/11/word-image-220.png" alt="Install the Autotrash CLI" width="655" height="303" srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-220.png 655w, https://vitux.com/wp-content/uploads/2019/11/word-image-220-300x139.png 300w" sizes="(max-width: 655px) 100vw, 655px" /></noscript></p><p>The system might prompt you with a Y/n option before starting the installation procedure. Please enter Y to continue.</p><h3>Step 3: Verify Autotrash installation (optional)</h3><p>You can check the version number of your installed autotrash software and also verify if it is indeed installed on your system. Run the following command to do so:</p><pre>$ autotrash --version</pre><p>Or,</p><pre>$ autotrash -V</pre><p><img class="lazy lazy-hidden aligncenter wp-image-9187" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/11/word-image-221.png" alt="Check autotrash version" width="549" height="92" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-221.png 549w, https://vitux.com/wp-content/uploads/2019/11/word-image-221-300x50.png 300w" sizes="(max-width: 549px) 100vw, 549px" /><noscript><img class="aligncenter wp-image-9187" src="https://vitux.com/wp-content/uploads/2019/11/word-image-221.png" alt="Check autotrash version" width="549" height="92" srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-221.png 549w, https://vitux.com/wp-content/uploads/2019/11/word-image-221-300x50.png 300w" sizes="(max-width: 549px) 100vw, 549px" /></noscript></p><p>The results ensure that autotrash version 0.1.5 is installed on my Debian.</p><h2>Using Autotrash CLI (with examples)</h2><p>The autotrash help will tell you all you can do with this application. You can view the help as follows:</p><pre>$ autotrash --help</pre><p><img class="lazy lazy-hidden aligncenter wp-image-9188" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/11/word-image-222.png" alt="Using Autotrash CLI" width="673" height="494" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-222.png 673w, https://vitux.com/wp-content/uploads/2019/11/word-image-222-300x220.png 300w" sizes="(max-width: 673px) 100vw, 673px" /><noscript><img class="aligncenter wp-image-9188" src="https://vitux.com/wp-content/uploads/2019/11/word-image-222.png" alt="Using Autotrash CLI" width="673" height="494" srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-222.png 673w, https://vitux.com/wp-content/uploads/2019/11/word-image-222-300x220.png 300w" sizes="(max-width: 673px) 100vw, 673px" /></noscript></p><p>For even more details, you can view the manpage of autotrash by using the following command:</p><pre>$ man autotrash</pre><p>Now we will present some <strong>examples </strong>that will elaborate on how you can make the best use of this utility:</p><h3>Example 1: Delete Files older than x number of days</h3><p>This is the most widely used feature of Autotrash. You can use the following command syntax to automatically remove the files residing in your system trash for x number of days:</p><p><em>$ autotrash -d [days]</em></p><p>For example, the following command will remove the files that have completed their 30 days in the trash can.</p><pre>$ autotrash -d 30</pre><p><img class="lazy lazy-hidden aligncenter wp-image-9189" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/11/word-image-223.png" alt="Delete files that are older than 30 days" width="403" height="40" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-223.png 403w, https://vitux.com/wp-content/uploads/2019/11/word-image-223-300x30.png 300w" sizes="(max-width: 403px) 100vw, 403px" /><noscript><img class="aligncenter wp-image-9189" src="https://vitux.com/wp-content/uploads/2019/11/word-image-223.png" alt="Delete files that are older than 30 days" width="403" height="40" srcset="https://vitux.com/wp-content/uploads/2019/11/word-image-223.png 403w, https://vitux.com/wp-content/uploads/2019/11/word-image-223-300x30.png 300w" sizes="(max-width: 403px) 100vw, 403px" /></noscript></p><p>This gives you enough time to restore any files that you might wish to- during the 30 days.</p><p>The following usage of the command lets you apply this feature for not only your trashed files but also deleted files of all the user’s using the system:</p><p><em>$ autotrash -td [days]</em></p><p>Example:</p><pre>$ autotrash -td 30</pre><h3>Example 2: Delete files based on free-space left</h3><p><strong>Max-free</strong></p><p>You can only use autotrash to purge files if there is less than M megabytes of free space left at the trash location. As an example, if you set this to 1024, then autotrash will only start to work if there is less than 1GB of free space in the trash. Till that time, autotrash will just exit normally without scanning the Trash directory.</p><p>Example:</p><pre>$ autotrash --max-free 1024 -d 30</pre><p><strong>Min-free</strong></p><p>Similarly, you can use autotrash to make sure there is a minimum of M megabytes of free space.</p><p>Example:</p><pre>$ autotrash --min-free 1024</pre><p>You can even combine the two commands to make sure that autotrash starts reading the trash if there is less than 2 GB of free space, and then keep a check. The command will then remove files older than 30 days and also remove extra files to ensure that 1 GB of space is always available.</p><pre>$ autotrash --max-free 2048 --min-free 1024 -d 30</pre><h3>Example 3: Delete M number of megabytes</h3><p>You can use the utility to purge at least M number of megabytes, deleting the oldest trash addition first. This feature uses trash entries rather than the individual files This means that if your oldest trashed item is a 1GB directory, and you request at least 10MB to be removed (M=10), autotrash will remove 1GB.</p><pre>$ autotrash --delete M</pre><p>Example</p><pre>$ autotrash --delete 1024</pre><p>The examples we presented will help you in configuring even more customizable ways to empty trash. Now you do not need to worry about space wastage on your system because of the system trash The autotrash utility will automatically take care of clearing your unwanted files based on your defined criteria.</p><div class="extra-hatom-entry-title"><span class="entry-title">Automatically Empty Trash on Debian through Autotrash CLI</span></div></div><footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix"> <span class="by-author author vcard"><a class="url fn n" href="https://vitux.com/author/karim/">Karim Buzdar</a></span><span class="date"><a href="https://vitux.com/automatically-empty-trash-on-debian-through-autotrash-cli/" title="4:26 pm" rel="bookmark"><time class="entry-date published" datetime="2020-05-20T16:26:10+00:00">May 20, 2020</time></a></span> <span class="category"><a href="https://vitux.com/debian/" rel="category tag">Debian</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span></div></footer></article><ul class="default-wp-page clearfix"><li class="previous"><a href="https://vitux.com/how-to-password-protect-files-in-vim-editor/" rel="prev"><span class="meta-nav">&larr;</span> How to password protect files in Vim editor</a></li><li class="next"></li></ul></div></div><div id="secondary"><aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3><div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="navDiv"></div></div></aside><aside id="wpp-5" class="widget popular-posts"><h3 class="widget-title"><span>Most Popular</span></h3> <ul class="wpp-list"><li> <a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/always-launch-terminal-as-root-user-sudo-in-ubuntu/" class="wpp-post-title" target="_self">Always Launch Terminal as root User (sudo) in Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on September 13, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a></span></span></li><li> <a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 26, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on April 30, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-find-files-on-the-ubuntu-command-line/" class="wpp-post-title" target="_self">How to find files on the Ubuntu command line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-wine-on-ubuntu/" class="wpp-post-title" target="_self">How to Install Wine on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on September 20, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-xampp-on-your-ubuntu-18-04-lts-system/" class="wpp-post-title" target="_self">How to Install XAMPP on your Ubuntu 18.04 LTS System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 2, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 22, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-ubuntu-18-04-along-with-windows-10/" class="wpp-post-title" target="_self">How to Install Ubuntu 18.04 along with Windows 10</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 29, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-download-a-file-on-ubuntu-linux-using-the-command-line/" class="wpp-post-title" target="_self">How to Download a File on Ubuntu Linux using the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 24, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li></ul></aside></div></div></div><footer id="colophon" class="clearfix"><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"> Copyright &copy; <a href="https://vitux.com">vitux.com</a><nav class="small-menu clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li></ul></div></nav></div></div></div></footer> <a href="#masthead" id="scroll-up"></a></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');</script> <script>(function(){
	  if(typeof _bsa !== 'undefined' && _bsa) {
	    _bsa.init('fancybar', 'CE7I6KQJ', 'placement:vituxcom');
	  }
	})();</script> <script type="text/javascript">$("#navDiv").load("/nav.php?ref="+document.referrer.split('/')[2]);</script> <script type="text/javascript">(function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();</script> <script>var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });</script> <script type='text/javascript'>/*  */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0","horizontal_container_classnames":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1589991367/out/footer-935d2afa406c7e4ed77187acf420210d9256d42a.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script> </body></html>
