<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-2&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-2&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-2&cb=2', false, [], true, false, true, false);</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />

<title>How to Install Memcached on Debian 10</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://vitux.com/memcached_debian/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Install Memcached on Debian 10" />
<meta property="og:description" content="Memcached is a Linux in-memory cache application. It works as a key-value store that stores the information in-memory only to speed up applications. Many CMS systems like WordPress and Drupal support Memcached to speed up web page delivery. In this" />
<meta property="og:url" content="https://vitux.com/memcached_debian/" />
<meta property="og:site_name" content="VITUX" />
<meta property="article:publisher" content="https://www.facebook.com/vituxcom/" />
<meta property="article:published_time" content="2020-09-18T16:10:01+00:00" />
<meta property="article:modified_time" content="2020-09-18T16:16:20+00:00" />
<meta property="og:image" content="https://vitux.com/wp-content/uploads/debian-memcached.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="512" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@vituxcom" />
<meta name="twitter:site" content="@vituxcom" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","potentialAction":[{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vitux.com/memcached_debian/#primaryimage","inLanguage":"en-US","url":"https://vitux.com/wp-content/uploads/debian-memcached.jpg","width":1024,"height":512,"caption":"Debian Memcache"},{"@type":"WebPage","@id":"https://vitux.com/memcached_debian/#webpage","url":"https://vitux.com/memcached_debian/","name":"How to Install Memcached on Debian 10","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/memcached_debian/#primaryimage"},"datePublished":"2020-09-18T16:10:01+00:00","dateModified":"2020-09-18T16:16:20+00:00","author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vitux.com/memcached_debian/"]}]},{"@type":"Person","@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","image":{"@type":"ImageObject","@id":"https://vitux.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=96&d=mm&r=g","caption":"Karim Buzdar"},"description":"About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. You can reach Karim on LinkedIn"}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/vitux.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://vitux.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://vitux.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://vitux.com/wp-content/themes/spacious/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_style-css' href='https://vitux.com/wp-content/themes/vitux/style.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-genericons-css' href='https://vitux.com/wp-content/themes/spacious/genericons/genericons.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-font-awesome-css' href='https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_googlefonts-css' href='//fonts.googleapis.com/css?family=Lato&#038;ver=5.5.1' type='text/css' media='all' />
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":14628,"token":"096965110a","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/spacious-custom.js?ver=5.5.1' id='spacious-custom-js'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js?ver=5.5.1' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://vitux.com/wp-json/" /><link rel="alternate" type="application/json" href="https://vitux.com/wp-json/wp/v2/posts/14628" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://vitux.com/?p=14628' />
<link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fmemcached_debian%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fmemcached_debian%2F&#038;format=xml" />
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158791751-45";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-158791751-45', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'vitux.com']);
_gaq.push(['f._setDomainName', 'vitux.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod1',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','vitux.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://vitux.com/memcached_debian/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 177389;
var ezdomain = 'vitux.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":177389,"engaged_time_visit":0,"ezcache_level":2,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"2b03f402-2b24-41c2-7008-3c7eae09c3ac","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":3,"serverid":"54.224.219.166:19934","state":"VA","t_epoch":1600622568,"template_id":126,"time_on_site_visit":0,"url":"https://vitux.com/memcached_debian/","user_id":0,"word_count":906,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_177389=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["2b03f402-2b24-41c2-7008-3c7eae09c3ac", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="post-template-default single single-post postid-14628 single-format-standard wp-embed-responsive  better-responsive-menu narrow-1218">
<div id="page" class="hfeed site">
<a class="skip-link screen-reader-text" href="#main">Skip to content</a>
<header id="masthead" class="site-header clearfix spacious-header-display-one">
<div id="header-text-nav-container" class="">
<div class="inner-wrap" id="spacious-header-display-one">
<div id="header-text-nav-wrap" class="clearfix">
<div id="header-left-section">
 <div id="header-text" class="">
<h3 id="site-title">
<a href="https://vitux.com/" title="VITUX" rel="home">VITUX</a>
</h3>
<p id="site-description">Linux Compendium</p>

</div>
</div>
<div id="header-right-section">
<div class="header-action">
</div>
<nav id="site-navigation" class="main-navigation clearfix   " role="navigation">
<p class="menu-toggle">Menu</p>
<div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li>
<li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li>
<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li>
<li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</div>
<div class="header-post-title-container clearfix">
<div class="inner-wrap">
<div class="post-title-wrapper">
<h1 class="header-post-title-class">How to Install Memcached on Debian 10</h1>
</div>
</div>
</div>
</header>
<div id="main" class="clearfix">
<div class="inner-wrap">
<div id="primary">
<div id="content" class="clearfix">
<article id="post-14628" class="post-14628 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-linux category-shell">
<div class="entry-content clearfix">
<p>Memcached is a Linux in-memory cache application. It works as a key-value store that stores the information in-memory only to speed up applications. Many CMS systems like WordPress and Drupal support Memcached to speed up web page delivery. In this article, we will learn how to install Memcached on Debian 10.</p>
<h2>Installing Memcached on Debian 10</h2>
<p>For installing Memcached on Debian 10, you will need to perform the following steps:</p>
<p>We know that most of the operations in the Linux operating system are performed via terminal. Since we are working with Debian 10 which is also a flavor of Linux, therefore, we will need to launch the terminal for installing Memcached on it. For doing that, all we have to do is to click on the Activities tab located on our Debian 10 desktop and then type terminal in the respective search bar. Finally, click on the terminal search result to launch the terminal window as shown in the image below:</p>
<p><img loading="lazy" class="aligncenter wp-image-14629" src="https://vitux.com/wp-content/uploads/word-image-1101.png" alt="Debian Terminal" width="733" height="107" srcset="https://vitux.com/wp-content/uploads/word-image-1101.png 733w, https://vitux.com/wp-content/uploads/word-image-1101-300x44.png 300w" sizes="(max-width: 733px) 100vw, 733px" /></p>
<p>Now you need to update your Debian 10 system so that it is all set to install the Memcached memory caching system on it. For doing that, type the following command in your terminal and then press the Enter key:</p>
<pre>sudo apt update</pre>
<p>This command will take some time to execute as it requires updating all the relevant packages before your actual installation. It is also shown in the following image:</p>
<p><img loading="lazy" class="aligncenter wp-image-14630" src="https://vitux.com/wp-content/uploads/word-image-1102.png" alt="Update packages" width="344" height="26" srcset="https://vitux.com/wp-content/uploads/word-image-1102.png 344w, https://vitux.com/wp-content/uploads/word-image-1102-300x23.png 300w" sizes="(max-width: 344px) 100vw, 344px" /></p>
<p>Once all the necessary packages have been updated, you will be able to see the output shown in the image below on your terminal:</p>
<p><img loading="lazy" class="aligncenter wp-image-14631" src="https://vitux.com/wp-content/uploads/word-image-1103.png" alt="Package lists have been updated" width="670" height="190" srcset="https://vitux.com/wp-content/uploads/word-image-1103.png 670w, https://vitux.com/wp-content/uploads/word-image-1103-300x85.png 300w" sizes="(max-width: 670px) 100vw, 670px" /></p>
<p>Now for installing Memcached on Debian 10, type the following command in your terminal and then press the Enter key:</p>
<pre>sudo apt install memcached libmemcached-tools</pre>
<p>This command will install Memcached along with the libmemcached-tools package which provides all the relevant tools for interacting with this system. This command is shown in the following image:</p>
<p><img loading="lazy" class="aligncenter wp-image-14632" src="https://vitux.com/wp-content/uploads/word-image-1104.png" alt="Install memcached" width="605" height="24" srcset="https://vitux.com/wp-content/uploads/word-image-1104.png 605w, https://vitux.com/wp-content/uploads/word-image-1104-300x12.png 300w" sizes="(max-width: 605px) 100vw, 605px" /></p>
<p>During this process, you will be asked for your consent i.e. whether you want to proceed with this installation or not. Type in “Y” in your terminal and then press the Enter key for providing your consent as shown in the image below:</p>
<p><img loading="lazy" class="aligncenter wp-image-14635" src="https://vitux.com/wp-content/uploads/word-image-1107.png" alt="Installing Memcached" width="667" height="272" srcset="https://vitux.com/wp-content/uploads/word-image-1107.png 667w, https://vitux.com/wp-content/uploads/word-image-1107-300x122.png 300w" sizes="(max-width: 667px) 100vw, 667px" /></p>
<p>Memcached has been successfully installed on your system. Now you need to check if it is working. To do so, you will need to start this service. Type the following command in your terminal and then press the Enter key:</p>
<pre>sudo systemctl start memcached</pre>
<p>This command is also shown in the image below:</p>
<p><img loading="lazy" class="aligncenter wp-image-14637" src="https://vitux.com/wp-content/uploads/word-image-1109.png" alt="Start memcached" width="478" height="27" srcset="https://vitux.com/wp-content/uploads/word-image-1109.png 478w, https://vitux.com/wp-content/uploads/word-image-1109-300x17.png 300w" sizes="(max-width: 478px) 100vw, 478px" /></p>
<p>Once you run this command, the Memcached service will start running and for verifying this, type the following command in your terminal and then press the Enter key:</p>
<pre>sudo systemctl status memcached</pre>
<p>Running this command will reveal the status of the Memcached service.</p>
<p>As soon as this command is executed successfully, you will be able to see that the Memcached service is Active and Running as shown in the image below:</p>
<p><img loading="lazy" class="aligncenter wp-image-14639" src="https://vitux.com/wp-content/uploads/word-image-1111.png" alt="Memcached service status" width="724" height="238" srcset="https://vitux.com/wp-content/uploads/word-image-1111.png 724w, https://vitux.com/wp-content/uploads/word-image-1111-300x99.png 300w" sizes="(max-width: 724px) 100vw, 724px" /></p>
<p>You can also stop this service at any time you want by typing the following command in your terminal and then pressing the Enter key:</p>
<pre>sudo systemctl stop memcached</pre>
<p>When you will run the status command again, you will be able to see that now the status of Memcached service is Inactive and Dead which will indicate that it has stopped running as shown in the image below:</p>
<p><img loading="lazy" class="aligncenter wp-image-14641" src="https://vitux.com/wp-content/uploads/word-image-1113.png" alt="Memcached service stopped" width="724" height="274" srcset="https://vitux.com/wp-content/uploads/word-image-1113.png 724w, https://vitux.com/wp-content/uploads/word-image-1113-300x114.png 300w" sizes="(max-width: 724px) 100vw, 724px" /></p>
<h2>Conclusion</h2>
<p>By following the simple method explained in this article, you can easily install and enable the Memcached service on Debian 10 and hence you can improve the performance of the applications that you run on your Debian 10 system.</p>
<div class="extra-hatom-entry-title"><span class="entry-title">How to Install Memcached on Debian 10</span></div> </div>
<footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix">
<span class="by-author author vcard"><a class="url fn n" href="https://vitux.com/author/karim/">Karim Buzdar</a></span>
<span class="date"><a href="https://vitux.com/memcached_debian/" title="4:10 pm" rel="bookmark"><time class="entry-date published" datetime="2020-09-18T16:10:01+00:00">September 18, 2020</time><time class="updated" datetime="2020-09-18T16:16:20+00:00">September 18, 2020</time></a></span> <span class="category"><a href="https://vitux.com/debian/" rel="category tag">Debian</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span>
</div></footer>
</article>
<ul class="default-wp-page clearfix">
<li class="previous"><a href="https://vitux.com/how-to-install-viber-messenger-app-on-ubuntu-20-04-lts/" rel="prev"><span class="meta-nav">&larr;</span> How to Install Viber Messenger App on Ubuntu 20.04 LTS</a></li>
<li class="next"></li>
</ul>
<div class="author-box clearfix">
<div class="author-img"><img src="https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=100&#038;d=mm&#038;r=g" width="100" height="100" alt="Avatar" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /></div>
<div class="author-description-wrapper">
<h4 class="author-name">Karim Buzdar</h4>
<p class="author-description">About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. You can reach Karim on <a href="https://www.linkedin.com/in/karimbuzdar/" rel="nofollow">LinkedIn</a></p>
</div>
</div>
</div>
</div>
<div id="secondary">
<aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get">
<div class="search-wrap">
<input type="text" placeholder="Search" class="s field" name="s">
<button class="search-icon" type="submit"></button>
</div>
</form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3> <div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p>
</div>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="navDiv">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3536364066785075" data-ad-slot="6537400998" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></aside>
<aside id="wpp-5" class="widget popular-posts">
<h3 class="widget-title"><span>Most Popular</span></h3>

<ul class="wpp-list">
<li>
<a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 22, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/5-ways-to-check-available-memory-in-ubuntu/" class="wpp-post-title" target="_self">5 Ways to Check Available Memory in Ubuntu 20.04</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on April 30, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/find-devices-connected-to-your-network-with-nmap/" class="wpp-post-title" target="_self">Find Devices Connected to Your Network with nmap</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on November 30, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-setup-java_home-path-in-ubuntu/" class="wpp-post-title" target="_self">How to Set JAVA_HOME Path in Ubuntu 18.04 LTS</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 23, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-find-files-on-the-ubuntu-command-line/" class="wpp-post-title" target="_self">How to find files on the Ubuntu command line</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on June 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-configure-networking-with-netplan-on-ubuntu/" class="wpp-post-title" target="_self">How to configure networking with Netplan on Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on June 3, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 26, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-install-wine-on-ubuntu/" class="wpp-post-title" target="_self">How to Install Wine on Ubuntu 20.04 LTS</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on August 10, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
</ul>
</aside>
</div>
</div>
</div>
<footer id="colophon" class="clearfix">
<div class="footer-socket-wrapper clearfix">
<div class="inner-wrap">
<div class="footer-socket-area">
Copyright &copy; <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</footer>
<a href="#masthead" id="scroll-up"></a>
</div>

<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');
		</script>
<script>
	(function(){
	  if(typeof _bsa !== 'undefined' && _bsa) {
	    _bsa.init('fancybar', 'CE7I6KQJ', 'placement:vituxcom');
	  }
	})();
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/navigation.js?ver=5.5.1' id='spacious-navigation-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/skip-link-focus-fix.js?ver=5.5.1' id='spacious-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/wp-embed.min.js?ver=5.5.1' id='wp-embed-js'></script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="vitux_com",_audins_did=177389;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.vitux_com,DomainId.177389" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
