<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=192-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=192-2&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=192-2&cb=5', false, [], true, false, true, false);</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />

<title>How to change the MAC Address on CentOS 8</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://vitux.com/centos_mac_address/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to change the MAC Address on CentOS 8" />
<meta property="og:description" content="If you don’t want to expose your device MAC address while connecting to Public WIFI’s or maybe the firewall or router blocked the specific MAC address, changing of MAC address to access internet service without being exposing the original MAC" />
<meta property="og:url" content="https://vitux.com/centos_mac_address/" />
<meta property="og:site_name" content="VITUX" />
<meta property="article:publisher" content="https://www.facebook.com/vituxcom/" />
<meta property="article:published_time" content="2020-06-09T13:04:13+00:00" />
<meta property="article:modified_time" content="2021-02-26T11:29:39+00:00" />
<meta property="og:image" content="https://vitux.com/wp-content/uploads/centos-mac-address.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="512" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@vituxcom" />
<meta name="twitter:site" content="@vituxcom" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Karim Buzdar">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="4 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","potentialAction":[{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vitux.com/centos_mac_address/#primaryimage","inLanguage":"en-US","url":"https://vitux.com/wp-content/uploads/centos-mac-address.jpg","width":1024,"height":512,"caption":"CentOS MAC Address change"},{"@type":"WebPage","@id":"https://vitux.com/centos_mac_address/#webpage","url":"https://vitux.com/centos_mac_address/","name":"How to change the MAC Address on CentOS 8","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/centos_mac_address/#primaryimage"},"datePublished":"2020-06-09T13:04:13+00:00","dateModified":"2021-02-26T11:29:39+00:00","author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"breadcrumb":{"@id":"https://vitux.com/centos_mac_address/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vitux.com/centos_mac_address/"]}]},{"@type":"BreadcrumbList","@id":"https://vitux.com/centos_mac_address/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://vitux.com/","url":"https://vitux.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://vitux.com/centos_mac_address/","url":"https://vitux.com/centos_mac_address/","name":"How to change the MAC Address on CentOS 8"}}]},{"@type":"Person","@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","image":{"@type":"ImageObject","@id":"https://vitux.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=96&d=mm&r=g","caption":"Karim Buzdar"},"description":"About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. He blogs at LinuxWays."}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/vitux.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://vitux.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://vitux.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://vitux.com/wp-content/themes/spacious/style.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_style-css' href='https://vitux.com/wp-content/themes/vitux/style.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-genericons-css' href='https://vitux.com/wp-content/themes/spacious/genericons/genericons.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-font-awesome-css' href='https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_googlefonts-css' href='//fonts.googleapis.com/css?family=Lato&#038;ver=1.9.1' type='text/css' media='all' />
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":13276,"token":"b1ec6f11b1","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/spacious-custom.js?ver=5.6.2' id='spacious-custom-js'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js?ver=5.6.2' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://vitux.com/wp-json/" /><link rel="alternate" type="application/json" href="https://vitux.com/wp-json/wp/v2/posts/13276" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://vitux.com/?p=13276' />
<link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fcentos_mac_address%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fcentos_mac_address%2F&#038;format=xml" />
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://vitux.com/centos_mac_address/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 177389;
var ezdomain = 'vitux.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":177389,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"405060bc-71a4-4dc3-4e12-c4ea3e1a925d","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":30850,"response_time_orig":2,"serverid":"3.80.92.7:8752","state":"VA","t_epoch":1614460917,"template_id":126,"time_on_site_visit":0,"url":"https://vitux.com/centos_mac_address/","user_id":0,"word_count":735,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?dcb=192-2&cb=2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_177389=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["405060bc-71a4-4dc3-4e12-c4ea3e1a925d", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="post-template-default single single-post postid-13276 single-format-standard wp-embed-responsive  better-responsive-menu narrow-1218">
<div id="page" class="hfeed site">
<a class="skip-link screen-reader-text" href="#main">Skip to content</a>
<header id="masthead" class="site-header clearfix spacious-header-display-one">
<div id="header-text-nav-container" class="">
<div class="inner-wrap" id="spacious-header-display-one">
<div id="header-text-nav-wrap" class="clearfix">
<div id="header-left-section">
<div id="header-text" class="">
<h3 id="site-title">
<a href="https://vitux.com/" title="VITUX" rel="home">VITUX</a>
</h3>
<p id="site-description">Linux Compendium</p>

</div>
</div>
<div id="header-right-section">
<div class="header-action">
</div>
<nav id="site-navigation" class="main-navigation clearfix   " role="navigation">
<p class="menu-toggle">
<span class="screen-reader-text">Menu </p>
<div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li>
<li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li>
<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li>
<li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</div>
<div class="header-post-title-container clearfix">
<div class="inner-wrap">
<div class="post-title-wrapper">
<h1 class="header-post-title-class">How to change the MAC Address on CentOS 8</h1>
</div>
</div>
</div>
</header>
<div id="main" class="clearfix">
<div class="inner-wrap">
<div id="primary">
<div id="content" class="clearfix">
<article id="post-13276" class="post-13276 post type-post status-publish format-standard has-post-thumbnail hentry category-centos category-linux category-shell">
<div class="entry-content clearfix">
<p>If you don’t want to expose your device MAC address while connecting to Public WIFI’s or maybe the firewall or router blocked the specific MAC address, changing of MAC address to access internet service without being exposing the original MAC address. Changing of MAC address is also known as MAC Spoofing or FAKE address. In this tutorial, we will learn how to change the MAC address in CentOS8.</p>
<h2>Find the MAC Address on CentOS</h2>
<p>To find out the MAC address or hardware address of a network interface, open the terminal and use anyone of the following command.</p>
<pre># ip link show</pre>
<p><img loading="lazy" class="aligncenter wp-image-13277" src="https://vitux.com/wp-content/uploads/word-image-418.png" alt="ip link show" width="299" height="29" /></p>
<pre># ifconfig | grep ether</pre>
<p><img loading="lazy" class="aligncenter wp-image-13278" src="https://vitux.com/wp-content/uploads/word-image-419.png" alt="ifconfig | grep ether" width="423" height="24" srcset="https://vitux.com/wp-content/uploads/word-image-419.png 423w, https://vitux.com/wp-content/uploads/word-image-419-300x17.png 300w" sizes="(max-width: 423px) 100vw, 423px" /></p>
<p>These commands will display the hardware address of your network interface card. Sample output is attached below for reference.</p>
<p><img loading="lazy" class="aligncenter wp-image-13279" src="https://vitux.com/wp-content/uploads/word-image-420.png" alt="MAC Address" width="591" height="36" srcset="https://vitux.com/wp-content/uploads/word-image-420.png 591w, https://vitux.com/wp-content/uploads/word-image-420-300x18.png 300w" sizes="(max-width: 591px) 100vw, 591px" /></p>
<h2>Changing the MAC Address</h2>
<p>We can do this in two methods. Please be careful not to change your mac address with the live network card. If you do this, it will disconnect your network connection. Use this method with an additional network card.</p>
<h3>Method 1: using IPRoute2</h3>
<p>To change the MAC address of a network card, you have to turn off that network card. Navigate to the terminal and use the following command.</p>
<pre># sudo ip link set dev ens37 down</pre>
<p><img loading="lazy" class="aligncenter wp-image-13280" src="https://vitux.com/wp-content/uploads/word-image-421.png" alt="Shutdown network card" width="486" height="23" srcset="https://vitux.com/wp-content/uploads/word-image-421.png 486w, https://vitux.com/wp-content/uploads/word-image-421-300x14.png 300w" sizes="(max-width: 486px) 100vw, 486px" /></p>
<p>the word ens37 is the device name of the network card, it might differ on your system. So adjust the command to match your network card device name. Do the same in the following commands.</p>
<p>Next, assign the MAC address of your own choice using the following command.</p>
<pre># sudo ip link set dev ens37 address XX:XX:XX:XX:XX:XX</pre>
<p><img loading="lazy" class="aligncenter wp-image-13281" src="https://vitux.com/wp-content/uploads/word-image-422.png" alt="ip link set dev" width="648" height="21" srcset="https://vitux.com/wp-content/uploads/word-image-422.png 648w, https://vitux.com/wp-content/uploads/word-image-422-300x10.png 300w, https://vitux.com/wp-content/uploads/word-image-422-642x21.png 642w" sizes="(max-width: 648px) 100vw, 648px" /></p>
<p>Finally, turn on the interface with the following command.</p>
<pre># sudo ip link set dev ens37 up</pre>
<p><img loading="lazy" class="aligncenter wp-image-13282" src="https://vitux.com/wp-content/uploads/word-image-423.png" alt="Enable network card" width="448" height="27" srcset="https://vitux.com/wp-content/uploads/word-image-423.png 448w, https://vitux.com/wp-content/uploads/word-image-423-300x18.png 300w" sizes="(max-width: 448px) 100vw, 448px" /></p>
<p>Now, verify the new MAC address by using the following command.</p>
<pre># ip link show ens37</pre>
<p><img loading="lazy" class="aligncenter wp-image-13283" src="https://vitux.com/wp-content/uploads/word-image-424.png" alt="show network card details" width="726" height="74" srcset="https://vitux.com/wp-content/uploads/word-image-424.png 726w, https://vitux.com/wp-content/uploads/word-image-424-300x31.png 300w" sizes="(max-width: 726px) 100vw, 726px" /></p>
<p>New MAC address has assigned successfully.</p>
<h3>Method 2: using the network configuration file</h3>
<p>You can also change the MAC address from the configuration file, for this open up the configuration file of that specific interface.</p>
<pre># sudo vim /etc/sysconfig/network-scripts/ifcfg-ens37</pre>
<p><img loading="lazy" class="aligncenter wp-image-13284" src="https://vitux.com/wp-content/uploads/word-image-425.png" alt="Edit network config file" width="670" height="29" srcset="https://vitux.com/wp-content/uploads/word-image-425.png 670w, https://vitux.com/wp-content/uploads/word-image-425-300x13.png 300w, https://vitux.com/wp-content/uploads/word-image-425-642x29.png 642w" sizes="(max-width: 670px) 100vw, 670px" /></p>
<p>Add/Edit the <strong>MACADDR </strong>according to your own MAC address.</p>
<p><img loading="lazy" class="aligncenter wp-image-13285" src="https://vitux.com/wp-content/uploads/word-image-426.png" alt="Network card configuration" width="380" height="293" srcset="https://vitux.com/wp-content/uploads/word-image-426.png 380w, https://vitux.com/wp-content/uploads/word-image-426-300x231.png 300w" sizes="(max-width: 380px) 100vw, 380px" /></p>
<p>Exit and save the configuration file and restart the network, using the following command.</p>
<pre># sudo systemctl restart network</pre>
<p><img loading="lazy" class="aligncenter wp-image-13286" src="https://vitux.com/wp-content/uploads/word-image-427.png" alt="Restart network" width="461" height="26" srcset="https://vitux.com/wp-content/uploads/word-image-427.png 461w, https://vitux.com/wp-content/uploads/word-image-427-300x17.png 300w" sizes="(max-width: 461px) 100vw, 461px" /></p>
<p>Again, verify the new MAC address.</p>
<h2>Conclusion</h2>
<p>In this tutorial, we learned how to change the MAC address of a network card using two different methods and after changing we also verify that new MAC address.</p>
<div class="extra-hatom-entry-title"><span class="entry-title">How to change the MAC Address on CentOS 8</span></div> </div>
<footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix">
<span class="by-author author vcard"><a class="url fn n" href="https://vitux.com/author/karim/">Karim Buzdar</a></span>
<span class="date"><a href="https://vitux.com/centos_mac_address/" title="1:04 pm" rel="bookmark"><time class="entry-date published" datetime="2020-06-09T13:04:13+00:00">June 9, 2020</time><time class="updated" datetime="2021-02-26T11:29:39+00:00">February 26, 2021</time></a></span> <span class="category"><a href="https://vitux.com/centos/" rel="category tag">CentOS</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span>
</div></footer>
</article>
<ul class="default-wp-page clearfix">
<li class="previous"><a href="https://vitux.com/how-to-generate-ssh-key-in-centos/" rel="prev"><span class="meta-nav">&larr;</span> How to Generate an SSH Key in CentOS 8</a></li>
<li class="next"><a href="https://vitux.com/use-ctrlaltdelete-for-shutting-down-instead-of-logging-out-on-debian/" rel="next">Use Ctrl+Alt+Delete for shutting down instead of logging out on Debian <span class="meta-nav">&rarr;</span></a></li>
</ul>
<div class="author-box clearfix">
<div class="author-img"><img src="https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=100&#038;d=mm&#038;r=g" width="100" height="100" alt="Avatar" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /></div>
<div class="author-description-wrapper">
<h4 class="author-name">Karim Buzdar</h4>
<p class="author-description">About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. He blogs at <a href="https://www.linuxways.net/" rel="nofollow">LinuxWays</a>.</p>
</div>
</div>
</div>
</div>
<div id="secondary">
<aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get">
<div class="search-wrap">
<input type="text" placeholder="Search" class="s field" name="s">
<button class="search-icon" type="submit"></button>
</div>
</form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3> <div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p>
</div>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="navDiv">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3536364066785075" data-ad-slot="6537400998" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></aside>
<aside id="wpp-5" class="widget popular-posts">
<h3 class="widget-title"><span>Most Popular</span></h3>

<ul class="wpp-list">
<li>
<a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 22, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-find-files-on-the-ubuntu-command-line/" class="wpp-post-title" target="_self">How to find files on the Ubuntu command line</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on June 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-setup-java_home-path-in-ubuntu/" class="wpp-post-title" target="_self">How to Set JAVA_HOME Path in Ubuntu 18.04 and 20.04 LTS</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 23, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/find-devices-connected-to-your-network-with-nmap/" class="wpp-post-title" target="_self">Find Devices Connected to Your Network with nmap</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on November 30, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/5-ways-to-check-available-memory-in-ubuntu/" class="wpp-post-title" target="_self">5 Ways to Check Available Memory in Ubuntu 20.04</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on April 30, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-manually-mount-unmount-a-usb-device-on-ubuntu/" class="wpp-post-title" target="_self">How to Manually Mount/UnMount a USB Device on Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on September 19, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/3-ways-to-reboot-ubuntu-through-the-command-line/" class="wpp-post-title" target="_self">3 Ways to Reboot Ubuntu through the Command Line</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on May 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-start-stop-or-restart-services-in-ubuntu/" class="wpp-post-title" target="_self">How to Start, Stop or Restart Services in Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on April 18, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
</ul>
</aside>
</div>
</div>
</div>
<footer id="colophon" class="clearfix">
<div class="footer-socket-wrapper clearfix">
<div class="inner-wrap">
<div class="footer-socket-area">
Copyright &copy; <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</footer>
<a href="#masthead" id="scroll-up"></a>
</div>

<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');
		</script>
<script>
	(function(){
	  if(typeof _bsa !== 'undefined' && _bsa) {
	    _bsa.init('fancybar', 'CE7I6KQJ', 'placement:vituxcom');
	  }
	})();
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/navigation.js?ver=5.6.2' id='spacious-navigation-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/skip-link-focus-fix.js?ver=5.6.2' id='spacious-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="vitux_com",_audins_did=177389;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=192-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.vitux_com,DomainId.177389" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script></body>
</html>
