<!DOCTYPE html><!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]--><!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]--><!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"><!--<![endif]--><head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-2&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-2&cb=5', false, [], true, false, true, false);</script>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<meta name="robots" content="index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1" />

<title>How to install the LAMP Stack on CentOS 8</title>
<link rel="canonical" href="https://vitux.com/how-to-install-lamp-on-centos/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to install the LAMP Stack on CentOS 8" />
<meta property="og:description" content="LAMP is an acronym of Linux, Apache, MySQL, and PHP. It is a free and open-source stack used by developers and website administrators to test and host their Web applications. It comes up with 4 components which are Apache (used" />
<meta property="og:url" content="https://vitux.com/how-to-install-lamp-on-centos/" />
<meta property="og:site_name" content="VITUX" />
<meta property="article:publisher" content="https://www.facebook.com/vituxcom/" />
<meta property="article:published_time" content="2021-04-21T07:48:38+00:00" />
<meta property="article:modified_time" content="2021-04-21T08:51:02+00:00" />
<meta property="og:image" content="https://vitux.com/wp-content/uploads/centos-lamp.png" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="512" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@vituxcom" />
<meta name="twitter:site" content="@vituxcom" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Karim Buzdar" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="5 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","potentialAction":[{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vitux.com/how-to-install-lamp-on-centos/#primaryimage","inLanguage":"en-US","url":"https://vitux.com/wp-content/uploads/centos-lamp.png","contentUrl":"https://vitux.com/wp-content/uploads/centos-lamp.png","width":1024,"height":512,"caption":"CentOS LAMP Server"},{"@type":"WebPage","@id":"https://vitux.com/how-to-install-lamp-on-centos/#webpage","url":"https://vitux.com/how-to-install-lamp-on-centos/","name":"How to install the LAMP Stack on CentOS 8","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/how-to-install-lamp-on-centos/#primaryimage"},"datePublished":"2021-04-21T07:48:38+00:00","dateModified":"2021-04-21T08:51:02+00:00","author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"breadcrumb":{"@id":"https://vitux.com/how-to-install-lamp-on-centos/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vitux.com/how-to-install-lamp-on-centos/"]}]},{"@type":"BreadcrumbList","@id":"https://vitux.com/how-to-install-lamp-on-centos/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://vitux.com/","url":"https://vitux.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://vitux.com/how-to-install-lamp-on-centos/","url":"https://vitux.com/how-to-install-lamp-on-centos/","name":"How to install the LAMP Stack on CentOS 8"}}]},{"@type":"Person","@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","image":{"@type":"ImageObject","@id":"https://vitux.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/964e511208f8959f5043ba3045bb4db0?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/964e511208f8959f5043ba3045bb4db0?s=96&d=mm&r=g","caption":"Karim Buzdar"},"description":"About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. You can reach Karim on LinkedIn"}]}</script>

<link rel="dns-prefetch" href="//fonts.googleapis.com" />
<link rel="dns-prefetch" href="//s.w.org" />
<link rel="alternate" type="application/rss+xml" title="VITUX » Feed" href="https://vitux.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="VITUX » Comments Feed" href="https://vitux.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/vitux.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="stylesheet" id="wp-block-library-css" href="https://vitux.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.1" type="text/css" media="all" />
<link rel="stylesheet" id="wp-block-library-theme-css" href="https://vitux.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.7.1" type="text/css" media="all" />
<link rel="stylesheet" id="wp-pagenavi-css" href="https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70" type="text/css" media="all" />
<link rel="stylesheet" id="wordpress-popular-posts-css-css" href="https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.3.1" type="text/css" media="all" />
<link rel="stylesheet" id="parent-style-css" href="https://vitux.com/wp-content/themes/spacious/style.css?ver=5.7.1" type="text/css" media="all" />
<link rel="stylesheet" id="spacious_style-css" href="https://vitux.com/wp-content/themes/vitux/style.css?ver=5.7.1" type="text/css" media="all" />
<link rel="stylesheet" id="spacious-genericons-css" href="https://vitux.com/wp-content/themes/spacious/genericons/genericons.css?ver=3.3.1" type="text/css" media="all" />
<link rel="stylesheet" id="spacious-font-awesome-css" href="https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css?ver=4.7.0" type="text/css" media="all" />
<link rel="stylesheet" id="spacious_googlefonts-css" href="//fonts.googleapis.com/css?family=Lato&amp;ver=1.9.2" type="text/css" media="all" />
<script type="application/json" id="wpp-json">
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":12844,"token":"9cada45f0e","lang":0,"debug":0}
</script>
<script type="text/javascript" src="https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.3.1" id="wpp-js-js"></script>
<script type="text/javascript" src="https://vitux.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1" id="jquery-core-js"></script>
<script type="text/javascript" src="https://vitux.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2" id="jquery-migrate-js"></script>
<script type="text/javascript" src="https://vitux.com/wp-content/themes/spacious/js/spacious-custom.js?ver=5.7.1" id="spacious-custom-js"></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js?ver=5.7.1' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://vitux.com/wp-json/" /><link rel="alternate" type="application/json" href="https://vitux.com/wp-json/wp/v2/posts/12844" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.1" />
<link rel="shortlink" href="https://vitux.com/?p=12844" />
<link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-install-lamp-on-centos%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-install-lamp-on-centos%2F&amp;format=xml" />
<style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://vitux.com/how-to-install-lamp-on-centos/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 177389;
var ezdomain = 'vitux.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":177389,"domain_test_group":20210301,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"77740579-db5c-47e8-7a4d-da6ac8a211d3","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":29730,"response_time_orig":5,"serverid":"3.83.218.150:22634","state":"VA","t_epoch":1619027632,"template_id":126,"time_on_site_visit":0,"url":"https://vitux.com/how-to-install-lamp-on-centos/","user_id":0,"word_count":791,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_177389=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["77740579-db5c-47e8-7a4d-da6ac8a211d3", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="post-template-default single single-post postid-12844 single-format-standard wp-embed-responsive  better-responsive-menu narrow-1218">
<div id="page" class="hfeed site">
<a class="skip-link screen-reader-text" href="#main">Skip to content</a>
<header id="masthead" class="site-header clearfix spacious-header-display-one">
<div id="header-text-nav-container" class="">
<div class="inner-wrap" id="spacious-header-display-one">
<div id="header-text-nav-wrap" class="clearfix">
<div id="header-left-section">
<div id="header-text" class="">
<h3 id="site-title">
<a href="https://vitux.com/" title="VITUX" rel="home">VITUX</a>
</h3>
<p id="site-description">Linux Compendium</p>

</div>
</div>
<div id="header-right-section">
<div class="header-action">
</div>
<nav id="site-navigation" class="main-navigation clearfix   " role="navigation">
<p class="menu-toggle">
<span class="screen-reader-text">Menu</span>
</p>
<div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li>
<li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li>
<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li>
<li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</div>
<div class="header-post-title-container clearfix">
<div class="inner-wrap">
<div class="post-title-wrapper">
<h1 class="header-post-title-class">How to install the LAMP Stack on CentOS 8</h1>
</div>
</div>
</div>
</header>
<div id="main" class="clearfix">
<div class="inner-wrap">
<div id="primary">
<div id="content" class="clearfix">
<article id="post-12844" class="post-12844 post type-post status-publish format-standard has-post-thumbnail hentry category-centos category-linux category-shell">
<div class="entry-content clearfix">
<p>LAMP is an acronym of Linux, Apache, MySQL, and PHP. It is a free and open-source stack used by developers and website administrators to test and host their Web applications. It comes up with 4 components which are Apache (used for hosting a website), MySQL or MariaDB, and PHP – a popular scripting language used to create dynamic web pages. MariaDB or MYSQL are used to store and manage the data.</p>
<p>In this tutorial, we will learn how to install a LAMP Server on CentOS 8. So, let’s get started.</p>
<h2>CentOS LAMP Installation</h2>
<p>Before installation, keep your Systems Packages repository updated. For this, open up the terminal and use the following command:</p>
<pre># sudo dnf update</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-12873" src="https://vitux.com/wp-content/uploads/word-image-99.png" alt="Update package lists" width="327" height="24" srcset="https://vitux.com/wp-content/uploads/word-image-99.png 327w, https://vitux.com/wp-content/uploads/word-image-99-300x22.png 300w" sizes="(max-width: 327px) 100vw, 327px" /></strong></p>
<h3>Installing Apache Web Server on CentOS8</h3>
<p>After updating the system packages, the next step is to install the Apache Web Server and its tools, for this run the following command:</p>
<pre># sudo dnf install –y httpd httpd-tools</pre>
<p><img loading="lazy" class="aligncenter wp-image-12874" src="https://vitux.com/wp-content/uploads/word-image-100.png" alt="Install Apache web server with dnf package manager" width="567" height="30" srcset="https://vitux.com/wp-content/uploads/word-image-100.png 567w, https://vitux.com/wp-content/uploads/word-image-100-300x16.png 300w" sizes="(max-width: 567px) 100vw, 567px" /></p>
<p>Once the installation is completed, enable and start the Apache service by running the following command:</p>
<pre># systemctl start httpd
# systemctl enable httpd</pre>
<p>To verify the service is running, run the following command:</p>
<pre># systemctl status httpd</pre>
<p><img loading="lazy" class="aligncenter wp-image-12875" src="https://vitux.com/wp-content/uploads/word-image-101.png" alt="Apache is up and running" width="745" height="274" srcset="https://vitux.com/wp-content/uploads/word-image-101.png 745w, https://vitux.com/wp-content/uploads/word-image-101-300x110.png 300w" sizes="(max-width: 745px) 100vw, 745px" /></p>
<p>As you can see that see Apache web service is running.</p>
<h3>Configure CentOS Firewall</h3>
<p>After installing Apache, update the firewall rules to allow requests for this use the following command:</p>
<pre># sudo firewall-cmd –add-service=http/tcp –permanent
# sudo firewall-cmd –add-service-https/tcp –permanent
# sudo firewall-cmd –reload</pre>
<p>Additionally, you can open up a web browser and test your Web Services by typing <strong>IP address or localhost</strong> as shown below.</p>
<p><img loading="lazy" class="aligncenter wp-image-12876" src="https://vitux.com/wp-content/uploads/word-image-102.png" alt="Apache test page" width="787" height="442" srcset="https://vitux.com/wp-content/uploads/word-image-102.png 787w, https://vitux.com/wp-content/uploads/word-image-102-300x168.png 300w, https://vitux.com/wp-content/uploads/word-image-102-768x431.png 768w" sizes="(max-width: 787px) 100vw, 787px" /></p>
<p>Now we have the Web server installed and running.</p>
<h3>Installing MariaDB on CentOS 8</h3>
<p>The next step is to install the Maria DB to store data and manage data for the website, for this use the following command:</p>
<pre># sudo dnf install –y mariadb-server mariadb</pre>
<p><img loading="lazy" class="aligncenter wp-image-12877" src="https://vitux.com/wp-content/uploads/word-image-103.png" alt="Install MariaDB" width="602" height="30" srcset="https://vitux.com/wp-content/uploads/word-image-103.png 602w, https://vitux.com/wp-content/uploads/word-image-103-300x15.png 300w" sizes="(max-width: 602px) 100vw, 602px" /></p>
<p>Once the installation is completed, enable and start the Maria DB service by running the following command:</p>
<pre># systemctl enable mariadb
# systemctl start mariadb</pre>
<p>To verify the service is running, use the following command:</p>
<pre># systemctl status mariadb</pre>
<p><img loading="lazy" class="aligncenter wp-image-12878" src="https://vitux.com/wp-content/uploads/word-image-104.png" alt="MariaDB Status" width="730" height="271" srcset="https://vitux.com/wp-content/uploads/word-image-104.png 730w, https://vitux.com/wp-content/uploads/word-image-104-300x111.png 300w" sizes="(max-width: 730px) 100vw, 730px" /></p>
<p>As you can see above that MariaDB is running.</p>
<p>To improve the security of the database, it’s recommended to run a security script that comes up with the MariaDB. It will remove the insecure default settings and lock the access of your database. To secure <strong>MariaDB </strong>by running the following command:</p>
<pre># mysql_secure_installation</pre>
<p>It will prompt you to enter the root password or set it up, therefore, answer “Y” for every subsequent prompt.</p>
<p><img loading="lazy" class="aligncenter wp-image-12879" src="https://vitux.com/wp-content/uploads/word-image-105.png" alt="Secure MariaDB" width="434" height="35" srcset="https://vitux.com/wp-content/uploads/word-image-105.png 434w, https://vitux.com/wp-content/uploads/word-image-105-300x24.png 300w" sizes="(max-width: 434px) 100vw, 434px" /></p>
<h3>Installing PHP on CentOS 8</h3>
<p>The last component in the LAMP stack is PHP, I already mentioned that PHP is used to create a dynamic web page, to install PHP using the following command:</p>
<pre># sudo dnf install –y php php-mysqlnd</pre>
<p><img loading="lazy" class="aligncenter wp-image-12880" src="https://vitux.com/wp-content/uploads/word-image-106.png" alt="Install PHP" width="528" height="35" srcset="https://vitux.com/wp-content/uploads/word-image-106.png 528w, https://vitux.com/wp-content/uploads/word-image-106-300x20.png 300w" sizes="(max-width: 528px) 100vw, 528px" /></p>
<h3>Testing the PHP</h3>
<p>To test the PHP create a page under <strong>/var/www/html/</strong> directory (default directory). Insert the code as shown below:</p>
<p><img loading="lazy" class="aligncenter wp-image-12881" src="https://vitux.com/wp-content/uploads/word-image-107.png" alt="Test PHP file - phpinfo" width="467" height="35" srcset="https://vitux.com/wp-content/uploads/word-image-107.png 467w, https://vitux.com/wp-content/uploads/word-image-107-300x22.png 300w" sizes="(max-width: 467px) 100vw, 467px" /></p>
<pre>&lt;?php

phpinfo (); // it will print the PHP Information that we have installed

?&gt;</pre>
<p>Need to instruct SELinux to execute PHP code, for this use the following command:</p>
<pre># setsebool –P httpd_execmem 1</pre>
<p>Finally restart the httpd service.</p>
<pre># systemctl restart httpd</pre>
<p>Now open the web browser and type the IP address of your server on the search bar. You will get the output like shown below:</p>
<pre>http://&lt;ip-address&gt;/info.php</pre>
<p><img loading="lazy" class="aligncenter wp-image-12882" src="https://vitux.com/wp-content/uploads/word-image-108.png" alt="PHP tested successfully" width="786" height="475" srcset="https://vitux.com/wp-content/uploads/word-image-108.png 786w, https://vitux.com/wp-content/uploads/word-image-108-300x181.png 300w, https://vitux.com/wp-content/uploads/word-image-108-768x464.png 768w" sizes="(max-width: 786px) 100vw, 786px" /></p>
<p>We have PHP version 7.2.11 is installed and we can see PHP complete information on the web page.</p>
<h2>Conclusion</h2>
<p>In this tutorial, we learned how to set up LAMP Server with its component Apache, MariaDB, and PHP on CentOS 8. We also see how to handle PHP requests. I hope this tutorial will help you to set up a LAMP Server.</p>
<div class="extra-hatom-entry-title"><span class="entry-title">How to install the LAMP Stack on CentOS 8</span></div> </div>
<footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix">
<span class="by-author author vcard"><a class="url fn n" href="https://vitux.com/author/karim/">Karim Buzdar</a></span>
<span class="date"><a href="https://vitux.com/how-to-install-lamp-on-centos/" title="7:48 am" rel="bookmark"><time class="entry-date published" datetime="2021-04-21T07:48:38+00:00">April 21, 2021</time><time class="updated" datetime="2021-04-21T08:51:02+00:00">April 21, 2021</time></a></span> <span class="category"><a href="https://vitux.com/centos/" rel="category tag">CentOS</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span>
</div></footer>
</article>
<ul class="default-wp-page clearfix">
<li class="previous"><a href="https://vitux.com/how-to-write-a-shell-script-in-ubuntu/" rel="prev"><span class="meta-nav">←</span> How to Write a Shell Script in Ubuntu 20.04 LTS</a></li>
<li class="next"><a href="https://vitux.com/3-ways-to-shut-down-power-off-your-ubuntu-system/" rel="next">3 Ways to Shut Down/Power Off your Ubuntu system <span class="meta-nav">→</span></a></li>
</ul>
<div class="author-box clearfix">
<div class="author-img"><img src="https://secure.gravatar.com/avatar/964e511208f8959f5043ba3045bb4db0?s=100&amp;d=mm&amp;r=g" width="100" height="100" alt="Avatar" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /></div>
<div class="author-description-wrapper">
<h4 class="author-name">Karim Buzdar</h4>
<p class="author-description">About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. You can reach Karim on <a href="https://www.linkedin.com/in/karimbuzdar/" rel="nofollow">LinkedIn</a></p>
</div>
</div>
</div>
</div>
<div id="secondary">
<aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get">
<div class="search-wrap">
<input type="text" placeholder="Search" class="s field" name="s" />
<button class="search-icon" type="submit"></button>
</div>
</form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3> <div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p>
</div>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="navDiv">
<script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3536364066785075" data-ad-slot="6537400998" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></aside>
<aside id="recent-posts-3" class="widget widget_recent_entries">
<h3 class="widget-title"><span>Latest Tutorials</span></h3>
<ul>
<li>
<a href="https://vitux.com/3-ways-to-shut-down-power-off-your-ubuntu-system/">3 Ways to Shut Down/Power Off your Ubuntu system</a>
</li>
<li>
<a href="https://vitux.com/how-to-install-lamp-on-centos/" aria-current="page">How to install the LAMP Stack on CentOS 8</a>
</li>
<li>
<a href="https://vitux.com/how-to-write-a-shell-script-in-ubuntu/">How to Write a Shell Script in Ubuntu 20.04 LTS</a>
</li>
<li>
<a href="https://vitux.com/how-to-change-text-size-in-ubuntu/">How to change Text Size in Ubuntu 20.04 LTS</a>
</li>
<li>
<a href="https://vitux.com/how-to-install-idle-python-ide-on-ubuntu/">How to Install IDLE Python IDE on Ubuntu 20.04</a>
</li>
</ul>
</aside> </div>
</div>
</div>
<footer id="colophon" class="clearfix">
<div class="footer-socket-wrapper clearfix">
<div class="inner-wrap">
<div class="footer-socket-area">
Copyright © <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</footer>
<a href="#masthead" id="scroll-up"></a>
</div>

<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');
		</script>
<script>
	(function(){
	  if(typeof _bsa !== 'undefined' && _bsa) {
	    _bsa.init('fancybar', 'CE7I6KQJ', 'placement:vituxcom');
	  }
	})();
</script>
<script type="text/javascript" src="https://vitux.com/wp-content/themes/spacious/js/navigation.js?ver=5.7.1" id="spacious-navigation-js"></script>
<script type="text/javascript" src="https://vitux.com/wp-content/themes/spacious/js/skip-link-focus-fix.js?ver=5.7.1" id="spacious-skip-link-focus-fix-js"></script>
<script type="text/javascript" src="https://vitux.com/wp-includes/js/wp-embed.min.js?ver=5.7.1" id="wp-embed-js"></script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="vitux_com",_audins_did=177389;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.vitux_com,DomainId.177389" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=2&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script></body></html>