<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><title>How to set up a ZFS storage pool on Ubuntu</title><!-- This site is optimized with the Yoast SEO plugin v11.9 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to set up a ZFS storage pool on Ubuntu" /><meta property="og:description" content="ZFS is a combined file system as well as a logical volume manager that offers raid like functionality with data integrity and simplified storage management. It allows you to store and manage a large amount of data. It was first" /><meta property="og:url" content="https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/" /><meta property="og:site_name" content="VITUX" /><meta property="article:publisher" content="https://www.facebook.com/vituxcom/" /><meta property="article:section" content="Ubuntu" /><meta property="article:published_time" content="2019-08-28T15:28:32+00:00" /><meta property="article:modified_time" content="2019-08-28T15:39:48+00:00" /><meta property="og:updated_time" content="2019-08-28T15:39:48+00:00" /><meta property="og:image" content="https://vitux.com/wp-content/uploads/2019/07/ubuntu-zfs-storage-pool.jpg" /><meta property="og:image:secure_url" content="https://vitux.com/wp-content/uploads/2019/07/ubuntu-zfs-storage-pool.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="512" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="ZFS is a combined file system as well as a logical volume manager that offers raid like functionality with data integrity and simplified storage management. It allows you to store and manage a large amount of data. It was first" /><meta name="twitter:title" content="How to set up a ZFS storage pool on Ubuntu" /><meta name="twitter:site" content="@vituxcom" /><meta name="twitter:image" content="https://vitux.com/wp-content/uploads/2019/07/ubuntu-zfs-storage-pool.jpg" /><meta name="twitter:creator" content="@vituxcom" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","publisher":{"@id":"https://vitux.com/#/schema/person/8cb93983c98be876deba153eab5eccee"},"potentialAction":{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/#primaryimage","url":"https://vitux.com/wp-content/uploads/2019/07/ubuntu-zfs-storage-pool.jpg","width":1024,"height":512,"caption":"Ubuntu ZFS Storage Pools"},{"@type":"WebPage","@id":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/#webpage","url":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/","inLanguage":"en-US","name":"How to set up a ZFS storage pool on Ubuntu","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/#primaryimage"},"datePublished":"2019-08-28T15:28:32+00:00","dateModified":"2019-08-28T15:39:48+00:00"},{"@type":"Article","@id":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/#article","isPartOf":{"@id":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/#webpage"},"author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"headline":"How to set up a ZFS storage pool on Ubuntu","datePublished":"2019-08-28T15:28:32+00:00","dateModified":"2019-08-28T15:39:48+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/#webpage"},"publisher":{"@id":"https://vitux.com/#/schema/person/8cb93983c98be876deba153eab5eccee"},"image":{"@id":"https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/#primaryimage"},"articleSection":"Linux,Shell,Ubuntu"},{"@type":["Person"],"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","sameAs":[]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" /><link rel='stylesheet' id='wp-block-library-css'  href='https://vitux.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://vitux.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='https://vitux.com/wp-content/themes/spacious/style.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious_style-css'  href='https://vitux.com/wp-content/themes/vitux/style.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious-genericons-css'  href='https://vitux.com/wp-content/themes/spacious/genericons/genericons.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious-font-awesome-css'  href='https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious_googlefonts-css'  href='//fonts.googleapis.com/css?family=Lato&#038;ver=5.2.2' type='text/css' media='all' /><link rel='stylesheet' id='jquery-lazyloadxt-fadein-css-css'  href='//vitux.com/wp-content/plugins/a3-lazy-load/assets/css/jquery.lazyloadxt.fadein.css' type='text/css' media='all' /><link rel='stylesheet' id='a3a3_lazy_load-css'  href='//vitux.com/wp-content/uploads/sass/a3_lazy_load.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"6387","token":"1fa2acea8d","debug":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1566319552/out/header-b69312bd.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://vitux.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.2" /><link rel='shortlink' href='https://vitux.com/?p=6387' /><link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-set-up-a-zfs-storage-pool-on-ubuntu%2F" /><link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-set-up-a-zfs-storage-pool-on-ubuntu%2F&#038;format=xml" /></head><body class="post-template-default single single-post postid-6387 single-format-standard  better-responsive-menu"><div id="page" class="hfeed site"> <header id="masthead" class="site-header clearfix "><div id="header-text-nav-container" class=""><div class="inner-wrap" id=""><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class=""><h3 id="site-title"> <a href="https://vitux.com/"
title="VITUX"
rel="home">VITUX</a></h3><p id="site-description">Linux Compendium</p> <!-- #site-description --></div><!-- #header-text --></div><!-- #header-left-section --><div id="header-right-section"><div class="header-action"></div> <nav id="site-navigation" class="main-navigation clearfix   " role="navigation"><p class="menu-toggle">Menu</p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li><li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li><li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li><li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li><li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li></ul></div> </nav></div><!-- #header-right-section --></div><!-- #header-text-nav-wrap --></div><!-- .inner-wrap --></div><!-- #header-text-nav-container --><div class="header-post-title-container clearfix"><div class="inner-wrap"><div class="post-title-wrapper"><h1 class="header-post-title-class">How to set up a ZFS storage pool on Ubuntu</h1></div></div></div> </header><div id="main" class="clearfix"><div class="inner-wrap"><div id="primary"><div id="content" class="clearfix"> <article id="post-6387" class="post-6387 post type-post status-publish format-standard has-post-thumbnail hentry category-linux category-shell category-ubuntu"><div class="entry-content clearfix"><p>ZFS is a combined file system as well as a logical volume manager that offers raid like functionality with data integrity and simplified storage management. It allows you to store and manage a large amount of data. It was first created at Sun Microsystems and now a part of the OpenZFS project. Now it has been ported to additional OSes including FreeBSD, Linux, and Mac OSX. ZFS storage pool can deal with a large amount of data that offers you to extend your on-site cloud solution.</p><p>In this article, we will show you how to install ZFS and how to set up a ZFS storage pool. But before going through the procedure, let’s take a look at its features:</p><h2>Features of ZFS</h2><p style="text-align: justify;">Some of the features of ZFS are as below:</p><ul><li>Pooled storage</li><li>Open-source</li><li>Copy-on-write</li><li>encryption</li><li>Snapshots</li><li>Continuous integrity checking</li><li>Efficient data compression</li><li>Data integrity verification and automatic repair</li></ul><p>We will use Ubuntu 18.04 LTS for describing the procedure mentioned in this article.</p><h2>Installing ZFS on Ubuntu</h2><p>To install ZFS on Ubuntu 18.04 LTS, launch the Terminal by pressing <strong>Ctrl+Alt+T</strong> and then type the following command in it:</p><pre>$ sudo apt install zfsutils-linux</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6388" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-190.png" alt="Install ZFS Utils for Linux" width="963" height="328" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-190.png 1176w, https://vitux.com/wp-content/uploads/2019/07/word-image-190-300x102.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-190-768x261.png 768w, https://vitux.com/wp-content/uploads/2019/07/word-image-190-1024x348.png 1024w" sizes="(max-width: 963px) 100vw, 963px" /><noscript><img class="aligncenter wp-image-6388" src="https://vitux.com/wp-content/uploads/2019/07/word-image-190.png" alt="Install ZFS Utils for Linux" width="963" height="328" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-190.png 1176w, https://vitux.com/wp-content/uploads/2019/07/word-image-190-300x102.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-190-768x261.png 768w, https://vitux.com/wp-content/uploads/2019/07/word-image-190-1024x348.png 1024w" sizes="(max-width: 963px) 100vw, 963px" /></noscript></p><p>Wait for a while until the installation is completed.</p><p>To verify the installation, run the following command in Terminal:</p><pre>$ whereis zfs</pre><p>You will see the output similar to below.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6389" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-191.png" alt="Check if ZFS is installed" width="966" height="84" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-191.png 1058w, https://vitux.com/wp-content/uploads/2019/07/word-image-191-300x26.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-191-768x67.png 768w, https://vitux.com/wp-content/uploads/2019/07/word-image-191-1024x89.png 1024w" sizes="(max-width: 966px) 100vw, 966px" /><noscript><img class="aligncenter wp-image-6389" src="https://vitux.com/wp-content/uploads/2019/07/word-image-191.png" alt="Check if ZFS is installed" width="966" height="84" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-191.png 1058w, https://vitux.com/wp-content/uploads/2019/07/word-image-191-300x26.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-191-768x67.png 768w, https://vitux.com/wp-content/uploads/2019/07/word-image-191-1024x89.png 1024w" sizes="(max-width: 966px) 100vw, 966px" /></noscript></p><h2>Creating a ZFS storage pool</h2><p>After installation, we will create a pool of drives. The first step while creating a ZFS storage pool is to know what type of pool you want to create. Then decide which drives to put in the storage pool.</p><h3>1. Select ZFS pool type</h3><p>There are two types of pool you can create:</p><p><strong>Striped pool</strong></p><p>In a striped pool, copy of data is stored across all drives. You can get combined storage and faster read/write speed. However, If one drive fails, you will lose all your data.</p><p><strong>Mirrored pool</strong></p><p>In a mirrored pool, a single and complete copy of data is stored on all drive. If one drive fails, you can still access your data.</p><h3>2. Select drives for pooling</h3><p>Now we have to identify what drives are available on our system to pool. To find out the drives, run the following command in Terminal:</p><pre>$ sudo fdisk –l</pre><p>From the output of fdisk command, note down the names of the drives which should be something like sda, sdb, sdc.</p><p>In our scenario, we have two drives available that are sdb and sdc. I will use these two drives to create a storage pool.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6390" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-192.png" alt="Select Drives for ZFS Pool" width="559" height="229" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-192.png 559w, https://vitux.com/wp-content/uploads/2019/07/word-image-192-300x123.png 300w" sizes="(max-width: 559px) 100vw, 559px" /><noscript><img class="aligncenter wp-image-6390" src="https://vitux.com/wp-content/uploads/2019/07/word-image-192.png" alt="Select Drives for ZFS Pool" width="559" height="229" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-192.png 559w, https://vitux.com/wp-content/uploads/2019/07/word-image-192-300x123.png 300w" sizes="(max-width: 559px) 100vw, 559px" /></noscript></p><h3>3. Creating Pool</h3><p>Once you have decided the pool type and the drives that need to pool, the next step is to create a pool from the above set of drives using zpool command available in Linux that is used to configure storage pools in ZFS.</p><p>To create a striped pool, run the following command in Terminal:</p><pre>$ sudo zpool create &lt;pool_name&gt; &lt;drive1&gt; &lt;drive2&gt;</pre><p>To create a mirrored pool, run the following command in Terminal:</p><pre>$ sudo zpool &lt;pool_name&gt; mirror &lt;drive1&gt; &lt;drive2&gt;</pre><p>You can create any pool depending upon your storage requirements. We will create a mirrored pool using the above command:</p><p><img class="lazy lazy-hidden aligncenter wp-image-6391" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-193.png" alt="Create ZFS Pool" width="659" height="22" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-193.png 659w, https://vitux.com/wp-content/uploads/2019/07/word-image-193-300x10.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-193-642x22.png 642w" sizes="(max-width: 659px) 100vw, 659px" /><noscript><img class="aligncenter wp-image-6391" src="https://vitux.com/wp-content/uploads/2019/07/word-image-193.png" alt="Create ZFS Pool" width="659" height="22" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-193.png 659w, https://vitux.com/wp-content/uploads/2019/07/word-image-193-300x10.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-193-642x22.png 642w" sizes="(max-width: 659px) 100vw, 659px" /></noscript></p><p>After creating the pool, you can verify the detailed status of the zpool by using the following command:</p><pre># zpool status</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6392" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-194.png" alt="Check ZFS Pool state" width="500" height="290" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-194.png 500w, https://vitux.com/wp-content/uploads/2019/07/word-image-194-300x174.png 300w" sizes="(max-width: 500px) 100vw, 500px" /><noscript><img class="aligncenter wp-image-6392" src="https://vitux.com/wp-content/uploads/2019/07/word-image-194.png" alt="Check ZFS Pool state" width="500" height="290" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-194.png 500w, https://vitux.com/wp-content/uploads/2019/07/word-image-194-300x174.png 300w" sizes="(max-width: 500px) 100vw, 500px" /></noscript></p><p>To see pool health status and space usage, use the below command in Terminal. This command also shows the disks that you have selected for your storage pool. You can add more drives later to further increase redundancy.</p><pre>$ zpool list</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6393" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-195.png" alt="List ZFS Pools" width="775" height="69" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-195.png 786w, https://vitux.com/wp-content/uploads/2019/07/word-image-195-300x27.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-195-768x68.png 768w" sizes="(max-width: 775px) 100vw, 775px" /><noscript><img class="aligncenter wp-image-6393" src="https://vitux.com/wp-content/uploads/2019/07/word-image-195.png" alt="List ZFS Pools" width="775" height="69" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-195.png 786w, https://vitux.com/wp-content/uploads/2019/07/word-image-195-300x27.png 300w, https://vitux.com/wp-content/uploads/2019/07/word-image-195-768x68.png 768w" sizes="(max-width: 775px) 100vw, 775px" /></noscript></p><p>Now run <strong>df –h</strong>, you will note that the newly created pool is automatically mounted at the mount point.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6394" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-196.png" alt="ZFS Pool listed in df command" width="481" height="50" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-196.png 481w, https://vitux.com/wp-content/uploads/2019/07/word-image-196-300x31.png 300w" sizes="(max-width: 481px) 100vw, 481px" /><noscript><img class="aligncenter wp-image-6394" src="https://vitux.com/wp-content/uploads/2019/07/word-image-196.png" alt="ZFS Pool listed in df command" width="481" height="50" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-196.png 481w, https://vitux.com/wp-content/uploads/2019/07/word-image-196-300x31.png 300w" sizes="(max-width: 481px) 100vw, 481px" /></noscript></p><p>The pool you have just created has a size of 1.9 G and it is mounted at the default mount point <strong>/new-pool</strong>. If you want, you can change the mount point using the following syntax:</p><pre>$ sudo zfs set mountpoint=&lt;path&gt; &lt;pool_name&gt;</pre><p>For instance, we want to set the <strong>/usr/share/pool</strong> as the new mount point. we will use the following command for this purpose:</p><pre>$ sudo zfs set mountpoint=/usr/share/pool new-pool</pre><p>To verify if the mount point has changed successfully, use<strong> df -h</strong> command</p><p><img class="lazy lazy-hidden wp-image-6395 aligncenter" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-197.png" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-197.png 632w, https://vitux.com/wp-content/uploads/2019/07/word-image-197-300x33.png 300w" sizes="(max-width: 632px) 100vw, 632px" /><noscript><img class="wp-image-6395 aligncenter" src="https://vitux.com/wp-content/uploads/2019/07/word-image-197.png" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-197.png 632w, https://vitux.com/wp-content/uploads/2019/07/word-image-197-300x33.png 300w" sizes="(max-width: 632px) 100vw, 632px" /></noscript></p><p style="text-align: justify;">From the above results, you can see that the mount point has changed successfully to the new mount point <strong>/usr/share/pool</strong>..</p><p>Now the storage pool has created, we will now create datasets and will keep everything inside these datasets. These datasets are like directories and have a mount point.</p><p>To create datasets, run the following command in Terminal:</p><pre>$ sudo zfs create &lt;pool_name&gt;/directory_name</pre><p>For instance, I want to create dataset named <strong>docs</strong> under my storage pool. I will use the following command:</p><pre>$ sudo zfs create new-pool/docs</pre><p>The datasets that we have just created will get automatically mounted with the name <strong>/new-pool/docs</strong> at the mount point <strong>/usr/share/pool</strong> which we can view by using the <strong>df -h</strong> command.</p><pre>$ df -h</pre><p><strong><img class="lazy lazy-hidden aligncenter wp-image-6398" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/07/word-image-200.png" alt="Result of df -h command" width="631" height="291" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-200.png 631w, https://vitux.com/wp-content/uploads/2019/07/word-image-200-300x138.png 300w" sizes="(max-width: 631px) 100vw, 631px" /><noscript><img class="aligncenter wp-image-6398" src="https://vitux.com/wp-content/uploads/2019/07/word-image-200.png" alt="Result of df -h command" width="631" height="291" srcset="https://vitux.com/wp-content/uploads/2019/07/word-image-200.png 631w, https://vitux.com/wp-content/uploads/2019/07/word-image-200-300x138.png 300w" sizes="(max-width: 631px) 100vw, 631px" /></noscript></strong></p><p><strong>Removing a ZFS pool</strong></p><p>If you want to remove the pool, you can use the zpool destroy command as shown below:</p><pre># zpool destroy pool_name</pre><p>That is all we needed in order to set up a ZFS storage pool in Ubuntu 18.04 LTS. Now you can start storing your files in the newly created pool. It is an awesome and powerful file system that you can use when working with loads of storage.</p><div class="extra-hatom-entry-title"><span class="entry-title">How to set up a ZFS storage pool on Ubuntu</span></div></div><footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix"> <span class="by-author author vcard"><a class="url fn n"
href="https://vitux.com/author/karim/">Karim Buzdar</a></span><span class="date"><a href="https://vitux.com/how-to-set-up-a-zfs-storage-pool-on-ubuntu/" title="3:28 pm" rel="bookmark"><time class="entry-date published" datetime="2019-08-28T15:28:32+00:00">August 28, 2019</time><time class="updated" datetime="2019-08-28T15:39:48+00:00">August 28, 2019</time></a></span> <span class="category"><a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a>, <a href="https://vitux.com/ubuntu/" rel="category tag">Ubuntu</a></span></div></footer> </article><ul class="default-wp-page clearfix"><li class="previous"><a href="https://vitux.com/how-to-mute-disable-hardware-beep-sound-in-ubuntu-terminal/" rel="prev"><span class="meta-nav">&larr;</span> How to mute/disable Hardware Beep Sound in Ubuntu Terminal</a></li><li class="next"></li></ul></div><!-- #content --></div><!-- #primary --><div id="secondary"> <aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async type="text/javascript" src="//cdn.carbonads.com/carbon.js?serve=CK7IVKQW&placement=vituxcom" id="_carbonads_js"></script></div></aside><aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form><!-- .searchform --></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3><div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p></div> </aside> <aside id="wpp-5" class="widget popular-posts"><h3 class="widget-title"><span>Most Popular</span></h3><!-- cached --> <!-- WordPress Popular Posts --><ul class="wpp-list"><li> <a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" title="How to Uninstall Programs from your Ubuntu System" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-xampp-on-your-ubuntu-18-04-lts-system/" title="How to Install XAMPP on your Ubuntu 18.04 LTS System" class="wpp-post-title" target="_self">How to Install XAMPP on your Ubuntu 18.04 LTS System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 2, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" title="Get Linux System and Hardware Details on the Command Line" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on August 7, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-use-apt-get-package-manager-on-ubuntu-command-line/" title="How to use apt Package Manager on Ubuntu Command Line" class="wpp-post-title" target="_self">How to use apt Package Manager on Ubuntu Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 23, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/5-ways-to-check-available-memory-in-ubuntu/" title="5 Ways to Check Available Memory in Ubuntu" class="wpp-post-title" target="_self">5 Ways to Check Available Memory in Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on December 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-shut-down-ubuntu/" title="How to Shut Down Ubuntu" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 21, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" title="How to Write and Run a C Program in Linux" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 17, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-virtualbox-on-ubuntu/" title="How to Install VirtualBox on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">How to Install VirtualBox on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 5, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-wine-on-ubuntu/" title="How to Install Wine on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">How to Install Wine on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on September 20, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/install-nfs-server-and-client-on-ubuntu/" title="Install NFS Server and Client on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">Install NFS Server and Client on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 13, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li></ul></aside></div></div><!-- .inner-wrap --></div><!-- #main --><footer id="colophon" class="clearfix"><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"> Copyright &copy; <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li></ul></div> </nav></div></div></div> </footer> <a href="#masthead" id="scroll-up"></a></div><!-- #page --> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');</script> <script type='text/javascript'>/*  */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0"};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1566319552/out/footer-e0172597.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script> </body></html>

<!-- Cachify | http://cachify.de
Memcached @ 28.08.2019 15:41:11 -->