<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1"><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Lato"] },classes:false, events:false, timeout:1500};</script><link rel="profile" href="http://gmpg.org/xfn/11" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><link media="all" href="https://vitux.com/wp-content/cache/autoptimize/css/autoptimize_51e6b3e4e19132b152459c6acb0af71e.css" rel="stylesheet" /><title>How to Speed Up Package Downloads and updates with apt-fast on Debian 10</title><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Speed Up Package Downloads and updates with apt-fast on Debian 10" /><meta property="og:description" content="In one of our previous articles, we have explained how to use apt package manager in order to perform different operations like searching for available packages, installing or upgrading packages, removing packages, etc. But today, we will discuss another utility" /><meta property="og:url" content="https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/" /><meta property="og:site_name" content="VITUX" /><meta property="article:publisher" content="https://www.facebook.com/vituxcom/" /><meta property="article:section" content="Debian" /><meta property="article:published_time" content="2020-02-13T18:05:11+00:00" /><meta property="og:image" content="https://vitux.com/wp-content/uploads/2019/09/debian-apt-fast.jpg" /><meta property="og:image:secure_url" content="https://vitux.com/wp-content/uploads/2019/09/debian-apt-fast.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="512" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="In one of our previous articles, we have explained how to use apt package manager in order to perform different operations like searching for available packages, installing or upgrading packages, removing packages, etc. But today, we will discuss another utility" /><meta name="twitter:title" content="How to Speed Up Package Downloads and updates with apt-fast on Debian 10" /><meta name="twitter:site" content="@vituxcom" /><meta name="twitter:image" content="https://vitux.com/wp-content/uploads/2019/09/debian-apt-fast.jpg" /><meta name="twitter:creator" content="@vituxcom" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","publisher":{"@id":"https://vitux.com/#/schema/person/"},"potentialAction":{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/#primaryimage","url":"https://vitux.com/wp-content/uploads/2019/09/debian-apt-fast.jpg","width":1024,"height":512,"caption":"Debian apt-fast"},{"@type":"WebPage","@id":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/#webpage","url":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/","inLanguage":"en-US","name":"How to Speed Up Package Downloads and updates with apt-fast on Debian 10","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/#primaryimage"},"datePublished":"2020-02-13T18:05:11+00:00","dateModified":"2020-02-13T18:05:11+00:00"},{"@type":"Article","@id":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/#article","isPartOf":{"@id":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/#webpage"},"author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"headline":"How to Speed Up Package Downloads and updates with apt-fast on Debian 10","datePublished":"2020-02-13T18:05:11+00:00","dateModified":"2020-02-13T18:05:11+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/#webpage"},"publisher":{"@id":"https://vitux.com/#/schema/person/"},"image":{"@id":"https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/#primaryimage"},"articleSection":"Debian,Linux,Shell"},{"@type":["Person"],"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","sameAs":[]}]}</script> <link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" /><link rel='stylesheet' id='a3a3_lazy_load-css'  href='//vitux.com/wp-content/uploads/sass/a3_lazy_load.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"7783","token":"7577044515","debug":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1581450378/out/header-b69312bd.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://vitux.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://vitux.com/?p=7783' /><link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian%2F" /><link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian%2F&#038;format=xml" /><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-7783 single-format-standard  better-responsive-menu"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a><header id="masthead" class="site-header clearfix spacious-header-display-one"><div id="header-text-nav-container" class=""><div class="inner-wrap" id="spacious-header-display-one"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class=""><h3 id="site-title"> <a href="https://vitux.com/"
title="VITUX"
rel="home">VITUX</a></h3><p id="site-description">Linux Compendium</p></div></div><div id="header-right-section"><div class="header-action"></div><nav id="site-navigation" class="main-navigation clearfix   " role="navigation"><p class="menu-toggle">Menu</p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li><li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li><li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li><li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li><li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li></ul></div></nav></div></div></div></div><div class="header-post-title-container clearfix"><div class="inner-wrap"><div class="post-title-wrapper"><h1 class="header-post-title-class">How to Speed Up Package Downloads and updates with apt-fast on Debian 10</h1></div></div></div></header><div id="main" class="clearfix"><div class="inner-wrap"><div id="primary"><div id="content" class="clearfix"><article id="post-7783" class="post-7783 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-linux category-shell"><div class="entry-content clearfix"><p>In one of our previous articles, we have explained how to use apt package manager in order to perform different operations like searching for available packages, installing or upgrading packages, removing packages, etc. But today, we will discuss another utility that can improve the download speed of apt packages and that is known as apt-fast.</p><p>Apt-fast is a shell script wrapper for “apt-get” and “aptitude” that utilizes the power of axel or aria 2 download managers to accelerate the download process. It improves download performance by downloading packages simultaneously and with multiple packages per connection.</p><p>In this article, we will explain how to install apt-fast in order to accelerate the update and downloading process. We have run the commands and procedure mentioned in this article on a Debian10 system.</p><h2>Step 1: Installing prerequisites</h2><p>In order to use apt-fast, first we have to install <strong>axel</strong> or <strong>aria2</strong> command-line download accelerators. Both are great tools that help to improve the download speed with multiple connections per package.</p><p>Launch the Terminal application in your system by going into the <strong>Activities</strong> tab in the top left corner of your desktop. Then in the search bar, type <strong><em>terminal</em></strong>. When the Terminal icon appears, click on it to launch it. Then run the following command in Terminal to install axel or aria2:</p><pre>$ sudo apt-get install axel</pre><p>Or</p><pre>$ sudo apt-get install aria2</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7784" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-273.png" alt="Install axel" width="800" height="332" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-273.png 988w, https://vitux.com/wp-content/uploads/2019/09/word-image-273-300x124.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-273-768x319.png 768w" sizes="(max-width: 800px) 100vw, 800px" /><noscript><img class="aligncenter wp-image-7784" src="https://vitux.com/wp-content/uploads/2019/09/word-image-273.png" alt="Install axel" width="800" height="332" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-273.png 988w, https://vitux.com/wp-content/uploads/2019/09/word-image-273-300x124.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-273-768x319.png 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></p><h2>Step 2: Installing and configuring apt-fast</h2><p>For installing apt-fast, first we will have to add the repository key for apt-fast. It will allow the system to trust the packages being added from the repository. Run the following command in Terminal to add the key:</p><pre>$ apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 1EE2FF37CA8DA16B</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7785" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-274.png" alt="add adv repository key" width="832" height="76" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-274.png 1376w, https://vitux.com/wp-content/uploads/2019/09/word-image-274-300x27.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-274-768x70.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-274-1024x94.png 1024w" sizes="(max-width: 832px) 100vw, 832px" /><noscript><img class="aligncenter wp-image-7785" src="https://vitux.com/wp-content/uploads/2019/09/word-image-274.png" alt="add adv repository key" width="832" height="76" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-274.png 1376w, https://vitux.com/wp-content/uploads/2019/09/word-image-274-300x27.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-274-768x70.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-274-1024x94.png 1024w" sizes="(max-width: 832px) 100vw, 832px" /></noscript></p><p>After adding the key, add PPA repository of apt-fast to your system by running the following command in Terminal:</p><pre>$ add-apt-repository ppa:apt-fast/stable</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7786" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-275.png" alt="add apt-fast repository" width="852" height="253" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-275.png 906w, https://vitux.com/wp-content/uploads/2019/09/word-image-275-300x89.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-275-768x228.png 768w" sizes="(max-width: 852px) 100vw, 852px" /><noscript><img class="aligncenter wp-image-7786" src="https://vitux.com/wp-content/uploads/2019/09/word-image-275.png" alt="add apt-fast repository" width="852" height="253" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-275.png 906w, https://vitux.com/wp-content/uploads/2019/09/word-image-275-300x89.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-275-768x228.png 768w" sizes="(max-width: 852px) 100vw, 852px" /></noscript></p><p>Now update the local apt repository by running the following command in Terminal:</p><pre>$ apt-get update</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7787" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-276.png" alt="Update packages" width="861" height="223" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-276.png 1034w, https://vitux.com/wp-content/uploads/2019/09/word-image-276-300x78.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-276-768x199.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-276-1024x265.png 1024w" sizes="(max-width: 861px) 100vw, 861px" /><noscript><img class="aligncenter wp-image-7787" src="https://vitux.com/wp-content/uploads/2019/09/word-image-276.png" alt="Update packages" width="861" height="223" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-276.png 1034w, https://vitux.com/wp-content/uploads/2019/09/word-image-276-300x78.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-276-768x199.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-276-1024x265.png 1024w" sizes="(max-width: 861px) 100vw, 861px" /></noscript></p><p>Finally, run the following command in Terminal to install apt-fast:</p><pre>$ apt-get -y install apt-fast</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7788" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-277.png" alt="Install apt-fast" width="685" height="385" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-277.png 946w, https://vitux.com/wp-content/uploads/2019/09/word-image-277-300x169.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-277-768x432.png 768w" sizes="(max-width: 685px) 100vw, 685px" /><noscript><img class="aligncenter wp-image-7788" src="https://vitux.com/wp-content/uploads/2019/09/word-image-277.png" alt="Install apt-fast" width="685" height="385" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-277.png 946w, https://vitux.com/wp-content/uploads/2019/09/word-image-277-300x169.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-277-768x432.png 768w" sizes="(max-width: 685px) 100vw, 685px" /></noscript></p><p>During the installation of apt-fast, a window will pop-up for you to configure apt-fast.</p><p>When the following screen appears, select <strong>apt-get </strong>as a package manager and hit<strong> Enter </strong>to move to the next step.</p><p><img class="lazy lazy-hidden aligncenter wp-image-7789" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-278.png" alt="configure apt-fast" width="569" height="286" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-278.png 629w, https://vitux.com/wp-content/uploads/2019/09/word-image-278-300x151.png 300w" sizes="(max-width: 569px) 100vw, 569px" /><noscript><img class="aligncenter wp-image-7789" src="https://vitux.com/wp-content/uploads/2019/09/word-image-278.png" alt="configure apt-fast" width="569" height="286" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-278.png 629w, https://vitux.com/wp-content/uploads/2019/09/word-image-278-300x151.png 300w" sizes="(max-width: 569px) 100vw, 569px" /></noscript></p><p>Now choose the maximum number of connections allowed. Leave it as default. Hit enter to move on to the next step.</p><p><img class="lazy lazy-hidden aligncenter wp-image-7790" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-279.png" alt="configure max connections" width="355" height="200" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-279.png 422w, https://vitux.com/wp-content/uploads/2019/09/word-image-279-300x169.png 300w" sizes="(max-width: 355px) 100vw, 355px" /><noscript><img class="aligncenter wp-image-7790" src="https://vitux.com/wp-content/uploads/2019/09/word-image-279.png" alt="configure max connections" width="355" height="200" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-279.png 422w, https://vitux.com/wp-content/uploads/2019/09/word-image-279-300x169.png 300w" sizes="(max-width: 355px) 100vw, 355px" /></noscript></p><p>Remember, you can also set the maximum number of connections later using the _MAXNUM variable in the configuration files.</p><p>You can choose to suppress the apt-fast confirmation dialog each time you want to install a package. For that leave the default value <strong>&lt;No&gt;</strong> and press Enter.</p><p><img class="lazy lazy-hidden aligncenter wp-image-7791" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-280.png" alt="Suppress dialog" width="679" height="213" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-280.png 746w, https://vitux.com/wp-content/uploads/2019/09/word-image-280-300x94.png 300w" sizes="(max-width: 679px) 100vw, 679px" /><noscript><img class="aligncenter wp-image-7791" src="https://vitux.com/wp-content/uploads/2019/09/word-image-280.png" alt="Suppress dialog" width="679" height="213" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-280.png 746w, https://vitux.com/wp-content/uploads/2019/09/word-image-280-300x94.png 300w" sizes="(max-width: 679px) 100vw, 679px" /></noscript></p><p>Once the installation is completed, we will need to do a basic configuration. The default configuration file of apt-fast is at <strong>/etc/apt-fast</strong>.</p><p>Run the following command in Terminal to edit the configuration file in an editor:</p><pre>$ sudo nano /etc/apt-fast.conf</pre><p>In the configuration file, add the comma separated mirrors in the following syntax:</p><p>MIRRORS=( http://ftp.debian.org/debian, http://ftp2.de.debian.org&#8217;)</p><p>Use the following Debian’s official mirror page and add nearest mirrors based on your geographical location.</p><p><a href="https://www.debian.org/mirror/list">https://www.debian.org/mirror/list</a></p><p><img class="lazy lazy-hidden aligncenter wp-image-7792" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-281.png" alt="apt-fast mirror configuration" width="740" height="463" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-281.png 965w, https://vitux.com/wp-content/uploads/2019/09/word-image-281-300x188.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-281-768x481.png 768w" sizes="(max-width: 740px) 100vw, 740px" /><noscript><img class="aligncenter wp-image-7792" src="https://vitux.com/wp-content/uploads/2019/09/word-image-281.png" alt="apt-fast mirror configuration" width="740" height="463" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-281.png 965w, https://vitux.com/wp-content/uploads/2019/09/word-image-281-300x188.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-281-768x481.png 768w" sizes="(max-width: 740px) 100vw, 740px" /></noscript></p><p>Also add the mirrors that are present in <strong>/etc/apt/sources.list</strong> or in the apt-fast configuration file <strong>/etc/apt-fast.conf.</strong></p><h2>Step 3: Using Apt-fast</h2><p>Once you are done with the installation and configuration of apt-fast, use it in the same way as you use apt-get. Just substitute fast instead of get in the apt-get command. Following are some useful commands in order to use apt-fast:</p><p>Use the following command to install a package using apt-fast:</p><pre>$ sudo apt-fast install package_name</pre><p>Use the following command to remove a package using apt-fast:</p><pre>$ sudo apt-fast remove package_name</pre><p>Use the following command to update a package using apt-fast:</p><pre>$ sudo apt-fast update</pre><p>Use the following command to upgrade a package using apt-fast:</p><pre>$ sudo apt-fast upgrade</pre><p>Let’s see how apt-fast works by installing Apache2. To do so, run the following command in Terminal:</p><pre>$ sudo apt-fast install apache2</pre><p>It will ask for confirmation, enter <strong>y</strong> to confirm.</p><p><img class="lazy lazy-hidden aligncenter wp-image-7793" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-282.png" alt="Using apt-fast" width="826" height="398" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-282.png 1299w, https://vitux.com/wp-content/uploads/2019/09/word-image-282-300x145.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-282-768x370.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-282-1024x493.png 1024w" sizes="(max-width: 826px) 100vw, 826px" /><noscript><img class="aligncenter wp-image-7793" src="https://vitux.com/wp-content/uploads/2019/09/word-image-282.png" alt="Using apt-fast" width="826" height="398" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-282.png 1299w, https://vitux.com/wp-content/uploads/2019/09/word-image-282-300x145.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-282-768x370.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-282-1024x493.png 1024w" sizes="(max-width: 826px) 100vw, 826px" /></noscript></p><p>From the above results, you can see that it is downloading the Apache2 package using multiple connections.</p><p>In this article, we have seen how the apt-fast utility can be used for not only installing the software packages on your system but also for increasing the download speed. Now enjoy the fast download experience!</p><div class="extra-hatom-entry-title"><span class="entry-title">How to Speed Up Package Downloads and updates with apt-fast on Debian 10</span></div></div><footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix"> <span class="by-author author vcard"><a class="url fn n"
href="https://vitux.com/author/karim/">Karim Buzdar</a></span><span class="date"><a href="https://vitux.com/how-to-speed-up-package-downloads-and-updates-with-apt-fast-on-debian/" title="6:05 pm" rel="bookmark"><time class="entry-date published" datetime="2020-02-13T18:05:11+00:00">February 13, 2020</time></a></span> <span class="category"><a href="https://vitux.com/debian/" rel="category tag">Debian</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span></div></footer></article><ul class="default-wp-page clearfix"><li class="previous"><a href="https://vitux.com/search-for-gifs-from-the-ubuntu-command-line-using-gif-cli/" rel="prev"><span class="meta-nav">&larr;</span> Search for gifs from the Ubuntu Command Line using gif-cli</a></li><li class="next"></li></ul></div></div><div id="secondary"><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async type="text/javascript" src="//cdn.carbonads.com/carbon.js?serve=CK7IVKQW&placement=vituxcom" id="_carbonads_js"></script></div></aside><aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3><div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p></div></aside><aside id="wpp-5" class="widget popular-posts"><h3 class="widget-title"><span>Most Popular</span></h3><ul class="wpp-list"><li> <a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 22, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-create-a-bootable-usb-stick-from-the-ubuntu-terminal/" class="wpp-post-title" target="_self">How to Create a Bootable USB Stick from the Ubuntu Terminal</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 18, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 26, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-xampp-on-your-ubuntu-18-04-lts-system/" class="wpp-post-title" target="_self">How to Install XAMPP on your Ubuntu 18.04 LTS System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 2, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-ubuntu-18-04-along-with-windows-10/" class="wpp-post-title" target="_self">How to Install Ubuntu 18.04 along with Windows 10</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 29, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 21, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-find-files-on-the-ubuntu-command-line/" class="wpp-post-title" target="_self">How to find files on the Ubuntu command line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/ubuntu-network-configuration/" class="wpp-post-title" target="_self">How to Configure Network Settings in Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 24, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-wine-on-ubuntu/" class="wpp-post-title" target="_self">How to Install Wine on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on September 20, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li></ul></aside></div></div></div><footer id="colophon" class="clearfix"><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"> Copyright &copy; <a href="https://vitux.com">vitux.com</a><nav class="small-menu clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li></ul></div></nav></div></div></div></footer> <a href="#masthead" id="scroll-up"></a></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');</script> <script type="text/javascript">(function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();</script> <script>var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });</script> <script type='text/javascript'>/*  */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0"};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1581450378/out/footer-75e3307e.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script> </body></html>

<!-- Cachify | http://cachify.de
Memcached @ 13.02.2020 18:06:35 -->