<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=191-2&cb=2', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=191-2&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=191-2&cb=3', false, [], true, false, true, false);</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />

<title>How to use mtr traceroute Command on CentOS 8</title>
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://vitux.com/how-to-use-mtr-command-on-centos-8/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to use mtr traceroute Command on CentOS 8" />
<meta property="og:description" content="MTR is known as Matt&#8217;s traceroute. It is a simple and cross-platform utility for network diagnostic that is used for most of the command-line systems. This tool is not so popular but provides the features of both traceroute and ping" />
<meta property="og:url" content="https://vitux.com/how-to-use-mtr-command-on-centos-8/" />
<meta property="og:site_name" content="VITUX" />
<meta property="article:publisher" content="https://www.facebook.com/vituxcom/" />
<meta property="article:published_time" content="2020-04-06T11:38:53+00:00" />
<meta property="article:modified_time" content="2020-11-18T11:01:44+00:00" />
<meta property="og:image" content="https://vitux.com/wp-content/uploads/2020/04/word-image-111.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@vituxcom" />
<meta name="twitter:site" content="@vituxcom" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Karim Buzdar">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="5 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","potentialAction":[{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vitux.com/how-to-use-mtr-command-on-centos-8/#primaryimage","inLanguage":"en-US","url":"https://vitux.com/wp-content/uploads/2020/04/word-image-111.png","width":802,"height":556},{"@type":"WebPage","@id":"https://vitux.com/how-to-use-mtr-command-on-centos-8/#webpage","url":"https://vitux.com/how-to-use-mtr-command-on-centos-8/","name":"How to use mtr traceroute Command on CentOS 8","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/how-to-use-mtr-command-on-centos-8/#primaryimage"},"datePublished":"2020-04-06T11:38:53+00:00","dateModified":"2020-11-18T11:01:44+00:00","author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vitux.com/how-to-use-mtr-command-on-centos-8/"]}]},{"@type":"Person","@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","image":{"@type":"ImageObject","@id":"https://vitux.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=96&d=mm&r=g","caption":"Karim Buzdar"},"description":"About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. He blogs at LinuxWays."}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/vitux.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://vitux.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://vitux.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://vitux.com/wp-content/themes/spacious/style.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_style-css' href='https://vitux.com/wp-content/themes/vitux/style.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-genericons-css' href='https://vitux.com/wp-content/themes/spacious/genericons/genericons.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-font-awesome-css' href='https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_googlefonts-css' href='//fonts.googleapis.com/css?family=Lato&#038;ver=5.5.3' type='text/css' media='all' />
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":11508,"token":"5bf0cd46f5","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/spacious-custom.js?ver=5.5.3' id='spacious-custom-js'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js?ver=5.5.3' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://vitux.com/wp-json/" /><link rel="alternate" type="application/json" href="https://vitux.com/wp-json/wp/v2/posts/11508" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://vitux.com/?p=11508' />
<link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-use-mtr-command-on-centos-8%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-use-mtr-command-on-centos-8%2F&#038;format=xml" />
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158791751-45";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(function(){
	_gat._createTracker('UA-158791751-45', 'e');
});
_gaq.push(function(){
	_gat._createTracker('UA-38339005-1', 'f');
});
_gaq.push(['e._setDomainName', 'vitux.com']);
_gaq.push(['f._setDomainName', 'vitux.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod70-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','vitux.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://vitux.com/how-to-use-mtr-command-on-centos-8/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 177389;
var ezdomain = 'vitux.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":177389,"engaged_time_visit":0,"ezcache_level":2,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"c88f946f-0336-4105-65f3-519a25271c92","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":4,"serverid":"54.234.102.242:4305","state":"VA","t_epoch":1605761791,"template_id":126,"time_on_site_visit":0,"url":"https://vitux.com/how-to-use-mtr-command-on-centos-8/","user_id":0,"word_count":1548,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=191-2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_177389=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["c88f946f-0336-4105-65f3-519a25271c92", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="post-template-default single single-post postid-11508 single-format-standard wp-embed-responsive  better-responsive-menu narrow-1218">
<div id="page" class="hfeed site">
<a class="skip-link screen-reader-text" href="#main">Skip to content</a>
<header id="masthead" class="site-header clearfix spacious-header-display-one">
<div id="header-text-nav-container" class="">
<div class="inner-wrap" id="spacious-header-display-one">
<div id="header-text-nav-wrap" class="clearfix">
<div id="header-left-section">
<div id="header-text" class="">
<h3 id="site-title">
<a href="https://vitux.com/" title="VITUX" rel="home">VITUX</a>
</h3>
<p id="site-description">Linux Compendium</p>

</div>
</div>
<div id="header-right-section">
<div class="header-action">
</div>
<nav id="site-navigation" class="main-navigation clearfix   " role="navigation">
<p class="menu-toggle">Menu</p>
<div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li>
<li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li>
<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li>
<li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</div>
<div class="header-post-title-container clearfix">
<div class="inner-wrap">
<div class="post-title-wrapper">
<h1 class="header-post-title-class">How to use mtr traceroute Command on CentOS 8</h1>
</div>
</div>
</div>
</header>
<div id="main" class="clearfix">
<div class="inner-wrap">
<div id="primary">
<div id="content" class="clearfix">
<article id="post-11508" class="post-11508 post type-post status-publish format-standard hentry category-centos category-linux category-shell">
<div class="entry-content clearfix">
<p>MTR is known as Matt&#8217;s traceroute. It is a simple and cross-platform utility for network diagnostic that is used for most of the command-line systems. This tool is not so popular but provides the features of both traceroute and ping programs. As similar to the traceroute program, the Mtr tool is also used to print the details about the desired route such as how packets initialize from the right host and reach the destination of the specified host. Mtr command displays more information as compared to the traceroute program in which the exact pathway determines between a local machine and a remote access system. It prints the percentage of the response rate and response time of all network hops that route between the host and destination system.</p>
<p>A network administrator must know about the usage of the mtr tool. The certain flags with mtr command increase the network diagnostic productivity. You can customize the desired output by using these flags. In this article, you will learn how mtr command will help you to find the network analysis between the network hops on CentOS 8. In most of the Linux distributions, the mtr tool is pre-installed by default. But, if it is not installed on your CentOS 8 then first you need to install it.</p>
<h2>Install mtr command on CentOS 8</h2>
<ol>
<li>Press Ctrl + Alt + t to open the terminal or open terminal using the desktop, click on the top corner of the “Activities” option, and select terminal from the left sidebar options.</li>
<li>To install the mtr tool on CentOS 8, you need to log in as a root user. So, type ‘su’ command on the terminal. Now you have been logged in as a root user.</li>
<li>Run the following command on the terminal to install mtr tool:</li>
</ol>
<pre> $sudo yum install mtr</pre>
<p><img loading="lazy" class="aligncenter wp-image-11509" src="https://vitux.com/wp-content/uploads/2020/04/word-image-111.png" alt="Install mtr command" width="802" height="556" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-111.png 802w, https://vitux.com/wp-content/uploads/2020/04/word-image-111-300x208.png 300w, https://vitux.com/wp-content/uploads/2020/04/word-image-111-768x532.png 768w" sizes="(max-width: 802px) 100vw, 802px" /></p>
<p>Mtr tool has been successfully installed on your CentOS 8.0. A “Complete!” status will display on the terminal.</p>
<h1>How to work with mtr command?</h1>
<p>There are the following ways to use the mtr command in the command line system.</p>
<ol>
<li>The mtr command gives the complete traceroute report of a remote system in real-time. Using mtr command, you need to provide the IP address or domain name of the remote system. An output would be displayed on the system that will provide you the updated real-time traceroute report of the remote system. To exit the current program you will hit the “q” key or press “Ctrl+C”  from your keyboard.</li>
</ol>
<p>For example, you will take the domain name as google.com in an argument with the mtr command. Run the following command to view the real-time traceroute report of google.com:</p>
<p>Domain name</p>
<pre>$mtr google.com</pre>
<p>Or</p>
<p>IP address</p>
<pre>$mtr 216.58.223.78</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-11510" src="https://vitux.com/wp-content/uploads/2020/04/word-image-112.png" alt="Use mtr traceroute command" width="732" height="491" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-112.png 732w, https://vitux.com/wp-content/uploads/2020/04/word-image-112-300x201.png 300w" sizes="(max-width: 732px) 100vw, 732px" /></strong></p>
<p>You can display a numeric IP address in the traceroute report instead of displaying the hostname. The -n flag with mtr command is used to display numeric IP addresses. Run the following command on the terminal window to view the numeric IP addresses:</p>
<pre><strong> </strong>$mtr -n google.com</pre>
<p><img loading="lazy" class="aligncenter wp-image-11511" src="https://vitux.com/wp-content/uploads/2020/04/word-image-113.png" alt="Show IP addresses in traceroute" width="727" height="389" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-113.png 727w, https://vitux.com/wp-content/uploads/2020/04/word-image-113-300x161.png 300w" sizes="(max-width: 727px) 100vw, 727px" /></p>
<p>If you want to display both options IP addresses as well as the hostname then you will use -b flag with mtr command. Run the following command to display both the hostname and IP addresses in traceroute report:</p>
<pre>$mtr -b google.com</pre>
<p><img loading="lazy" class="aligncenter wp-image-11512" src="https://vitux.com/wp-content/uploads/2020/04/word-image-114.png" alt="Show IP and hostname" width="728" height="399" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-114.png 728w, https://vitux.com/wp-content/uploads/2020/04/word-image-114-300x164.png 300w" sizes="(max-width: 728px) 100vw, 728px" /></p>
<p>You can set a specific value to limit the number of pings using mtr command. For this purpose, you will use the mtr command along with <strong>-c </strong>flag and specified limit value. In this case, you have limited the number of pings to an exact value and should exit after that specified number of pings. You can see the exact number of pings below the “Snt column”. As soon as the number of pings reaches the specified limit then real-time report updates the status of “stops” and you will automatically exit from the program. To easily understand, run the following command on your terminal to perform the above operation:</p>
<pre>$mtr -c5 google.com</pre>
<p>Using mtr command, you can set report mode. In this case, the report mode will enable that will display the output into a text file. This method is useful for network statistical analysis. Since the output is printed to a text file so you can use these observations for later use. To enable the report mode, you will use <strong>-r</strong> flag together with -c flag option. You will also mention the specified pings limit with -c flag and also specify the report name. The report name is basically the name of the report that will save after running the mtr command. Run the following command to perform the operation:</p>
<pre>$mtr -r -c 5 google.com &gt; mtr-report</pre>
<p><img loading="lazy" class="aligncenter wp-image-11513" src="https://vitux.com/wp-content/uploads/2020/04/word-image-115.png" alt="Save traceroute as file" width="799" height="344" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-115.png 799w, https://vitux.com/wp-content/uploads/2020/04/word-image-115-300x129.png 300w, https://vitux.com/wp-content/uploads/2020/04/word-image-115-768x331.png 768w" sizes="(max-width: 799px) 100vw, 799px" /></p>
<p>The above-mentioned report will be saved by default into the home folder of CentOS 8.0. You can also save a report in other drives of your system to specify the exact path of the saved location.</p>
<p>To use -w flag and r flag with mtr command, it will enable the report mode in which you can print more clear and readable reports of traceroute. Run the following command on the terminal to try this operation:</p>
<pre>$mtr -rw -c 5 google.com &gt;mtr-report</pre>
<p>By default, the mtr report prints into a specific order. You can rearrange the report output fields in a desired manner to make the output more productive and useful.</p>
<p>For this purpose, you will use <strong>-o</strong> flag to re-arrange the output. Run the following command on the terminal window to rearrange the output:</p>
<pre>$mtr -o "LSDR NBAW JMXI" 216.58.223.78</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-11514" src="https://vitux.com/wp-content/uploads/2020/04/word-image-116.png" alt="Format traceroute result" width="791" height="534" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-116.png 791w, https://vitux.com/wp-content/uploads/2020/04/word-image-116-300x203.png 300w, https://vitux.com/wp-content/uploads/2020/04/word-image-116-768x518.png 768w" sizes="(max-width: 791px) 100vw, 791px" /></strong></p>
<p>By default, the ICMP and the ECHO requests have a time interval of 1 second. You can change this interval by changing the interval value. To specify the new time interval, you will use the<strong> -i</strong> flag with mtr command. Run the following command to see the output:<strong>  </strong></p>
<pre>$mtr -i 2 google.com</pre>
<p>If you want to use packets of TCP SYN and UDP datagrams instead of using ICMP ECHO requests then you will use TCP and UDP flags with mtr command. Run the following command to perform the required operation:</p>
<pre>$ mtr --tcp google.com</pre>
<p>OR</p>
<pre>$ mtr --udp google.com</pre>
<p><img loading="lazy" class="aligncenter wp-image-11515" src="https://vitux.com/wp-content/uploads/2020/04/word-image-117.png" alt="Use udp for traceroute" width="734" height="412" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-117.png 734w, https://vitux.com/wp-content/uploads/2020/04/word-image-117-300x168.png 300w" sizes="(max-width: 734px) 100vw, 734px" /></p>
<p>By default, two hops have a time interval of 30 seconds. You can also define the maximum interval limit of two hops between the local machine and the remote system. Using <strong>-m</strong> flag can change the default limit. Run the following command to try this operation on your CentOS 8.0:</p>
<pre>$mtr -m 35 216.58.223.78</pre>
<p><img loading="lazy" class="aligncenter wp-image-11516" src="https://vitux.com/wp-content/uploads/2020/04/word-image-118.png" alt="Set traceroute interval" width="733" height="260" srcset="https://vitux.com/wp-content/uploads/2020/04/word-image-118.png 733w, https://vitux.com/wp-content/uploads/2020/04/word-image-118-300x106.png 300w" sizes="(max-width: 733px) 100vw, 733px" /></p>
<p>Users can check the IP packet size and network quality. Using <strong>-s</strong> flag you can change the packet size. Run the following command on the terminal to check the output:</p>
<pre>$mtr -r -s PACKETSIZE -c 5 google.com &gt;mtr-report</pre>
<p>The output will save into the mtr-report file.</p>
<p>You can also print report output in XML format. XML is a better option to make a report for automated processing. Run the following command to generate XML format output:</p>
<pre>$mtr --xml google.com</pre>
<p>From all the above-mentioned commands, you are able to deal with more mtr commands. To explore more about mtr tool you can run the following commands on the terminal:</p>
<pre>$man mtr</pre>
<p>or</p>
<pre>$mtr --help</pre>
<h2>Conclusion</h2>
<p>In the above article, we have learned how to use the mtr tool on the command line on CentOS 8. Moreover, we have explored different mtr commands that are so helpful for a network administrator. I hope this article will be helpful to you.</p>
<div class="extra-hatom-entry-title"><span class="entry-title">How to use mtr traceroute Command on CentOS 8</span></div> </div>
<footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix">
<span class="by-author author vcard"><a class="url fn n" href="https://vitux.com/author/karim/">Karim Buzdar</a></span>
<span class="date"><a href="https://vitux.com/how-to-use-mtr-command-on-centos-8/" title="11:38 am" rel="bookmark"><time class="entry-date published" datetime="2020-04-06T11:38:53+00:00">April 6, 2020</time><time class="updated" datetime="2020-11-18T11:01:44+00:00">November 18, 2020</time></a></span> <span class="category"><a href="https://vitux.com/centos/" rel="category tag">CentOS</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span>
</div></footer>
</article>
<ul class="default-wp-page clearfix">
<li class="previous"><a href="https://vitux.com/how-to-create-your-first-java-program-in-debian/" rel="prev"><span class="meta-nav">&larr;</span> How to Create your First Java Program in Debian 10</a></li>
<li class="next"><a href="https://vitux.com/how-to-use-the-history-command-on-centos/" rel="next">How to use the history command on CentOS 8 <span class="meta-nav">&rarr;</span></a></li>
</ul>
<div class="author-box clearfix">
<div class="author-img"><img src="https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=100&#038;d=mm&#038;r=g" width="100" height="100" alt="Avatar" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /></div>
<div class="author-description-wrapper">
<h4 class="author-name">Karim Buzdar</h4>
<p class="author-description">About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. He blogs at <a href="https://www.linuxways.net/" rel="nofollow">LinuxWays</a>.</p>
</div>
</div>
</div>
</div>
<div id="secondary">
<aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get">
<div class="search-wrap">
<input type="text" placeholder="Search" class="s field" name="s">
<button class="search-icon" type="submit"></button>
</div>
</form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3> <div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p>
</div>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="navDiv">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3536364066785075" data-ad-slot="6537400998" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></aside>
<aside id="wpp-5" class="widget popular-posts">
<h3 class="widget-title"><span>Most Popular</span></h3>

<ul class="wpp-list">
<li>
<a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 22, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/5-ways-to-check-available-memory-in-ubuntu/" class="wpp-post-title" target="_self">5 Ways to Check Available Memory in Ubuntu 20.04</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on April 30, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/find-devices-connected-to-your-network-with-nmap/" class="wpp-post-title" target="_self">Find Devices Connected to Your Network with nmap</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on November 30, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-setup-java_home-path-in-ubuntu/" class="wpp-post-title" target="_self">How to Set JAVA_HOME Path in Ubuntu 18.04 and 20.04 LTS</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 23, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-configure-networking-with-netplan-on-ubuntu/" class="wpp-post-title" target="_self">How to configure networking with Netplan on Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on June 3, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-manually-mount-unmount-a-usb-device-on-ubuntu/" class="wpp-post-title" target="_self">How to Manually Mount/UnMount a USB Device on Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on September 19, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-start-stop-or-restart-services-in-ubuntu/" class="wpp-post-title" target="_self">How to Start, Stop or Restart Services in Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on April 18, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/3-ways-to-reboot-ubuntu-through-the-command-line/" class="wpp-post-title" target="_self">3 Ways to Reboot Ubuntu through the Command Line</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on May 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
</ul>
</aside>
</div>
</div>
</div>
<footer id="colophon" class="clearfix">
<div class="footer-socket-wrapper clearfix">
<div class="inner-wrap">
<div class="footer-socket-area">
Copyright &copy; <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</footer>
<a href="#masthead" id="scroll-up"></a>
</div>

<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');
		</script>
<script>
	(function(){
	  if(typeof _bsa !== 'undefined' && _bsa) {
	    _bsa.init('fancybar', 'CE7I6KQJ', 'placement:vituxcom');
	  }
	})();
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/navigation.js?ver=5.5.3' id='spacious-navigation-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/skip-link-focus-fix.js?ver=5.5.3' id='spacious-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="vitux_com",_audins_did=177389;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=191-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.vitux_com,DomainId.177389" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body>
</html>
