<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData)});}}
function AddPixelById(impFullId,pixelData){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
(new Image()).src=pixelURL;}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '//ezodn.com/detroitchicago/raleigh.js?gcb=188-2&cb=1', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '//ezodn.com/detroitchicago/tampa.js?gcb=188-2&cb=1', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script><meta name="viewport" content="width=device-width, initial-scale=1"><script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Lato"] },classes:false, events:false, timeout:1500};</script><link rel="profile" href="http://gmpg.org/xfn/11" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script> <link media="all" href="https://vitux.com/wp-content/cache/autoptimize/css/autoptimize_f14bb657e24f03fb95a1c7c226b09f10.css" rel="stylesheet" /><title>Install and Configure Webmin with free Let&#039;s Encrypt SSL Certificate on Debian 10</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://vitux.com/install-and-configure-webmin-on-debian-10/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Install and Configure Webmin with free Let&#039;s Encrypt SSL Certificate on Debian 10" /><meta property="og:description" content="Webmin is a web-based remote management application for system administration that simplifies the process of managing Unix like systems. It is much easier and simpler than the traditional method in which you have to manually modify the configuration files, execute" /><meta property="og:url" content="https://vitux.com/install-and-configure-webmin-on-debian-10/" /><meta property="og:site_name" content="VITUX" /><meta property="article:publisher" content="https://www.facebook.com/vituxcom/" /><meta property="article:published_time" content="2020-07-17T06:59:50+00:00" /><meta property="article:modified_time" content="2020-07-17T07:05:39+00:00" /><meta property="og:image" content="https://vitux.com/wp-content/uploads/webmin-dashboard.png" /><meta property="og:image:width" content="1033" /><meta property="og:image:height" content="530" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@vituxcom" /><meta name="twitter:site" content="@vituxcom" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","potentialAction":[{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vitux.com/install-and-configure-webmin-on-debian-10/#primaryimage","inLanguage":"en-US","url":"https://vitux.com/wp-content/uploads/webmin-dashboard.png","width":1033,"height":530,"caption":"Webmin Dashboard"},{"@type":"WebPage","@id":"https://vitux.com/install-and-configure-webmin-on-debian-10/#webpage","url":"https://vitux.com/install-and-configure-webmin-on-debian-10/","name":"Install and Configure Webmin with free Let's Encrypt SSL Certificate on Debian 10","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/install-and-configure-webmin-on-debian-10/#primaryimage"},"datePublished":"2020-07-17T06:59:50+00:00","dateModified":"2020-07-17T07:05:39+00:00","author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vitux.com/install-and-configure-webmin-on-debian-10/"]}]},{"@type":["Person"],"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","image":{"@type":"ImageObject","@id":"https://vitux.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=96&d=mm&r=g","caption":"Karim Buzdar"},"description":"About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. You can reach Karim on LinkedIn"}]}</script> <link rel="amphtml" href="https://vitux.com/install-and-configure-webmin-on-debian-10/amp/" /><meta name="generator" content="AMP for WP 1.0.58.4" /><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" /><link rel='stylesheet' id='a3a3_lazy_load-css' href='//vitux.com/wp-content/uploads/sass/a3_lazy_load.min.css' type='text/css' media='all' /> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1594920971/out/header-5164b3ccf92958302ee1014c2cd8dce27bccbfa6.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://vitux.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://vitux.com/?p=9253' /><link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Finstall-and-configure-webmin-on-debian-10%2F" /><link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Finstall-and-configure-webmin-on-debian-10%2F&#038;format=xml" /> <script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script> <script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-158791751-45";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-158791751-45']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'vitux.com']);
_gaq.push(['f._setDomainName', 'vitux.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod11',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','vitux.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://vitux.com/install-and-configure-webmin-on-debian-10/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 177389;
var ezdomain = 'vitux.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":177389,"engaged_time_visit":0,"ezcache_level":2,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"3c13062a-aa12-42ec-4572-6bd28dfead22","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":4,"serverid":"3.235.244.134:21812","state":"VA","t_epoch":1595222122,"template_id":126,"time_on_site_visit":0,"url":"https://vitux.com/install-and-configure-webmin-on-debian-10/","user_id":0,"word_count":1406,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_177389=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["3c13062a-aa12-42ec-4572-6bd28dfead22", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="post-template-default single single-post postid-9253 single-format-standard wp-embed-responsive  better-responsive-menu narrow-1218">
<div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a><header id="masthead" class="site-header clearfix spacious-header-display-one"><div id="header-text-nav-container" class=""><div class="inner-wrap" id="spacious-header-display-one"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class=""><h3 id="site-title"> <a href="https://vitux.com/" title="VITUX" rel="home">VITUX</a></h3><p id="site-description">Linux Compendium</p> </div></div><div id="header-right-section"><div class="header-action"></div><nav id="site-navigation" class="main-navigation clearfix   " role="navigation"><p class="menu-toggle">Menu</p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li><li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li><li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li><li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li><li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li></ul></div></nav></div></div></div></div><div class="header-post-title-container clearfix"><div class="inner-wrap"><div class="post-title-wrapper"><h1 class="header-post-title-class">Install and Configure Webmin with free Let&#8217;s Encrypt SSL Certificate on Debian 10</h1></div></div></div></header><div id="main" class="clearfix"><div class="inner-wrap"><div id="primary"><div id="content" class="clearfix"><article id="post-9253" class="post-9253 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-linux category-shell"><div class="entry-content clearfix"><p>Webmin is a web-based remote management application for system administration that simplifies the process of managing Unix like systems. It is much easier and simpler than the traditional method in which you have to manually modify the configuration files, execute commands for user accounts creation, setting up servers, and much more. It let you handle these tasks with a single, standardized web-interface by automatically updating the required configuration files. With it, you can manage user accounts, setting up disk quotas, installing, removing applications, changing network-related settings, managing database, sharing files, etc.</p><p>In this article, we will guide you step-by-step to install Webmin on Debian 10 OS. We will also discuss how to configure and access Webmin with a domain name and how to secure it by using a free Let&#8217;s Encrypt SSL certificate.</p><h1>Webmin Installation on Debian 10</h1><p>Webmin is installed through a command-line terminal. In order to open the terminal, go to the Activities tab on the top left corner of the desktop. Then in the search bar, type terminal. when the terminal icon appears, click on it to open.</p><h2>Adding Webmin Repository</h2><p>There are two methods through which we can add the Webmin repository in our sources list. We will describe here both methods.</p><h3>Method 1:</h3><p>Webmin packages are not available in the official Debian repositories. It is available for download in RPM, DEB and TAR packages. So first, we will need to add the Webmin repository link to the sources.list file. For this, open the /etc/apt/sourceslist file using the following command:</p><pre>$ sudo nano /etc/apt/sources.list</pre><p>then at the bottom of the file, enter the following line to add the Webmin repository :</p><pre>deb http://download.webmin.com/download/repository sarge contrib</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9254" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image.png" alt="Edit sources.list file" width="730" height="302" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image.png 822w, https://vitux.com/wp-content/uploads/2019/12/word-image-300x124.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-768x318.png 768w" sizes="(max-width: 730px) 100vw, 730px" /><noscript><img class="aligncenter wp-image-9254" src="https://vitux.com/wp-content/uploads/2019/12/word-image.png" alt="Edit sources.list file" width="730" height="302" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image.png 822w, https://vitux.com/wp-content/uploads/2019/12/word-image-300x124.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-768x318.png 768w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></h1><p>Once done, press <strong>Ctrl+O </strong>to save and then <strong>Ctrl+X</strong> to exit.</p><p>Next in this step, we will have to fetch the Webmin PGP key with which the repository was signed. Execute the following command to do so:</p><pre>$ wget http://www.webmin.com/jcameron-key.asc</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9255" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-1.png" alt="Download the repository key" width="730" height="314" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-1.png 795w, https://vitux.com/wp-content/uploads/2019/12/word-image-1-300x129.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-1-768x330.png 768w" sizes="(max-width: 730px) 100vw, 730px" /><noscript><img class="aligncenter wp-image-9255" src="https://vitux.com/wp-content/uploads/2019/12/word-image-1.png" alt="Download the repository key" width="730" height="314" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-1.png 795w, https://vitux.com/wp-content/uploads/2019/12/word-image-1-300x129.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-1-768x330.png 768w" sizes="(max-width: 730px) 100vw, 730px" /></noscript></h1><p>Now add the key using the following command:</p><h1><img class="lazy lazy-hidden aligncenter wp-image-9256" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-2.png" alt="Add repository key" width="600" height="55" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-2.png 600w, https://vitux.com/wp-content/uploads/2019/12/word-image-2-300x28.png 300w" sizes="(max-width: 600px) 100vw, 600px" /><noscript><img class="aligncenter wp-image-9256" src="https://vitux.com/wp-content/uploads/2019/12/word-image-2.png" alt="Add repository key" width="600" height="55" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-2.png 600w, https://vitux.com/wp-content/uploads/2019/12/word-image-2-300x28.png 300w" sizes="(max-width: 600px) 100vw, 600px" /></noscript></h1><h3>Method 2:</h3><p>There is an alternative way of adding the repository and key. Follow the below steps to do so:</p><p>To download and add the Webmin repository key, execute the following command in Terminal:</p><pre>$ wget -qO- http://www.webmin.com/jcameron-key.asc | sudo apt-key add</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9257" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-3.png" alt="Download and install key in one step" width="774" height="91" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-3.png 851w, https://vitux.com/wp-content/uploads/2019/12/word-image-3-300x35.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-3-768x90.png 768w" sizes="(max-width: 774px) 100vw, 774px" /><noscript><img class="aligncenter wp-image-9257" src="https://vitux.com/wp-content/uploads/2019/12/word-image-3.png" alt="Download and install key in one step" width="774" height="91" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-3.png 851w, https://vitux.com/wp-content/uploads/2019/12/word-image-3-300x35.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-3-768x90.png 768w" sizes="(max-width: 774px) 100vw, 774px" /></noscript></h1><p>Then to add the Webmin repository, execute the following command in Terminal:</p><pre>$ sudo add-apt-repository "deb http://download.webmin.com/download/repository sarge contrib"</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9258" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-4.png" alt="Add the repository" width="707" height="44" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-4.png 851w, https://vitux.com/wp-content/uploads/2019/12/word-image-4-300x19.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-4-768x48.png 768w" sizes="(max-width: 707px) 100vw, 707px" /><noscript><img class="aligncenter wp-image-9258" src="https://vitux.com/wp-content/uploads/2019/12/word-image-4.png" alt="Add the repository" width="707" height="44" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-4.png 851w, https://vitux.com/wp-content/uploads/2019/12/word-image-4-300x19.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-4-768x48.png 768w" sizes="(max-width: 707px) 100vw, 707px" /></noscript></h1><h2>Install Webmin</h2><p>Now we will update the Debian list of packages with the Webmin repository. For that, run the following command in terminal:</p><pre>$ sudo apt update</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9259" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-5.png" alt="Update repository package list" width="772" height="313" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-5.png 1129w, https://vitux.com/wp-content/uploads/2019/12/word-image-5-300x122.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-5-1024x415.png 1024w, https://vitux.com/wp-content/uploads/2019/12/word-image-5-768x312.png 768w" sizes="(max-width: 772px) 100vw, 772px" /><noscript><img class="aligncenter wp-image-9259" src="https://vitux.com/wp-content/uploads/2019/12/word-image-5.png" alt="Update repository package list" width="772" height="313" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-5.png 1129w, https://vitux.com/wp-content/uploads/2019/12/word-image-5-300x122.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-5-1024x415.png 1024w, https://vitux.com/wp-content/uploads/2019/12/word-image-5-768x312.png 768w" sizes="(max-width: 772px) 100vw, 772px" /></noscript></h1><p>Then install Webmin by running the following command in Terminal:</p><pre>$ sudo apt install webmin</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9260" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-6.png" alt="Install Webmin" width="779" height="282" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-6.png 804w, https://vitux.com/wp-content/uploads/2019/12/word-image-6-300x109.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-6-768x278.png 768w" sizes="(max-width: 779px) 100vw, 779px" /><noscript><img class="aligncenter wp-image-9260" src="https://vitux.com/wp-content/uploads/2019/12/word-image-6.png" alt="Install Webmin" width="779" height="282" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-6.png 804w, https://vitux.com/wp-content/uploads/2019/12/word-image-6-300x109.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-6-768x278.png 768w" sizes="(max-width: 779px) 100vw, 779px" /></noscript></h1><p>The system will ask for confirmation by providing with <strong>Y/n</strong> option. Hit <strong>Y</strong> to confirm.</p><p>After the installation is completed, look for these lines at the end of the output:</p><h1><img class="lazy lazy-hidden aligncenter wp-image-9261" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-7.png" alt="Webmin installation complete" width="771" height="71" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-7.png 836w, https://vitux.com/wp-content/uploads/2019/12/word-image-7-300x28.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-7-768x71.png 768w" sizes="(max-width: 771px) 100vw, 771px" /><noscript><img class="aligncenter wp-image-9261" src="https://vitux.com/wp-content/uploads/2019/12/word-image-7.png" alt="Webmin installation complete" width="771" height="71" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-7.png 836w, https://vitux.com/wp-content/uploads/2019/12/word-image-7-300x28.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-7-768x71.png 768w" sizes="(max-width: 771px) 100vw, 771px" /></noscript></h1><h2>Configure Webmin</h2><p>Here, we will create an Apache virtual host to access Webmin using the domain name. We will also set up Apache to sit in front of Webmin and accept requests over port 80. Then those requests will be sent over to Webmin running on port 10000. This step will assume you have an Apache server installed already.</p><p>I will use the domain name yourdomain.tld as an example domain name below. Replace it with your own domain name wherever it occurs in the files we create below and also in the commands.</p><p>(Note: This step is not necessary if you want to access Webmin only on localhost.)</p><h3>Step 1: Create a new Apache virtual host file</h3><p>To create a new Apache virtual host file under /etc/apache2/sites-available/, run the following command in terminal:</p><pre>$ sudo nano /etc/apache2/sites-available/yourdomain_tld.conf</pre><p>Add the following lines in it:</p><pre>&lt;VirtualHost *:80&gt;
  ServerAdmin <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="631a0c16231a0c1611070c0e020a0d4d170f07">[email&#160;protected]</a>
  ServerName yourdomain.tld
  ProxyPass / http://localhost:10000/
  ProxyPassReverse / http://localhost:10000/
&lt;/VirtualHost&gt;</pre><p>Replace <strong>your_email</strong> and <strong>your_domainName</strong> with your own email address and domain name.</p><h1><img class="lazy lazy-hidden aligncenter wp-image-9262" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-8.png" alt="Webmin virtual host" width="698" height="288" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-8.png 700w, https://vitux.com/wp-content/uploads/2019/12/word-image-8-300x124.png 300w" sizes="(max-width: 698px) 100vw, 698px" /><noscript><img class="aligncenter wp-image-9262" src="https://vitux.com/wp-content/uploads/2019/12/word-image-8.png" alt="Webmin virtual host" width="698" height="288" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-8.png 700w, https://vitux.com/wp-content/uploads/2019/12/word-image-8-300x124.png 300w" sizes="(max-width: 698px) 100vw, 698px" /></noscript></h1><p>The above configuration will allow Apache to sent requests to the Webmin server running at port 10000. Once done, use <strong>Ctrl+O</strong> to save and then <strong>Ctrl+X</strong> to exit the file.</p><h3>Step 2: Stop Webmin from using TLS/SSL</h3><p>In this step, we will guide Webmin to stop using SSL/TLS as Apache will provide us with that. For that, open the file miniserv.conf located at /etc/webmin/ using the following command:</p><pre>$ sudo nano /etc/webmin/miniserv.conf</pre><p>Find the line <strong>ssl=1</strong> and change it to <strong>ssl=0</strong>, as shown below:</p><h1><img class="lazy lazy-hidden aligncenter wp-image-9265" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-11.png" alt="Configure Webmin" width="755" height="385" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-11.png 755w, https://vitux.com/wp-content/uploads/2019/12/word-image-11-300x153.png 300w" sizes="(max-width: 755px) 100vw, 755px" /><noscript><img class="aligncenter wp-image-9265" src="https://vitux.com/wp-content/uploads/2019/12/word-image-11.png" alt="Configure Webmin" width="755" height="385" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-11.png 755w, https://vitux.com/wp-content/uploads/2019/12/word-image-11-300x153.png 300w" sizes="(max-width: 755px) 100vw, 755px" /></noscript></h1><p>Once done, press <strong>Ctrl+O</strong> to save and <strong>Ctrl+X</strong> to exit.</p><h3>Step 3: Add your domain name to the list of allowed domains</h3><p>The next thing to do it to add your domain name to the list of allowed domains in the Webmin configuration. Open the file through this command:</p><p>Next, we will add our domain name to the list of allowed domains in the Webmin configuration file. To edit the configuration file, enter the following command in terminal:</p><pre>$ sudo nano /etc/webmin/config</pre><p>At the end of the file, add the following line:</p><pre>referers=yourdomain.tld</pre><p>Replace <strong>yourdomain.tld</strong> with your domain name. once done, use <strong>Ctrl+O</strong> to save and <strong>Ctrl+X</strong> to exit the file.</p><h1><img class="lazy lazy-hidden aligncenter wp-image-9266" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-12.png" alt="Webmin Config file" width="707" height="359" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-12.png 853w, https://vitux.com/wp-content/uploads/2019/12/word-image-12-300x152.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-12-768x390.png 768w" sizes="(max-width: 707px) 100vw, 707px" /><noscript><img class="aligncenter wp-image-9266" src="https://vitux.com/wp-content/uploads/2019/12/word-image-12.png" alt="Webmin Config file" width="707" height="359" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-12.png 853w, https://vitux.com/wp-content/uploads/2019/12/word-image-12-300x152.png 300w, https://vitux.com/wp-content/uploads/2019/12/word-image-12-768x390.png 768w" sizes="(max-width: 707px) 100vw, 707px" /></noscript></h1><h3>Step 4: Restart Webmin to apply configurations</h3><p>To apply the above configuration changes, we will need to restart the Webmin service. Run the following command to do so:</p><pre>$ sudo systemctl restart Webmin</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9267" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-13.png" alt="Restart Webmin" width="554" height="30" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-13.png 554w, https://vitux.com/wp-content/uploads/2019/12/word-image-13-300x16.png 300w" sizes="(max-width: 554px) 100vw, 554px" /><noscript><img class="aligncenter wp-image-9267" src="https://vitux.com/wp-content/uploads/2019/12/word-image-13.png" alt="Restart Webmin" width="554" height="30" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-13.png 554w, https://vitux.com/wp-content/uploads/2019/12/word-image-13-300x16.png 300w" sizes="(max-width: 554px) 100vw, 554px" /></noscript></h1><h3>Step 5: Activate the Apache proxy_http module and your Apache Virtual Host</h3><p>First, enable the Apache’s proxy_http module using the following command:</p><pre>$ sudo a2enmod proxy_http</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9268" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-14.png" alt="Enable Proxy module" width="618" height="146" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-14.png 618w, https://vitux.com/wp-content/uploads/2019/12/word-image-14-300x71.png 300w" sizes="(max-width: 618px) 100vw, 618px" /><noscript><img class="aligncenter wp-image-9268" src="https://vitux.com/wp-content/uploads/2019/12/word-image-14.png" alt="Enable Proxy module" width="618" height="146" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-14.png 618w, https://vitux.com/wp-content/uploads/2019/12/word-image-14-300x71.png 300w" sizes="(max-width: 618px) 100vw, 618px" /></noscript></h1><p>Now restart the apache2 service to activate new configuration:</p><pre>$ sudo systemctl restart apache2</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9269" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-15.png" alt="Restart Apache" width="563" height="32" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-15.png 563w, https://vitux.com/wp-content/uploads/2019/12/word-image-15-300x17.png 300w" sizes="(max-width: 563px) 100vw, 563px" /><noscript><img class="aligncenter wp-image-9269" src="https://vitux.com/wp-content/uploads/2019/12/word-image-15.png" alt="Restart Apache" width="563" height="32" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-15.png 563w, https://vitux.com/wp-content/uploads/2019/12/word-image-15-300x17.png 300w" sizes="(max-width: 563px) 100vw, 563px" /></noscript></h1><p>Then enable the Apache virtual host through the following command:</p><pre>$ sudo a2ensite yourdomain.tld</pre><h1><img class="lazy lazy-hidden aligncenter wp-image-9270" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/12/word-image-16.png" alt="Activate website vhost" width="553" height="52" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-16.png 553w, https://vitux.com/wp-content/uploads/2019/12/word-image-16-300x28.png 300w" sizes="(max-width: 553px) 100vw, 553px" /><noscript><img class="aligncenter wp-image-9270" src="https://vitux.com/wp-content/uploads/2019/12/word-image-16.png" alt="Activate website vhost" width="553" height="52" srcset="https://vitux.com/wp-content/uploads/2019/12/word-image-16.png 553w, https://vitux.com/wp-content/uploads/2019/12/word-image-16-300x28.png 300w" sizes="(max-width: 553px) 100vw, 553px" /></noscript></h1><p>Finally restart the Apache2 service.</p><h2>Secure Webmin with a free Let&#8217;s Encrypt SSL Certificate</h2><p>To secure Webmin with a free Let&#8217;s Encrypt SSL certificate, we will install Certbot Let&#8217;s Encrypt client.</p><pre>apt-get install certbot python-certbot-apache</pre><p>Then run certbot command to get a free SSL certificate:</p><pre>certbot --apache</pre><p>Select your Webmin website in the dialog that appears on the screen.</p><h2>Access Webmin</h2><p>To access Webmin, navigate to the following address:</p><pre>https://yourdomain.tld</pre><p>You will see the following login page. Log in using the root or another privileged user.</p><p style="text-align: center;"><img class="lazy lazy-hidden alignnone wp-image-13996 size-full" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/webmin-login.png" alt="Webmin Login" width="948" height="489" srcset="" data-srcset="https://vitux.com/wp-content/uploads/webmin-login.png 948w, https://vitux.com/wp-content/uploads/webmin-login-300x155.png 300w, https://vitux.com/wp-content/uploads/webmin-login-768x396.png 768w" sizes="(max-width: 948px) 100vw, 948px" /><noscript><img class="alignnone wp-image-13996 size-full" src="https://vitux.com/wp-content/uploads/webmin-login.png" alt="Webmin Login" width="948" height="489" srcset="https://vitux.com/wp-content/uploads/webmin-login.png 948w, https://vitux.com/wp-content/uploads/webmin-login-300x155.png 300w, https://vitux.com/wp-content/uploads/webmin-login-768x396.png 768w" sizes="(max-width: 948px) 100vw, 948px" /></noscript></p><p>Once logged in, you will see the dashboard similar to below providing you with the basic information about your system:</p><p style="text-align: center;"><img class="lazy lazy-hidden alignnone wp-image-13997 size-full" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/webmin-dashboard.png" alt="Webmin Dashboard" width="1033" height="530" srcset="" data-srcset="https://vitux.com/wp-content/uploads/webmin-dashboard.png 1033w, https://vitux.com/wp-content/uploads/webmin-dashboard-300x154.png 300w, https://vitux.com/wp-content/uploads/webmin-dashboard-1024x525.png 1024w, https://vitux.com/wp-content/uploads/webmin-dashboard-768x394.png 768w" sizes="(max-width: 1033px) 100vw, 1033px" /><noscript><img class="alignnone wp-image-13997 size-full" src="https://vitux.com/wp-content/uploads/webmin-dashboard.png" alt="Webmin Dashboard" width="1033" height="530" srcset="https://vitux.com/wp-content/uploads/webmin-dashboard.png 1033w, https://vitux.com/wp-content/uploads/webmin-dashboard-300x154.png 300w, https://vitux.com/wp-content/uploads/webmin-dashboard-1024x525.png 1024w, https://vitux.com/wp-content/uploads/webmin-dashboard-768x394.png 768w" sizes="(max-width: 1033px) 100vw, 1033px" /></noscript></p><p>So, we have learned how to install and configure Webmin on a Debian OS. Now you can use this user-friendly and web-based admin tool for administering and managing Linux servers, packages, and users on the fly! It is a really helpful tool for both aspiring and professional system administrators.</p><div class="extra-hatom-entry-title"><span class="entry-title">Install and Configure Webmin with free Let&#8217;s Encrypt SSL Certificate on Debian 10</span></div></div><footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix"> <span class="by-author author vcard"><a class="url fn n" href="https://vitux.com/author/karim/">Karim Buzdar</a></span><span class="date"><a href="https://vitux.com/install-and-configure-webmin-on-debian-10/" title="6:59 am" rel="bookmark"><time class="entry-date published" datetime="2020-07-17T06:59:50+00:00">July 17, 2020</time><time class="updated" datetime="2020-07-17T07:05:39+00:00">July 17, 2020</time></a></span> <span class="category"><a href="https://vitux.com/debian/" rel="category tag">Debian</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span></div></footer></article><ul class="default-wp-page clearfix"><li class="previous"><a href="https://vitux.com/how-to-uninstall-programs-on-debian/" rel="prev"><span class="meta-nav">&larr;</span> How to Uninstall Programs on Debian</a></li><li class="next"></li></ul><div class="author-box clearfix"><div class="author-img"><img src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=100&#038;d=mm&#038;r=g" width="100" height="100" alt="Avatar" class="lazy lazy-hidden avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /><noscript><img src="https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=100&#038;d=mm&#038;r=g" width="100" height="100" alt="Avatar" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /></noscript></div><div class="author-description-wrapper"><h4 class="author-name">Karim Buzdar</h4><p class="author-description">About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. You can reach Karim on <a href="https://www.linkedin.com/in/karimbuzdar/" rel="nofollow">LinkedIn</a></p></div></div></div></div><div id="secondary"><aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3><div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="navDiv"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3536364066785075" data-ad-slot="6537400998" data-ad-format="auto" data-full-width-responsive="true"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </div></div></aside><aside id="wpp-5" class="widget popular-posts"><h3 class="widget-title"><span>Most Popular</span></h3> <ul class="wpp-list"><li> <a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-find-files-on-the-ubuntu-command-line/" class="wpp-post-title" target="_self">How to find files on the Ubuntu command line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 26, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-download-a-file-on-ubuntu-linux-using-the-command-line/" class="wpp-post-title" target="_self">How to Download a File on Ubuntu Linux using the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 24, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-xampp-on-your-ubuntu-18-04-lts-system/" class="wpp-post-title" target="_self">How to Install XAMPP on your Ubuntu 18.04 LTS System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 2, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on April 30, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/5-ways-to-check-available-memory-in-ubuntu/" class="wpp-post-title" target="_self">5 Ways to Check Available Memory in Ubuntu 20.04</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on April 30, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/ubuntu-network-configuration/" class="wpp-post-title" target="_self">How to Configure Network Settings in Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 24, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/find-devices-connected-to-your-network-with-nmap/" class="wpp-post-title" target="_self">Find Devices Connected to Your Network with nmap</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 30, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-edit-config-files-in-ubuntu/" class="wpp-post-title" target="_self">How to Edit Config Files in Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on May 2, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li></ul></aside></div></div></div><footer id="colophon" class="clearfix"><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"> Copyright &copy; <a href="https://vitux.com">vitux.com</a><nav class="small-menu clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li></ul></div></nav></div></div></div></footer> <a href="#masthead" id="scroll-up"></a></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');</script> <script>(function(){
	  if(typeof _bsa !== 'undefined' && _bsa) {
	    _bsa.init('fancybar', 'CE7I6KQJ', 'placement:vituxcom');
	  }
	})();</script> <script type='text/javascript'>/*  */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0","horizontal_container_classnames":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1594920971/out/footer-935d2afa406c7e4ed77187acf420210d9256d42a.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script> <script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=33', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=33', false, [], true, false, false, false);
</script>
<script>var _audins_dom="vitux_com",_audins_did=177389;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.vitux_com,DomainId.177389" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'></script></body></html>
