<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><title>How to Downgrade Packages on Ubuntu</title><!-- This site is optimized with the Yoast SEO plugin v11.7 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://vitux.com/how-to-downgrade-packages-on-ubuntu/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Downgrade Packages on Ubuntu" /><meta property="og:description" content="Ubuntu package manager keeps the packages updated by upgrading them to the latest version. But sometimes due to the upgrade, programs do not work smoothly because of bugs or compatibility issues in the new version as compared to the previous" /><meta property="og:url" content="https://vitux.com/how-to-downgrade-packages-on-ubuntu/" /><meta property="og:site_name" content="VITUX" /><meta property="article:publisher" content="https://www.facebook.com/vituxcom/" /><meta property="article:section" content="Ubuntu" /><meta property="article:published_time" content="2019-07-23T18:52:34+00:00" /><meta property="article:modified_time" content="2019-07-23T19:03:20+00:00" /><meta property="og:updated_time" content="2019-07-23T19:03:20+00:00" /><meta property="og:image" content="https://vitux.com/wp-content/uploads/2019/06/downgrade-ubuntu-packages.jpg" /><meta property="og:image:secure_url" content="https://vitux.com/wp-content/uploads/2019/06/downgrade-ubuntu-packages.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="512" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Ubuntu package manager keeps the packages updated by upgrading them to the latest version. But sometimes due to the upgrade, programs do not work smoothly because of bugs or compatibility issues in the new version as compared to the previous" /><meta name="twitter:title" content="How to Downgrade Packages on Ubuntu" /><meta name="twitter:site" content="@vituxcom" /><meta name="twitter:image" content="https://vitux.com/wp-content/uploads/2019/06/downgrade-ubuntu-packages.jpg" /><meta name="twitter:creator" content="@vituxcom" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","publisher":{"@id":"https://vitux.com/#/schema/person/8cb93983c98be876deba153eab5eccee"},"potentialAction":{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/#primaryimage","url":"https://vitux.com/wp-content/uploads/2019/06/downgrade-ubuntu-packages.jpg","width":1024,"height":512,"caption":"Downgrade Ubuntu Packages"},{"@type":"WebPage","@id":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/#webpage","url":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/","inLanguage":"en-US","name":"How to Downgrade Packages on Ubuntu","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/#primaryimage"},"datePublished":"2019-07-23T18:52:34+00:00","dateModified":"2019-07-23T19:03:20+00:00"},{"@type":"Article","@id":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/#article","isPartOf":{"@id":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/#webpage"},"author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"headline":"How to Downgrade Packages on Ubuntu","datePublished":"2019-07-23T18:52:34+00:00","dateModified":"2019-07-23T19:03:20+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/#webpage"},"publisher":{"@id":"https://vitux.com/#/schema/person/8cb93983c98be876deba153eab5eccee"},"image":{"@id":"https://vitux.com/how-to-downgrade-packages-on-ubuntu/#primaryimage"},"articleSection":"Desktop,Shell,Ubuntu"},{"@type":["Person"],"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","sameAs":[]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" /><link rel='stylesheet' id='wp-block-library-css'  href='https://vitux.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://vitux.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='https://vitux.com/wp-content/themes/spacious/style.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious_style-css'  href='https://vitux.com/wp-content/themes/vitux/style.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious-genericons-css'  href='https://vitux.com/wp-content/themes/spacious/genericons/genericons.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious-font-awesome-css'  href='https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='google_fonts-css'  href='//fonts.googleapis.com/css?family=Lato&#038;ver=5.2.2' type='text/css' media='all' /><link rel='stylesheet' id='jquery-lazyloadxt-fadein-css-css'  href='//vitux.com/wp-content/plugins/a3-lazy-load/assets/css/jquery.lazyloadxt.fadein.css' type='text/css' media='all' /><link rel='stylesheet' id='a3a3_lazy_load-css'  href='//vitux.com/wp-content/uploads/sass/a3_lazy_load.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"6038","token":"35781a2c5b","debug":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1563900759/out/header-b69312bd.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://vitux.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.2" /><link rel='shortlink' href='https://vitux.com/?p=6038' /><link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-downgrade-packages-on-ubuntu%2F" /><link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-downgrade-packages-on-ubuntu%2F&#038;format=xml" /></head><body class="post-template-default single single-post postid-6038 single-format-standard  better-responsive-menu"><div id="page" class="hfeed site"> <header id="masthead" class="site-header clearfix "><div id="header-text-nav-container"><div class="inner-wrap"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class=""><h3 id="site-title"> <a href="https://vitux.com/"
title="VITUX"
rel="home">VITUX</a></h3><p id="site-description">Linux Compendium</p> <!-- #site-description --></div><!-- #header-text --></div><!-- #header-left-section --><div id="header-right-section"><div class="header-action"></div> <nav id="site-navigation" class="main-navigation" role="navigation"><p class="menu-toggle">Menu</p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li><li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li><li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li><li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li><li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li></ul></div> </nav></div><!-- #header-right-section --></div><!-- #header-text-nav-wrap --></div><!-- .inner-wrap --></div><!-- #header-text-nav-container --><div class="header-post-title-container clearfix"><div class="inner-wrap"><div class="post-title-wrapper"><h1 class="header-post-title-class">How to Downgrade Packages on Ubuntu</h1></div></div></div> </header><div id="main" class="clearfix"><div class="inner-wrap"><div id="primary"><div id="content" class="clearfix"> <article id="post-6038" class="post-6038 post type-post status-publish format-standard has-post-thumbnail hentry category-desktop category-shell category-ubuntu"><div class="entry-content clearfix"><p>Ubuntu package manager keeps the packages updated by upgrading them to the latest version. But sometimes due to the upgrade, programs do not work smoothly because of bugs or compatibility issues in the new version as compared to the previous versions. We can overcome this issue by downgrading the installed packages to their earlier versions where they were working fine and then locking down them at a particular version to prevent them from being updated automatically in the future.</p><p>In this article, we will see how to downgrade an installed package on Ubuntu. There are two different ways using which we can use to downgrade an installed package to its earlier version:</p><ol><li>Using Synaptic Package Manager</li><li>Using Terminal</li></ol><p>We will see how to use both of these ways to downgrade Firefox application in Ubuntu. However, you can follow this same procedure for downgrading other applications too.</p><p>We will use Ubuntu 18.04 LTS for describing the procedure mentioned in this article.</p><h2>Downgrade packages using Synaptic Package Manager</h2><p>The Synaptic package manager is a graphical-based package management application that is more powerful than Ubuntu’s software center. Using it, you can install, upgrade, downgrade and remove packages, search for packages using filers, lock packages and much more using its user-friendly GUI interface.</p><p><strong>Step 1:</strong> It is not installed by default in Ubuntu 18.04 LTS, so we will need to first install synaptic package manager. For that, open the Terminal by using <strong>Ctrl+Alt+T</strong> key shortcut. Then enter the following command:</p><pre>$ sudo apt install synaptic</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6039" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-267.png" alt="Install Synaptic package manager" width="890" height="286" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-267.png 1160w, https://vitux.com/wp-content/uploads/2019/06/word-image-267-300x96.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-267-768x247.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-267-1024x329.png 1024w" sizes="(max-width: 890px) 100vw, 890px" /><noscript><img class="aligncenter wp-image-6039" src="https://vitux.com/wp-content/uploads/2019/06/word-image-267.png" alt="Install Synaptic package manager" width="890" height="286" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-267.png 1160w, https://vitux.com/wp-content/uploads/2019/06/word-image-267-300x96.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-267-768x247.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-267-1024x329.png 1024w" sizes="(max-width: 890px) 100vw, 890px" /></noscript></p><p>Wait for a while until the installation is completed.</p><p><strong>Step 2:</strong> Once the installation is completed, run the following command in Terminal to launch the Synaptic package manager.</p><pre>$ sudo synaptic</pre><p>It will prompt for the password. Enter the password to authenticate it.</p><p><strong>Step 3:</strong> In the main application window, search for the package you to want to downgrade. For that, click on the <strong>Search</strong> button from the toolbar. In the search box, type the package name and click on <strong>Search</strong>. We are going to downgrade Firefox application, so we will type <strong><em>firefox</em></strong> in the search bar.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6040" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-268.png" alt="Search for pacage name" width="892" height="351" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-268.png 1178w, https://vitux.com/wp-content/uploads/2019/06/word-image-268-300x118.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-268-768x303.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-268-1024x403.png 1024w" sizes="(max-width: 892px) 100vw, 892px" /><noscript><img class="aligncenter wp-image-6040" src="https://vitux.com/wp-content/uploads/2019/06/word-image-268.png" alt="Search for pacage name" width="892" height="351" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-268.png 1178w, https://vitux.com/wp-content/uploads/2019/06/word-image-268-300x118.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-268-768x303.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-268-1024x403.png 1024w" sizes="(max-width: 892px) 100vw, 892px" /></noscript></p><p><strong>Step 4:</strong> When the search result appears, select the Firefox application. You will see the current and the latest available versions of the Firefox application. Then from the menu bar, click on <strong>Package</strong>, and then select <strong>Force Version</strong>.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6041" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-269.png" alt="Force software version" width="890" height="326" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-269.png 1409w, https://vitux.com/wp-content/uploads/2019/06/word-image-269-300x110.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-269-768x281.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-269-1024x375.png 1024w" sizes="(max-width: 890px) 100vw, 890px" /><noscript><img class="aligncenter wp-image-6041" src="https://vitux.com/wp-content/uploads/2019/06/word-image-269.png" alt="Force software version" width="890" height="326" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-269.png 1409w, https://vitux.com/wp-content/uploads/2019/06/word-image-269-300x110.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-269-768x281.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-269-1024x375.png 1024w" sizes="(max-width: 890px) 100vw, 890px" /></noscript></p><p>A dialog box will appear that will allow you to choose the version of the package you want to downgrade to. Select the required version from the drop-down menu and click <strong>Force Version</strong> button.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6042" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-270.png" alt="Confirm that you want to force a specific version" width="891" height="145" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-270.png 1231w, https://vitux.com/wp-content/uploads/2019/06/word-image-270-300x49.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-270-768x125.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-270-1024x166.png 1024w" sizes="(max-width: 891px) 100vw, 891px" /><noscript><img class="aligncenter wp-image-6042" src="https://vitux.com/wp-content/uploads/2019/06/word-image-270.png" alt="Confirm that you want to force a specific version" width="891" height="145" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-270.png 1231w, https://vitux.com/wp-content/uploads/2019/06/word-image-270-300x49.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-270-768x125.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-270-1024x166.png 1024w" sizes="(max-width: 891px) 100vw, 891px" /></noscript></p><p><strong>Step 5:</strong> Then from the toolbar, click on <strong>Apply </strong>to save the changes.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6043" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-271.png" alt="Apply changes" width="891" height="324" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-271.png 1406w, https://vitux.com/wp-content/uploads/2019/06/word-image-271-300x109.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-271-768x279.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-271-1024x372.png 1024w" sizes="(max-width: 891px) 100vw, 891px" /><noscript><img class="aligncenter wp-image-6043" src="https://vitux.com/wp-content/uploads/2019/06/word-image-271.png" alt="Apply changes" width="891" height="324" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-271.png 1406w, https://vitux.com/wp-content/uploads/2019/06/word-image-271-300x109.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-271-768x279.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-271-1024x372.png 1024w" sizes="(max-width: 891px) 100vw, 891px" /></noscript></p><p>A confirmation dialog box will appear, click on <strong>Apply</strong> to confirm.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6044" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-272.png" alt="Show details" width="892" height="417" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-272.png 954w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-300x140.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-768x359.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-750x350.png 750w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-642x300.png 642w" sizes="(max-width: 892px) 100vw, 892px" /><noscript><img class="aligncenter wp-image-6044" src="https://vitux.com/wp-content/uploads/2019/06/word-image-272.png" alt="Show details" width="892" height="417" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-272.png 954w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-300x140.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-768x359.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-750x350.png 750w, https://vitux.com/wp-content/uploads/2019/06/word-image-272-642x300.png 642w" sizes="(max-width: 892px) 100vw, 892px" /></noscript></p><p>Now it will start downloading the older package.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6045" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-273.png" alt="Download package files" width="820" height="189" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-273.png 850w, https://vitux.com/wp-content/uploads/2019/06/word-image-273-300x69.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-273-768x177.png 768w" sizes="(max-width: 820px) 100vw, 820px" /><noscript><img class="aligncenter wp-image-6045" src="https://vitux.com/wp-content/uploads/2019/06/word-image-273.png" alt="Download package files" width="820" height="189" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-273.png 850w, https://vitux.com/wp-content/uploads/2019/06/word-image-273-300x69.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-273-768x177.png 768w" sizes="(max-width: 820px) 100vw, 820px" /></noscript></p><p>Once the download is finished, you will note that the installed version is now <strong>59.0.2+build1-0ubuntu1 </strong>in the Synaptic application window that has downgraded from <strong>65.0+build2-0ubuntu0.18.04.1.</strong></p><p><strong>Step 6:</strong> After downgrading the Firefox package, you can also prevent the package from being updated automatically by locking it at a specific version. Select the downgraded Firefox application, and from the top menu bar, click on <strong>Package</strong>. Then select <strong>Lock Version</strong>. Next time when you upgrade your packages, this locked package will not be upgraded.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6046" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-274.png" alt="Lock software version" width="890" height="319" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-274.png 1413w, https://vitux.com/wp-content/uploads/2019/06/word-image-274-300x107.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-274-768x275.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-274-1024x367.png 1024w" sizes="(max-width: 890px) 100vw, 890px" /><noscript><img class="aligncenter wp-image-6046" src="https://vitux.com/wp-content/uploads/2019/06/word-image-274.png" alt="Lock software version" width="890" height="319" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-274.png 1413w, https://vitux.com/wp-content/uploads/2019/06/word-image-274-300x107.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-274-768x275.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-274-1024x367.png 1024w" sizes="(max-width: 890px) 100vw, 890px" /></noscript></p><p>Once done with the process, you can also view the current version of the Firefox by using the Firefox menu. Click on the Firefox menu button on the right side of its window, and then click on <strong>Help</strong> as shown in below screenshot.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6047" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-275.png" alt="Check installed version" width="845" height="443" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-275.png 1274w, https://vitux.com/wp-content/uploads/2019/06/word-image-275-300x157.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-275-768x403.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-275-1024x537.png 1024w" sizes="(max-width: 845px) 100vw, 845px" /><noscript><img class="aligncenter wp-image-6047" src="https://vitux.com/wp-content/uploads/2019/06/word-image-275.png" alt="Check installed version" width="845" height="443" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-275.png 1274w, https://vitux.com/wp-content/uploads/2019/06/word-image-275-300x157.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-275-768x403.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-275-1024x537.png 1024w" sizes="(max-width: 845px) 100vw, 845px" /></noscript></p><p>Then from the sub-menu, select <strong>About Firefox</strong>.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6048" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-276.png" alt="About Firefox" width="844" height="439" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-276.png 1275w, https://vitux.com/wp-content/uploads/2019/06/word-image-276-300x156.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-276-768x399.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-276-1024x532.png 1024w" sizes="(max-width: 844px) 100vw, 844px" /><noscript><img class="aligncenter wp-image-6048" src="https://vitux.com/wp-content/uploads/2019/06/word-image-276.png" alt="About Firefox" width="844" height="439" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-276.png 1275w, https://vitux.com/wp-content/uploads/2019/06/word-image-276-300x156.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-276-768x399.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-276-1024x532.png 1024w" sizes="(max-width: 844px) 100vw, 844px" /></noscript></p><p><strong>About Mozilla Firefox</strong> window will appear. You can see here the version number.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6049" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-277.png" alt="Firefox version" width="842" height="344" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-277.png 908w, https://vitux.com/wp-content/uploads/2019/06/word-image-277-300x123.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-277-768x314.png 768w" sizes="(max-width: 842px) 100vw, 842px" /><noscript><img class="aligncenter wp-image-6049" src="https://vitux.com/wp-content/uploads/2019/06/word-image-277.png" alt="Firefox version" width="842" height="344" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-277.png 908w, https://vitux.com/wp-content/uploads/2019/06/word-image-277-300x123.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-277-768x314.png 768w" sizes="(max-width: 842px) 100vw, 842px" /></noscript></p><h2>Downgrade packages using Ubuntu Terminal</h2><p>We can also use the Terminal application in Ubuntu for downgrading packages. Press <strong>Ctrl+Alt+T</strong> to launch the Terminal.</p><p><strong>Step 1:</strong> To list the available version of a specific package in the repositories, run the following command in Terminal:</p><pre>$ sudo apt-cache showpkg package-name</pre><p>For instance, to downgrade the Mozilla Firefox application to the older version, we will use the following command. It will search the repository for older versions of Firefox:</p><pre>$ sudo apt-cache showpkg firefox</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6050" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-278.png" alt="Show available package versions" width="888" height="231" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-278.png 1200w, https://vitux.com/wp-content/uploads/2019/06/word-image-278-300x78.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-278-768x200.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-278-1024x266.png 1024w" sizes="(max-width: 888px) 100vw, 888px" /><noscript><img class="aligncenter wp-image-6050" src="https://vitux.com/wp-content/uploads/2019/06/word-image-278.png" alt="Show available package versions" width="888" height="231" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-278.png 1200w, https://vitux.com/wp-content/uploads/2019/06/word-image-278-300x78.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-278-768x200.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-278-1024x266.png 1024w" sizes="(max-width: 888px) 100vw, 888px" /></noscript></p><p><strong>Step 2:</strong> To install an older version of any package, run the following command in Terminal:</p><pre>$ sudo apt-get install packagename=version</pre><p>From the above results, we can see that the available older version of Firefox is <strong>59.0.2+build1-0ubuntu1. </strong>To downgrade Firefox application to this version, run the following command in Terminal. It will simply install the older version of Firefox using apt-get command.</p><pre>$ sudo apt-get install firefox=59.0.2+build1-0ubuntu1</pre><p>When prompted for confirmation, press <strong>y</strong> to confirm.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6051" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-279.png" alt="Downgrade package on the shell" width="915" height="304" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-279.png 1211w, https://vitux.com/wp-content/uploads/2019/06/word-image-279-300x100.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-279-768x256.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-279-1024x341.png 1024w" sizes="(max-width: 915px) 100vw, 915px" /><noscript><img class="aligncenter wp-image-6051" src="https://vitux.com/wp-content/uploads/2019/06/word-image-279.png" alt="Downgrade package on the shell" width="915" height="304" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-279.png 1211w, https://vitux.com/wp-content/uploads/2019/06/word-image-279-300x100.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-279-768x256.png 768w, https://vitux.com/wp-content/uploads/2019/06/word-image-279-1024x341.png 1024w" sizes="(max-width: 915px) 100vw, 915px" /></noscript></p><p><strong>Step 3:</strong> Once the above process is finished, you can check the version of the Firefox to verify. From the below screenshot, you can see that it has successfully downgraded to version 59.02.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6052" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-280.png" alt="Check version" width="861" height="352" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-280.png 908w, https://vitux.com/wp-content/uploads/2019/06/word-image-280-300x123.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-280-768x314.png 768w" sizes="(max-width: 861px) 100vw, 861px" /><noscript><img class="aligncenter wp-image-6052" src="https://vitux.com/wp-content/uploads/2019/06/word-image-280.png" alt="Check version" width="861" height="352" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-280.png 908w, https://vitux.com/wp-content/uploads/2019/06/word-image-280-300x123.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-280-768x314.png 768w" sizes="(max-width: 861px) 100vw, 861px" /></noscript></p><p><strong>Step 4:</strong> Similar to Synaptic package manager, in the Terminal, you can also hold or lock the packages from being updated or upgraded automatically. Run the following command in Terminal to lock the package:</p><pre>$ sudo apt-mark hold firefox</pre><p>However, this method only prevents the package from being upgraded automatically. It cannot prevent or stop the package from manual up-gradation.</p><p>So that is all you need to do in order to downgrade packages on Ubuntu. Because of this, now you are able to return your packages to a previous state where they were working fine and lock them out from future upgrades.</p><div class="extra-hatom-entry-title"><span class="entry-title">How to Downgrade Packages on Ubuntu</span></div></div><footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix"><span class="date"><a href="https://vitux.com/how-to-downgrade-packages-on-ubuntu/" title="6:52 pm" rel="bookmark"><time class="entry-date published" datetime="2019-07-23T18:52:34+00:00">July 23, 2019</time><time class="updated" datetime="2019-07-23T19:03:20+00:00">July 23, 2019</time></a></span> <span class="category"><a href="https://vitux.com/desktop/" rel="category tag">Desktop</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a>, <a href="https://vitux.com/ubuntu/" rel="category tag">Ubuntu</a></span></div></footer> </article><ul class="default-wp-page clearfix"><li class="previous"><a href="https://vitux.com/listen-to-music-through-the-ubuntu-terminal/" rel="prev"><span class="meta-nav">&larr;</span> Listen to Music through the Ubuntu Terminal</a></li><li class="next"></li></ul></div><!-- #content --></div><!-- #primary --><div id="secondary"> <aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async type="text/javascript" src="//cdn.carbonads.com/carbon.js?serve=CK7IVKQW&placement=vituxcom" id="_carbonads_js"></script></div></aside><aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form><!-- .searchform --></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3><div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p></div> </aside> <aside id="wpp-5" class="widget popular-posts"><h3 class="widget-title"><span>Most Popular</span></h3><!-- cached --> <!-- WordPress Popular Posts --><ul class="wpp-list"><li> <a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" title="How to Uninstall Programs from your Ubuntu System" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" title="Get Linux System and Hardware Details on the Command Line" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on August 7, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-ubuntu-18-04-along-with-windows-10/" title="How to Install Ubuntu 18.04 along with Windows 10" class="wpp-post-title" target="_self">How to Install Ubuntu 18.04 along with Windows 10</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 29, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/find-devices-connected-to-your-network-with-nmap/" title="Find Devices Connected to Your Network with nmap" class="wpp-post-title" target="_self">Find Devices Connected to Your Network with nmap</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 30, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-xampp-on-your-ubuntu-18-04-lts-system/" title="How to Install XAMPP on your Ubuntu 18.04 LTS System" class="wpp-post-title" target="_self">How to Install XAMPP on your Ubuntu 18.04 LTS System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 2, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/find-out-which-port-number-a-process-is-listening-on-using-linux/" title="Linux: Find Out Which Port Number a Process is Listening on" class="wpp-post-title" target="_self">Linux: Find Out Which Port Number a Process is Listening on</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 18, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a></span></span></li><li> <a href="https://vitux.com/how-to-open-folders-in-ubuntu/" title="6 Ways to Open Folders in Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">6 Ways to Open Folders in Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on February 14, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/install-nfs-server-and-client-on-ubuntu/" title="Install NFS Server and Client on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">Install NFS Server and Client on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 13, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-wine-on-ubuntu/" title="How to Install Wine on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">How to Install Wine on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on September 20, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-shut-down-ubuntu/" title="How to Shut Down Ubuntu" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 21, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li></ul></aside></div></div><!-- .inner-wrap --></div><!-- #main --><footer id="colophon" class="clearfix"><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"> Copyright &copy; <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li></ul></div> </nav></div></div></div> </footer> <a href="#masthead" id="scroll-up"></a></div><!-- #page --> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');</script> <script type='text/javascript'>/*  */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0"};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1563900759/out/footer-e0172597.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script> </body></html>

<!-- Cachify | http://cachify.de
Memcached @ 23.07.2019 19:03:43 -->