<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head><meta charset="UTF-8" />
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=192-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=192-2&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=192-2&cb=5', false, [], true, false, true, false);</script>
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>How to install OBS Screen Recording Software on Debian 10</title>
<link rel="canonical" href="https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to install OBS Screen Recording Software on Debian 10" />
<meta property="og:description" content="OBS stands for “Open Broadcast Software which is a screen recording and streaming tool”. The user can configure and customize things using the features provided by the OBS. It is an open and free-source software providing the following features: Multiple" />
<meta property="og:url" content="https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/" />
<meta property="og:site_name" content="VITUX" />
<meta property="article:publisher" content="https://www.facebook.com/vituxcom/" />
<meta property="article:published_time" content="2021-03-19T11:23:53+00:00" />
<meta property="article:modified_time" content="2021-03-19T11:25:48+00:00" />
<meta property="og:image" content="https://vitux.com/wp-content/uploads/debian-screen-recording-1.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="512" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@vituxcom" />
<meta name="twitter:site" content="@vituxcom" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Karim Buzdar">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="8 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","potentialAction":[{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/#primaryimage","inLanguage":"en-US","url":"https://vitux.com/wp-content/uploads/debian-screen-recording-1.jpg","width":1024,"height":512,"caption":"Debian Screen Recording"},{"@type":"WebPage","@id":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/#webpage","url":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/","name":"How to install OBS Screen Recording Software on Debian 10","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/#primaryimage"},"datePublished":"2021-03-19T11:23:53+00:00","dateModified":"2021-03-19T11:25:48+00:00","author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"breadcrumb":{"@id":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/"]}]},{"@type":"BreadcrumbList","@id":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://vitux.com/","url":"https://vitux.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/","url":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/","name":"How to install OBS Screen Recording Software on Debian 10"}}]},{"@type":"Person","@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","image":{"@type":"ImageObject","@id":"https://vitux.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=96&d=mm&r=g","caption":"Karim Buzdar"},"description":"About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. He blogs at LinuxWays."}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/vitux.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://vitux.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css' href='https://vitux.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css' href='https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://vitux.com/wp-content/themes/spacious/style.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_style-css' href='https://vitux.com/wp-content/themes/vitux/style.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-genericons-css' href='https://vitux.com/wp-content/themes/spacious/genericons/genericons.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='spacious-font-awesome-css' href='https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='spacious_googlefonts-css' href='//fonts.googleapis.com/css?family=Lato&#038;ver=1.9.2' type='text/css' media='all' />
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":15399,"token":"99889372fb","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/spacious-custom.js?ver=5.7' id='spacious-custom-js'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js?ver=5.7' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="https://vitux.com/wp-json/" /><link rel="alternate" type="application/json" href="https://vitux.com/wp-json/wp/v2/posts/15399" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://vitux.com/?p=15399' />
<link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-install-obs-screen-recording-software-on-debian-10%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-install-obs-screen-recording-software-on-debian-10%2F&#038;format=xml" />
<script src="//m.servedby-buysellads.com/monetization.js" type="text/javascript"></script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 177389;
var ezdomain = 'vitux.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":177389,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"e77d6043-9655-41c4-7f70-992be4bd5186","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":39500,"response_time_orig":4,"serverid":"3.85.105.80:9549","state":"VA","t_epoch":1616169558,"template_id":126,"time_on_site_visit":0,"url":"https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/","user_id":0,"word_count":1241,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_177389=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["e77d6043-9655-41c4-7f70-992be4bd5186", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body class="post-template-default single single-post postid-15399 single-format-standard wp-embed-responsive  better-responsive-menu narrow-1218">
<div id="page" class="hfeed site">
<a class="skip-link screen-reader-text" href="#main">Skip to content</a>
<header id="masthead" class="site-header clearfix spacious-header-display-one">
<div id="header-text-nav-container" class="">
<div class="inner-wrap" id="spacious-header-display-one">
<div id="header-text-nav-wrap" class="clearfix">
<div id="header-left-section">
<div id="header-text" class="">
<h3 id="site-title">
<a href="https://vitux.com/" title="VITUX" rel="home">VITUX</a>
</h3>
<p id="site-description">Linux Compendium</p>

</div>
</div>
<div id="header-right-section">
<div class="header-action">
</div>
<nav id="site-navigation" class="main-navigation clearfix   " role="navigation">
<p class="menu-toggle">
<span class="screen-reader-text">Menu</span>
</p>
<div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li>
<li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li>
<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li>
<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li>
<li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</div>
<div class="header-post-title-container clearfix">
<div class="inner-wrap">
<div class="post-title-wrapper">
<h1 class="header-post-title-class">How to install OBS Screen Recording Software on Debian 10</h1>
</div>
</div>
</div>
</header>
<div id="main" class="clearfix">
<div class="inner-wrap">
<div id="primary">
<div id="content" class="clearfix">

<article id="post-15399" class="post-15399 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-desktop">
<div class="entry-content clearfix">
<p>OBS stands for “<strong>Open Broadcast Software which is a screen recording and streaming tool”</strong>. The user can configure and customize things using the features provided by the OBS. It is an open and free-source software providing the following features:</p>
<ul>
<li>Multiple Themes</li>
<li>Multiple video sources filters</li>
<li>Intuitive audio mixer</li>
<li>Real-time audio/video capturing and mixing</li>
<li>Streamlined settings panel</li>
<li>Powerful configuration option</li>
</ul>
<p>The software is efficient and easy to use which gives satisfactory results to its users. <strong>OBS stands among the top 50 video editing software products.</strong></p>
<p>For this particular article, I am using <strong>Debian 10, </strong>a Linux operating system distribution. Complete the following steps for installing OBS. This tutorial shows two alternative ways of installing OBS Studio, one using Debian packages and another one using snap.</p>
<h2>Prerequisites</h2>
<ul>
<li>The machine running Debian 10 0S.</li>
<li>The user must be familiar with the Sudo command and be a sudo user.</li>
</ul>
<h2>Installing OBS in Debian 10 using Debian packages</h2>
<p>This chapter shows how to install OBS from Debian package repository. if you like to install it as SNAP package instead, go to the next chapter.</p>
<h3>Step 01: Open Debian 10 Terminal</h3>
<p>Go to the<strong> bottom left of the Desktop</strong> and click on the <strong>Menu</strong> <strong>icon</strong>.</p>
<p><img loading="lazy" class="aligncenter wp-image-15400" src="https://vitux.com/wp-content/uploads/word-image-1614.png" alt="Open Mennu" width="801" height="261" srcset="https://vitux.com/wp-content/uploads/word-image-1614.png 801w, https://vitux.com/wp-content/uploads/word-image-1614-300x98.png 300w, https://vitux.com/wp-content/uploads/word-image-1614-768x250.png 768w" sizes="(max-width: 801px) 100vw, 801px" /></p>
<p>Go to the <strong>search bar</strong> on the <strong>top left</strong>.</p>
<p>Type <strong>“Terminal”</strong> there and click on the <strong>“Multilingual Terminal</strong>”.</p>
<p><img loading="lazy" class="aligncenter wp-image-15401" src="https://vitux.com/wp-content/uploads/word-image-1615.png" alt="Linux Terminal" width="570" height="534" srcset="https://vitux.com/wp-content/uploads/word-image-1615.png 570w, https://vitux.com/wp-content/uploads/word-image-1615-300x281.png 300w" sizes="(max-width: 570px) 100vw, 570px" /></p>
<p>Click on the <strong>“Multilingual Terminal”</strong> and it will show the following display.</p>
<p><img loading="lazy" class="aligncenter wp-image-15402" src="https://vitux.com/wp-content/uploads/word-image-1616.png" alt="Linux Terminal Screen" width="766" height="77" srcset="https://vitux.com/wp-content/uploads/word-image-1616.png 766w, https://vitux.com/wp-content/uploads/word-image-1616-300x30.png 300w" sizes="(max-width: 766px) 100vw, 766px" /></p>
<h3>Step 02: Update the repository cache</h3>
<ul>
<li>Before installing OBS, update the software package version&#8217;s information or dependencies by the following command:</li>
</ul>
<pre> $ sudo apt-get update</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-15403" src="https://vitux.com/wp-content/uploads/word-image-1617.png" alt="apt-get update" width="465" height="20" srcset="https://vitux.com/wp-content/uploads/word-image-1617.png 465w, https://vitux.com/wp-content/uploads/word-image-1617-300x13.png 300w" sizes="(max-width: 465px) 100vw, 465px" /></strong></p>
<p>Running this command downloads the package information from the internet or all configured sources.</p>
<p><img loading="lazy" class="aligncenter wp-image-15404" src="https://vitux.com/wp-content/uploads/word-image-1618.png" alt="Updating package lists" width="787" height="319" srcset="https://vitux.com/wp-content/uploads/word-image-1618.png 787w, https://vitux.com/wp-content/uploads/word-image-1618-300x122.png 300w, https://vitux.com/wp-content/uploads/word-image-1618-768x311.png 768w" sizes="(max-width: 787px) 100vw, 787px" /></p>
<h2><strong>Step 03: Install Open Broadcast Software</strong></h2>
<p>Run the following command to install the OBS:</p>
<pre>$ sudo apt install obs-studio</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-15405" src="https://vitux.com/wp-content/uploads/word-image-1619.png" alt="apt install obs-studio" width="563" height="29" srcset="https://vitux.com/wp-content/uploads/word-image-1619.png 563w, https://vitux.com/wp-content/uploads/word-image-1619-300x15.png 300w" sizes="(max-width: 563px) 100vw, 563px" /></strong></p>
<p>After running the above command, it will ask you whether you want to continue or not? <strong>Type “Y” and press enter</strong> if you want to install the OBS or not. After the installation process will be done, it will show the following display:</p>
<p><img loading="lazy" class="aligncenter wp-image-15406" src="https://vitux.com/wp-content/uploads/word-image-1620.png" alt="Installing package dependencies" width="686" height="440" srcset="https://vitux.com/wp-content/uploads/word-image-1620.png 686w, https://vitux.com/wp-content/uploads/word-image-1620-300x192.png 300w" sizes="(max-width: 686px) 100vw, 686px" /></p>
<h2>Install OBS using snap</h2>
<p>In this chapter, I&#8217;ll show you how to install OBS using snap. If you installed OBS already using packages in the first chapter, then skip this chapter and go directly to the next chapter on using OBS.</p>
<h3>Install snap Daemon</h3>
<ul>
<li><strong>OBS snap is a universal Linux Package</strong> that enables features for package management for all Linux distributions. It provides very satisfactory and persistent results and output.</li>
<li><strong>Before installing the snap package, the PC or a machine must have installed &#8220;snappy&#8221;. </strong><em>“Snappy is a snap package manager for Linux”</em>. You can install snappy by running the following command:</li>
</ul>
<pre> $ sudo apt install snapd -y</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-15407" src="https://vitux.com/wp-content/uploads/word-image-1621.png" alt="apt install snapd" width="542" height="28" srcset="https://vitux.com/wp-content/uploads/word-image-1621.png 542w, https://vitux.com/wp-content/uploads/word-image-1621-300x15.png 300w" sizes="(max-width: 542px) 100vw, 542px" /></strong></p>
<p>After the installation process will be done, it will show the following display:</p>
<p><img loading="lazy" class="aligncenter wp-image-15408" src="https://vitux.com/wp-content/uploads/word-image-1622.png" alt="Installing Snap" width="784" height="441" srcset="https://vitux.com/wp-content/uploads/word-image-1622.png 784w, https://vitux.com/wp-content/uploads/word-image-1622-300x169.png 300w, https://vitux.com/wp-content/uploads/word-image-1622-768x432.png 768w" sizes="(max-width: 784px) 100vw, 784px" /></p>
<h2><strong>Step 01: Install the snap core</strong></h2>
<p>To Snap be fully runnable, it requires a snap core to be installed in a PC/machine or a system too. Run the following command to install the snap core.</p>
<pre>$ sudo snap install core</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-15409" src="https://vitux.com/wp-content/uploads/word-image-1623.png" alt="Install Snap core" width="520" height="28" srcset="https://vitux.com/wp-content/uploads/word-image-1623.png 520w, https://vitux.com/wp-content/uploads/word-image-1623-300x16.png 300w" sizes="(max-width: 520px) 100vw, 520px" /></strong></p>
<h2><strong>Step 02: Restart the snap service</strong></h2>
<p>After getting done with all of the above steps, restart the snap service using the following command:</p>
<pre> $ sudo systemctl restart snapd</pre>
<p><img loading="lazy" class="aligncenter wp-image-15410" src="https://vitux.com/wp-content/uploads/word-image-1624.png" alt="Restart Snap Daemon" width="557" height="66" srcset="https://vitux.com/wp-content/uploads/word-image-1624.png 557w, https://vitux.com/wp-content/uploads/word-image-1624-300x36.png 300w" sizes="(max-width: 557px) 100vw, 557px" /></p>
<p>Next, you have to install snap packages from the SnapCraft store. Snappy is now able to do it. Go to SnapCraft store <a href="https://snapcraft.io/obs-studio">https://snapcraft.io/obs-studio</a> and look for an OBS studio there. It is also shown in the below attached image.</p>
<p><img loading="lazy" class="aligncenter wp-image-15411" src="https://vitux.com/wp-content/uploads/word-image-1625.png" alt="OBS Studio Snap" width="1007" height="638" srcset="https://vitux.com/wp-content/uploads/word-image-1625.png 1007w, https://vitux.com/wp-content/uploads/word-image-1625-300x190.png 300w, https://vitux.com/wp-content/uploads/word-image-1625-768x487.png 768w" sizes="(max-width: 1007px) 100vw, 1007px" /></p>
<ul>
<li>Run the following command to install the obs-studio:</li>
</ul>
<pre> $ sudo snap install obs-studio</pre>
<p><strong><img loading="lazy" class="aligncenter wp-image-15412" src="https://vitux.com/wp-content/uploads/word-image-1626.png" alt="snap install obs-studio" width="634" height="51" srcset="https://vitux.com/wp-content/uploads/word-image-1626.png 634w, https://vitux.com/wp-content/uploads/word-image-1626-300x24.png 300w" sizes="(max-width: 634px) 100vw, 634px" /></strong></p>
<h2>Using OBS for screen Recording on Debian</h2>
<p>Once you have done with the above steps, open the OBS from the menu search bar. Follow the following steps:</p>
<ul>
<li>Go to the<strong> bottom left of the Desktop</strong> and click on the <strong>Menu</strong> <strong>icon</strong>.</li>
<li>Go to the <strong>search bar</strong> on the <strong>top left</strong>.</li>
<li>Type <strong>“obs” </strong>there and click on the <strong>“OBS”.</strong></li>
</ul>
<p><strong><img loading="lazy" class="aligncenter wp-image-15413" src="https://vitux.com/wp-content/uploads/word-image-1627.png" alt="OBS Icon" width="482" height="473" srcset="https://vitux.com/wp-content/uploads/word-image-1627.png 482w, https://vitux.com/wp-content/uploads/word-image-1627-300x294.png 300w" sizes="(max-width: 482px) 100vw, 482px" /></strong></p>
<p>Clicking on the <strong>OBS</strong> will show the following display. OBS software should start.</p>
<p><img loading="lazy" class="aligncenter wp-image-15414" src="https://vitux.com/wp-content/uploads/word-image-1628.png" alt="OBS Configuration Wizard" width="1022" height="725" srcset="https://vitux.com/wp-content/uploads/word-image-1628.png 1022w, https://vitux.com/wp-content/uploads/word-image-1628-300x213.png 300w, https://vitux.com/wp-content/uploads/word-image-1628-768x545.png 768w" sizes="(max-width: 1022px) 100vw, 1022px" /></p>
<h2><strong>Step 01: Setting up the OBS software</strong></h2>
<p>Opening the OBS software will display you the auto-configuration wizard. If you are a naive user, you should complete the auto-configuration steps, otherwise, you can skip it if you are already a frequent user.</p>
<p><img loading="lazy" class="aligncenter wp-image-15415" src="https://vitux.com/wp-content/uploads/word-image-1629.png" alt="Optimize for Streaming" width="952" height="534" srcset="https://vitux.com/wp-content/uploads/word-image-1629.png 952w, https://vitux.com/wp-content/uploads/word-image-1629-300x168.png 300w, https://vitux.com/wp-content/uploads/word-image-1629-768x431.png 768w" sizes="(max-width: 952px) 100vw, 952px" /></p>
<p>The first step will be providing the usage information whether you want to set the optimization for both streaming and recording or it will be only recording. Select the option of your own choice. For this particular article,<strong> I am selecting option 01</strong> as highlighted in the below-attached image. After selecting the option,<strong> click Next</strong>.</p>
<p><img loading="lazy" class="aligncenter wp-image-15416" src="https://vitux.com/wp-content/uploads/word-image-1630.png" alt="OBS Configuration" width="957" height="527" srcset="https://vitux.com/wp-content/uploads/word-image-1630.png 957w, https://vitux.com/wp-content/uploads/word-image-1630-300x165.png 300w, https://vitux.com/wp-content/uploads/word-image-1630-768x423.png 768w" sizes="(max-width: 957px) 100vw, 957px" /></p>
<p>Next, you have to choose the<strong> “resolution”</strong> and <strong>“frame rate”.</strong> The user can select both of them according to their desire. It also depends on hardware requirements and internet status. After selecting, <strong>click Next</strong>.</p>
<p><img loading="lazy" class="aligncenter wp-image-15417" src="https://vitux.com/wp-content/uploads/word-image-1631.png" alt="Choose screen resolution and frame rate" width="641" height="457" srcset="https://vitux.com/wp-content/uploads/word-image-1631.png 641w, https://vitux.com/wp-content/uploads/word-image-1631-300x214.png 300w" sizes="(max-width: 641px) 100vw, 641px" /></p>
<p>OBS support many platforms like Youtube, Facebook, Twitch, and others. In this section, the user has to select the platform freely concerning his/her choice or work requirements. For this article, I am going with <strong>Twitch</strong>.</p>
<p><img loading="lazy" class="aligncenter wp-image-15418" src="https://vitux.com/wp-content/uploads/word-image-1632.png" alt="Streaming service" width="631" height="426" srcset="https://vitux.com/wp-content/uploads/word-image-1632.png 631w, https://vitux.com/wp-content/uploads/word-image-1632-300x203.png 300w" sizes="(max-width: 631px) 100vw, 631px" /></p>
<p>After entering the Stream key<strong>,</strong> a bandwidth test will start to fix the fine bitrate for streaming. It may take some period. After getting done, OBS will prompt you to Apply Settings that you have made. Click on the Apply Settings. Clicking on it will give you the following display:</p>
<p><img loading="lazy" class="aligncenter wp-image-15419" src="https://vitux.com/wp-content/uploads/word-image-1633.png" alt="Start screen recording with OBS" width="1023" height="730" srcset="https://vitux.com/wp-content/uploads/word-image-1633.png 1023w, https://vitux.com/wp-content/uploads/word-image-1633-300x214.png 300w, https://vitux.com/wp-content/uploads/word-image-1633-768x548.png 768w" sizes="(max-width: 1023px) 100vw, 1023px" /></p>
<p>Now, you are all ready to use OBS software.</p>
<h2>Conclusion</h2>
<p>This article shows how to install and set up OBS in a few easy steps. The article demonstrates as well as explains each step with detailed screenshots too, making it simple to understand for a user to follow it.</p>
<div class="extra-hatom-entry-title"><span class="entry-title">How to install OBS Screen Recording Software on Debian 10</span></div> </div>
<footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix">
<span class="by-author author vcard"><a class="url fn n" href="https://vitux.com/author/karim/">Karim Buzdar</a></span>
<span class="date"><a href="https://vitux.com/how-to-install-obs-screen-recording-software-on-debian-10/" title="11:23 am" rel="bookmark"><time class="entry-date published" datetime="2021-03-19T11:23:53+00:00">March 19, 2021</time><time class="updated" datetime="2021-03-19T11:25:48+00:00">March 19, 2021</time></a></span> <span class="category"><a href="https://vitux.com/debian/" rel="category tag">Debian</a>, <a href="https://vitux.com/desktop/" rel="category tag">Desktop</a></span>
</div></footer>
</article>
<ul class="default-wp-page clearfix">
<li class="previous"><a href="https://vitux.com/how-to-install-wine-on-ubuntu/" rel="prev"><span class="meta-nav">&larr;</span> How to Install Wine on Ubuntu 20.04 LTS</a></li>
<li class="next"></li>
</ul>
<div class="author-box clearfix">
<div class="author-img"><img src="https://secure.gravatar.com/avatar/52314fa822f7a78a4278d668c5ab383e?s=100&#038;d=mm&#038;r=g" width="100" height="100" alt="Avatar" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /></div>
<div class="author-description-wrapper">
<h4 class="author-name">Karim Buzdar</h4>
<p class="author-description">About the Author: Karim Buzdar holds a degree in telecommunication engineering and holds several sysadmin certifications. As an IT engineer and technical author, he writes for various web sites. He blogs at <a href="https://www.linuxways.net/" rel="nofollow">LinuxWays</a>.</p>
</div>
</div>
</div>
</div>
<div id="secondary">
<aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get">
<div class="search-wrap">
<input type="text" placeholder="Search" class="s field" name="s">
<button class="search-icon" type="submit"></button>
</div>
</form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3> <div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p>
</div>
</aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="navDiv">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-3536364066785075" data-ad-slot="6537400998" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div></aside>
<aside id="wpp-5" class="widget popular-posts">
<h3 class="widget-title"><span>Most Popular</span></h3>

<ul class="wpp-list">
<li>
<a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 22, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/5-ways-to-check-available-memory-in-ubuntu/" class="wpp-post-title" target="_self">5 Ways to Check Available Memory in Ubuntu 20.04</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on April 30, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-setup-java_home-path-in-ubuntu/" class="wpp-post-title" target="_self">How to Set JAVA_HOME Path in Ubuntu 18.04 and 20.04 LTS</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on January 23, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-find-files-on-the-ubuntu-command-line/" class="wpp-post-title" target="_self">How to find files on the Ubuntu command line</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on June 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/find-devices-connected-to-your-network-with-nmap/" class="wpp-post-title" target="_self">Find Devices Connected to Your Network with nmap</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on November 30, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on July 29, 2020</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-manually-mount-unmount-a-usb-device-on-ubuntu/" class="wpp-post-title" target="_self">How to Manually Mount/UnMount a USB Device on Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on September 19, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/how-to-start-stop-or-restart-services-in-ubuntu/" class="wpp-post-title" target="_self">How to Start, Stop or Restart Services in Ubuntu</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on April 18, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
<li>
<a href="https://vitux.com/3-ways-to-reboot-ubuntu-through-the-command-line/" class="wpp-post-title" target="_self">3 Ways to Reboot Ubuntu through the Command Line</a>
<span class="wpp-meta post-stats"><span class="wpp-date">posted on May 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span>
</li>
</ul>
</aside>
</div>
</div>
</div>
<footer id="colophon" class="clearfix">
<div class="footer-socket-wrapper clearfix">
<div class="inner-wrap">
<div class="footer-socket-area">
Copyright &copy; <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li>
</ul></div> </nav>
</div>
</div>
</div>
</footer>
<a href="#masthead" id="scroll-up"></a>
</div>

<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');
		</script>
<script>
	(function(){
	  if(typeof _bsa !== 'undefined' && _bsa) {
	    _bsa.init('fancybar', 'CE7I6KQJ', 'placement:vituxcom');
	  }
	})();
</script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/navigation.js?ver=5.7' id='spacious-navigation-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/skip-link-focus-fix.js?ver=5.7' id='spacious-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://vitux.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="vitux_com",_audins_did=177389;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=192-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.vitux_com,DomainId.177389" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script></body>
</html>
