<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><title>How to replace Gnome Screensaver with Xscreensaver on Ubuntu</title><!-- This site is optimized with the Yoast SEO plugin v12.0 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to replace Gnome Screensaver with Xscreensaver on Ubuntu" /><meta property="og:description" content="By default, your Ubuntu systems are running the Gnome Screensaver application. In recent past, the Gnome developers have altered the application in a way that it only runs a blank screen when your Ubuntu screen remains idle for a specific" /><meta property="og:url" content="https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/" /><meta property="og:site_name" content="VITUX" /><meta property="article:publisher" content="https://www.facebook.com/vituxcom/" /><meta property="article:section" content="Ubuntu" /><meta property="article:published_time" content="2019-09-11T16:05:02+00:00" /><meta property="article:modified_time" content="2019-09-11T16:06:40+00:00" /><meta property="og:updated_time" content="2019-09-11T16:06:40+00:00" /><meta property="og:image" content="https://vitux.com/wp-content/uploads/2019/09/ubuntu-xscreensaver.jpg" /><meta property="og:image:secure_url" content="https://vitux.com/wp-content/uploads/2019/09/ubuntu-xscreensaver.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="512" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="By default, your Ubuntu systems are running the Gnome Screensaver application. In recent past, the Gnome developers have altered the application in a way that it only runs a blank screen when your Ubuntu screen remains idle for a specific" /><meta name="twitter:title" content="How to replace Gnome Screensaver with Xscreensaver on Ubuntu" /><meta name="twitter:site" content="@vituxcom" /><meta name="twitter:image" content="https://vitux.com/wp-content/uploads/2019/09/ubuntu-xscreensaver.jpg" /><meta name="twitter:creator" content="@vituxcom" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","publisher":{"@id":"https://vitux.com/#/schema/person/8cb93983c98be876deba153eab5eccee"},"potentialAction":{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/#primaryimage","url":"https://vitux.com/wp-content/uploads/2019/09/ubuntu-xscreensaver.jpg","width":1024,"height":512,"caption":"Ubuntu Xscreensaver"},{"@type":"WebPage","@id":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/#webpage","url":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/","inLanguage":"en-US","name":"How to replace Gnome Screensaver with Xscreensaver on Ubuntu","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/#primaryimage"},"datePublished":"2019-09-11T16:05:02+00:00","dateModified":"2019-09-11T16:06:40+00:00"},{"@type":"Article","@id":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/#article","isPartOf":{"@id":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/#webpage"},"author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"headline":"How to replace Gnome Screensaver with Xscreensaver on Ubuntu","datePublished":"2019-09-11T16:05:02+00:00","dateModified":"2019-09-11T16:06:40+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/#webpage"},"publisher":{"@id":"https://vitux.com/#/schema/person/8cb93983c98be876deba153eab5eccee"},"image":{"@id":"https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/#primaryimage"},"articleSection":"Desktop,Linux,Ubuntu"},{"@type":["Person"],"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","sameAs":[]}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" /><link rel='stylesheet' id='wp-block-library-css'  href='https://vitux.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://vitux.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-pagenavi-css'  href='https://vitux.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css' type='text/css' media='all' /><link rel='stylesheet' id='parent-style-css'  href='https://vitux.com/wp-content/themes/spacious/style.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious_style-css'  href='https://vitux.com/wp-content/themes/vitux/style.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious-genericons-css'  href='https://vitux.com/wp-content/themes/spacious/genericons/genericons.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious-font-awesome-css'  href='https://vitux.com/wp-content/themes/spacious/font-awesome/css/font-awesome.min.css' type='text/css' media='all' /><link rel='stylesheet' id='spacious_googlefonts-css'  href='//fonts.googleapis.com/css?family=Lato&#038;ver=5.2.3' type='text/css' media='all' /><link rel='stylesheet' id='jquery-lazyloadxt-fadein-css-css'  href='//vitux.com/wp-content/plugins/a3-lazy-load/assets/css/jquery.lazyloadxt.fadein.css' type='text/css' media='all' /><link rel='stylesheet' id='a3a3_lazy_load-css'  href='//vitux.com/wp-content/uploads/sass/a3_lazy_load.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"6057","token":"a9408ed119","debug":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1567521975/out/header-b69312bd.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://vitux.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.2.3" /><link rel='shortlink' href='https://vitux.com/?p=6057' /><link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu%2F" /><link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Fhow-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu%2F&#038;format=xml" /></head><body class="post-template-default single single-post postid-6057 single-format-standard  better-responsive-menu"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a> <header id="masthead" class="site-header clearfix "><div id="header-text-nav-container" class=""><div class="inner-wrap" id=""><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class=""><h3 id="site-title"> <a href="https://vitux.com/"
title="VITUX"
rel="home">VITUX</a></h3><p id="site-description">Linux Compendium</p> <!-- #site-description --></div><!-- #header-text --></div><!-- #header-left-section --><div id="header-right-section"><div class="header-action"></div> <nav id="site-navigation" class="main-navigation clearfix   " role="navigation"><p class="menu-toggle">Menu</p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li><li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li><li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li><li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li><li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li></ul></div> </nav></div><!-- #header-right-section --></div><!-- #header-text-nav-wrap --></div><!-- .inner-wrap --></div><!-- #header-text-nav-container --><div class="header-post-title-container clearfix"><div class="inner-wrap"><div class="post-title-wrapper"><h1 class="header-post-title-class">How to replace Gnome Screensaver with Xscreensaver on Ubuntu</h1></div></div></div> </header><div id="main" class="clearfix"><div class="inner-wrap"><div id="primary"><div id="content" class="clearfix"> <article id="post-6057" class="post-6057 post type-post status-publish format-standard has-post-thumbnail hentry category-desktop category-linux category-ubuntu"><div class="entry-content clearfix"><p>By default, your Ubuntu systems are running the Gnome Screensaver application. In recent past, the Gnome developers have altered the application in a way that it only runs a blank screen when your Ubuntu screen remains idle for a specific time. You can verify that this application is running on your system by entering the following command in your Ubuntu command line, the Terminal:</p><pre>$ gnome-screensaver</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6058" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-281.png" alt="Gnome Screensaver" width="728" height="106" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-281.png 728w, https://vitux.com/wp-content/uploads/2019/06/word-image-281-300x44.png 300w" sizes="(max-width: 728px) 100vw, 728px" /><noscript><img class="aligncenter wp-image-6058" src="https://vitux.com/wp-content/uploads/2019/06/word-image-281.png" alt="Gnome Screensaver" width="728" height="106" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-281.png 728w, https://vitux.com/wp-content/uploads/2019/06/word-image-281-300x44.png 300w" sizes="(max-width: 728px) 100vw, 728px" /></noscript></p><p>However, we are so used to running those moving patterns and images on our idle screens, such as on Windows and Mac, that we miss them on Ubuntu. Initially, these screensavers were your operating system’s way of limiting Phospor burning on plasma and CRTs. With modern display screens, this is not the case but when we miss something, there should be a way to get it back!</p><p>In this article, we will describe how you can install the Xscreensaver utility, automatically enable it at startup, and use it to set screensavers on your system depending on your specific requirements.</p><p>We have run the commands and procedures mentioned in this article on a Ubuntu 18.04 LTS system.</p><h2>Install Xscreensaver</h2><p>The Xscreensaver package is available in the official Ubuntu repositories (ubuntu-bionic-universe) and can easily be installed through the command line using the apt-get command.</p><p>Open your Terminal application either through the system Application Launcher Search or through the Ctrl+Alt+T shortcut.</p><p>The next step is to update your system’s repository index through the following command:</p><pre>$ sudo apt-get update</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6059" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-282.png" alt="Update package list" width="662" height="147" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-282.png 662w, https://vitux.com/wp-content/uploads/2019/06/word-image-282-300x67.png 300w" sizes="(max-width: 662px) 100vw, 662px" /><noscript><img class="aligncenter wp-image-6059" src="https://vitux.com/wp-content/uploads/2019/06/word-image-282.png" alt="Update package list" width="662" height="147" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-282.png 662w, https://vitux.com/wp-content/uploads/2019/06/word-image-282-300x67.png 300w" sizes="(max-width: 662px) 100vw, 662px" /></noscript></p><p>This helps you in installing the latest available version of a software from the Internet. Please note that only an authorized user can add, remove and configure software on Ubuntu.</p><p>Now you are ready to install the Xscreensaver, and some required packages; you can do so by running the following command as sudo:</p><pre>$ sudo apt-get install xscreensaver xscreensaver-gl-extra xscreensaver-data-extra</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6060" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-283.png" alt="Install Xscreensaver" width="689" height="345" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-283.png 689w, https://vitux.com/wp-content/uploads/2019/06/word-image-283-300x150.png 300w" sizes="(max-width: 689px) 100vw, 689px" /><noscript><img class="aligncenter wp-image-6060" src="https://vitux.com/wp-content/uploads/2019/06/word-image-283.png" alt="Install Xscreensaver" width="689" height="345" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-283.png 689w, https://vitux.com/wp-content/uploads/2019/06/word-image-283-300x150.png 300w" sizes="(max-width: 689px) 100vw, 689px" /></noscript></p><p>The system might ask you the password for sudo and also provide you with a Y/n option to continue the installation. Enter Y and then hit enter; the software and the relevant packages will then be installed on your system. The process may, however, take some time depending on your Internet speed.</p><p>In order to verify that the software is indeed installed on your system and also to get the version information, run the following screensaver command:</p><pre>$ xscreensaver -help</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6061" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-284.png" alt="Check XScreensaver version" width="665" height="186" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-284.png 665w, https://vitux.com/wp-content/uploads/2019/06/word-image-284-300x84.png 300w" sizes="(max-width: 665px) 100vw, 665px" /><noscript><img class="aligncenter wp-image-6061" src="https://vitux.com/wp-content/uploads/2019/06/word-image-284.png" alt="Check XScreensaver version" width="665" height="186" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-284.png 665w, https://vitux.com/wp-content/uploads/2019/06/word-image-284-300x84.png 300w" sizes="(max-width: 665px) 100vw, 665px" /></noscript></p><h4>Removing the default Ubuntu Screensaver</h4><p>As mentioned above, the default Gnome Screensaver would only display a blank screen when your system is idle for a long time. For the system to not use this screensaver app anymore, let us remove it through the following command:</p><pre>$ sudo apt-get remove gnome-screensaver</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6062" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-285.png" alt="Remove Sscreensaver" width="579" height="171" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-285.png 579w, https://vitux.com/wp-content/uploads/2019/06/word-image-285-300x89.png 300w" sizes="(max-width: 579px) 100vw, 579px" /><noscript><img class="aligncenter wp-image-6062" src="https://vitux.com/wp-content/uploads/2019/06/word-image-285.png" alt="Remove Sscreensaver" width="579" height="171" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-285.png 579w, https://vitux.com/wp-content/uploads/2019/06/word-image-285-300x89.png 300w" sizes="(max-width: 579px) 100vw, 579px" /></noscript></p><p><strong>Important:</strong> For this screen saver application to be removed completely, you need to restart your system.</p><h2>Add Xscreensaver to Autostart</h2><p>The Xscreevsaver now appears in the Applications listing and can be launched anytime. However, we would not like starting it every time we reboot our system in order for the screen saver program to be active. Thus, it is best to add the Xscreensaver utility to your system startup.</p><p>Open the Startup Applications utility either by locating it in the Applications list or simply by searching for it through the system Application Launcher search as follows.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6063" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-286.png" alt="Startup app" width="412" height="222" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-286.png 412w, https://vitux.com/wp-content/uploads/2019/06/word-image-286-300x162.png 300w" sizes="(max-width: 412px) 100vw, 412px" /><noscript><img class="aligncenter wp-image-6063" src="https://vitux.com/wp-content/uploads/2019/06/word-image-286.png" alt="Startup app" width="412" height="222" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-286.png 412w, https://vitux.com/wp-content/uploads/2019/06/word-image-286-300x162.png 300w" sizes="(max-width: 412px) 100vw, 412px" /></noscript></p><p><strong>Note: </strong>Although I have been using the Startup Applications utility for a long time, I could not find it installed on my Ubuntu while working on this article. If you ever face a similar situation, you can add this app back to your system through the following command:</p><pre>$ sudo apt-get install gnome-startup-applications</pre><p>The application can also be launched through the Terminal by running the following command:</p><pre>$ gnome-session-properties</pre><p>When the Startup Applications utility opens, click the Add button to add a new program to startup.</p><p>In the Add Startup Program dialog, enter the following information:</p><p><strong>Name: </strong>screensaver</p><p><strong>Command: </strong>xscreensaver -nosplash</p><p>The nosplash flag would mean that the application would run without the UI being displayed</p><p><strong>Comment: </strong>start screensaver app at startup (or any other relevant comment)</p><p><img class="lazy lazy-hidden aligncenter wp-image-6064" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-287.png" alt="Add startup item for Xscreensaver" width="671" height="588" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-287.png 671w, https://vitux.com/wp-content/uploads/2019/06/word-image-287-300x263.png 300w" sizes="(max-width: 671px) 100vw, 671px" /><noscript><img class="aligncenter wp-image-6064" src="https://vitux.com/wp-content/uploads/2019/06/word-image-287.png" alt="Add startup item for Xscreensaver" width="671" height="588" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-287.png 671w, https://vitux.com/wp-content/uploads/2019/06/word-image-287-300x263.png 300w" sizes="(max-width: 671px) 100vw, 671px" /></noscript></p><p>Now click the Add button. Every time you boot the system, this startup program will start running the Xscreensaver utility so that your screensaver becomes active the way you have configured it.</p><h3>How to Set up a Screensaver</h3><p>In order to set a screensaver through the Xscreensaver utility, open the application either through the Application Launcher search as follows:</p><p><img class="lazy lazy-hidden aligncenter wp-image-6065" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-288.png" alt="xscreensaver" width="367" height="214" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-288.png 367w, https://vitux.com/wp-content/uploads/2019/06/word-image-288-300x175.png 300w" sizes="(max-width: 367px) 100vw, 367px" /><noscript><img class="aligncenter wp-image-6065" src="https://vitux.com/wp-content/uploads/2019/06/word-image-288.png" alt="xscreensaver" width="367" height="214" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-288.png 367w, https://vitux.com/wp-content/uploads/2019/06/word-image-288-300x175.png 300w" sizes="(max-width: 367px) 100vw, 367px" /></noscript></p><p>Or, through the following Terminal command:</p><pre>$ xscreensaver</pre><p>The application will open in the following view when you open it for the first time:</p><p><img class="lazy lazy-hidden aligncenter wp-image-6066" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-289.png" alt="Screensaver preferences" width="791" height="525" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-289.png 791w, https://vitux.com/wp-content/uploads/2019/06/word-image-289-300x199.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-289-768x510.png 768w" sizes="(max-width: 791px) 100vw, 791px" /><noscript><img class="aligncenter wp-image-6066" src="https://vitux.com/wp-content/uploads/2019/06/word-image-289.png" alt="Screensaver preferences" width="791" height="525" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-289.png 791w, https://vitux.com/wp-content/uploads/2019/06/word-image-289-300x199.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-289-768x510.png 768w" sizes="(max-width: 791px) 100vw, 791px" /></noscript></p><p>Click OK, if you get a dialog as shown above in order to run Xscreensaver on your current display screen. By default, this screen saver utility will run random screensavers on your system when the screen is idle for 10 minutes. It will also change the screensavers randomly, after every 10 minutes.</p><p><img class="lazy lazy-hidden aligncenter wp-image-6067" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-290.png" alt="Display modes" width="786" height="527" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-290.png 786w, https://vitux.com/wp-content/uploads/2019/06/word-image-290-300x201.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-290-768x515.png 768w" sizes="(max-width: 786px) 100vw, 786px" /><noscript><img class="aligncenter wp-image-6067" src="https://vitux.com/wp-content/uploads/2019/06/word-image-290.png" alt="Display modes" width="786" height="527" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-290.png 786w, https://vitux.com/wp-content/uploads/2019/06/word-image-290-300x201.png 300w, https://vitux.com/wp-content/uploads/2019/06/word-image-290-768x515.png 768w" sizes="(max-width: 786px) 100vw, 786px" /></noscript></p><p>Through the Mode drop-down, you can even configure the utility to set up only one screensaver and select that one screensaver from the list you can see under “Mode”. You can also set the idle time after which the screensaver will run through the &#8216;Blank After&#8217; option. If you explore the utility some more, you will learn that there are many other configurations you can make to the behavior of your screensaver through the Xcreensaver.</p><h3>Go Back to the Gnome-Screensaver</h3><p>If for any reason, you want to remove the Xscreensaver utility and switch back to the default Gnome Screensaver application, please follow these steps:</p><p>1. Remove the Xscreensaver utility and the relevant packages, you added while installing the Xscreensaver, through the following command in your Terminal:</p><pre>$ sudo apt-get remove xscreensaver xscreensaver-gl-extra xscreensaver-data-extra</pre><p>2. Install the Gnome Screensaver utility through the following command:</p><pre>$ sudo apt-get install gnome-screensaver</pre><p>3. Remove Xscreensaver app from your Startup Applications.</p><p>You do not need to add the Gnome Screensaver to your system startup as the application is meant to automatically run at all times. You can verify this by running the following command:</p><pre>$ gnome-screensaver</pre><p><img class="lazy lazy-hidden aligncenter wp-image-6068" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/06/word-image-291.png" alt="Gnome Screensaver" width="736" height="121" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-291.png 736w, https://vitux.com/wp-content/uploads/2019/06/word-image-291-300x49.png 300w" sizes="(max-width: 736px) 100vw, 736px" /><noscript><img class="aligncenter wp-image-6068" src="https://vitux.com/wp-content/uploads/2019/06/word-image-291.png" alt="Gnome Screensaver" width="736" height="121" srcset="https://vitux.com/wp-content/uploads/2019/06/word-image-291.png 736w, https://vitux.com/wp-content/uploads/2019/06/word-image-291-300x49.png 300w" sizes="(max-width: 736px) 100vw, 736px" /></noscript></p><p>4. Restart your system.</p><p>This was all you needed to know about installing the Xscreensaver application. You can now choose from a list of screensavers to run, whenever your Ubuntu screen is idle for a time specified by you.</p><div class="extra-hatom-entry-title"><span class="entry-title">How to replace Gnome Screensaver with Xscreensaver on Ubuntu</span></div></div><footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix"> <span class="by-author author vcard"><a class="url fn n"
href="https://vitux.com/author/karim/">Karim Buzdar</a></span><span class="date"><a href="https://vitux.com/how-to-replace-gnome-screensaver-with-xscreensaver-on-ubuntu/" title="4:05 pm" rel="bookmark"><time class="entry-date published" datetime="2019-09-11T16:05:02+00:00">September 11, 2019</time><time class="updated" datetime="2019-09-11T16:06:40+00:00">September 11, 2019</time></a></span> <span class="category"><a href="https://vitux.com/desktop/" rel="category tag">Desktop</a>, <a href="https://vitux.com/linux/" rel="category tag">Linux</a>, <a href="https://vitux.com/ubuntu/" rel="category tag">Ubuntu</a></span></div></footer> </article><ul class="default-wp-page clearfix"><li class="previous"><a href="https://vitux.com/how-to-resize-images-on-the-ubuntu-command-line/" rel="prev"><span class="meta-nav">&larr;</span> How to Resize Images on the Ubuntu Command Line</a></li><li class="next"></li></ul></div><!-- #content --></div><!-- #primary --><div id="secondary"> <aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async type="text/javascript" src="//cdn.carbonads.com/carbon.js?serve=CK7IVKQW&placement=vituxcom" id="_carbonads_js"></script></div></aside><aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form><!-- .searchform --></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3><div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p></div> </aside> <aside id="wpp-5" class="widget popular-posts"><h3 class="widget-title"><span>Most Popular</span></h3><!-- cached --> <!-- WordPress Popular Posts --><ul class="wpp-list"><li> <a href="https://vitux.com/how-to-install-xampp-on-your-ubuntu-18-04-lts-system/" title="How to Install XAMPP on your Ubuntu 18.04 LTS System" class="wpp-post-title" target="_self">How to Install XAMPP on your Ubuntu 18.04 LTS System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 2, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" title="How to Uninstall Programs from your Ubuntu System" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" title="How to Write and Run a C Program in Linux" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 17, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" title="Get Linux System and Hardware Details on the Command Line" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on August 7, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-use-apt-get-package-manager-on-ubuntu-command-line/" title="How to use apt Package Manager on Ubuntu Command Line" class="wpp-post-title" target="_self">How to use apt Package Manager on Ubuntu Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 23, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/5-ways-to-check-available-memory-in-ubuntu/" title="5 Ways to Check Available Memory in Ubuntu" class="wpp-post-title" target="_self">5 Ways to Check Available Memory in Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on December 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-shut-down-ubuntu/" title="How to Shut Down Ubuntu" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 21, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-virtualbox-on-ubuntu/" title="How to Install VirtualBox on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">How to Install VirtualBox on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 5, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/install-nfs-server-and-client-on-ubuntu/" title="Install NFS Server and Client on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">Install NFS Server and Client on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 13, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-wine-on-ubuntu/" title="How to Install Wine on Ubuntu 18.04 LTS" class="wpp-post-title" target="_self">How to Install Wine on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on September 20, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li></ul></aside></div></div><!-- .inner-wrap --></div><!-- #main --><footer id="colophon" class="clearfix"><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"> Copyright &copy; <a href="https://vitux.com">vitux.com</a> <nav class="small-menu clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li></ul></div> </nav></div></div></div> </footer> <a href="#masthead" id="scroll-up"></a></div><!-- #page --> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');</script> <script type='text/javascript'>/*  */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0"};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1567521975/out/footer-75e3307e.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script> </body></html>

<!-- Cachify | http://cachify.de
Memcached @ 11.09.2019 16:07:45 -->