<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) & !(IE 8)]><!--><html lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1"><script data-cfasync="false" id="ao_optimized_gfonts_config" type="text/javascript">WebFontConfig={google:{families:["Lato"] },classes:false, events:false, timeout:1500};</script><link rel="profile" href="http://gmpg.org/xfn/11" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><link type="text/css" media="all" href="https://vitux.com/wp-content/cache/autoptimize/css/autoptimize_195d333ae3f6e71b8cfcc5e1fef2da62.css" rel="stylesheet" /><title>Install and Use Guake - A drop-down Terminal Emulator for Debian 10</title><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Install and Use Guake - A drop-down Terminal Emulator for Debian 10" /><meta property="og:description" content="Although Debian users these days get to perform various operations through programs having high-end GUIs, there are multiple reasons to use the Linux command line called the Terminal. Through Terminal, you can access many powerful native Linux commands as well" /><meta property="og:url" content="https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/" /><meta property="og:site_name" content="VITUX" /><meta property="article:publisher" content="https://www.facebook.com/vituxcom/" /><meta property="article:section" content="Debian" /><meta property="article:published_time" content="2019-12-11T07:24:05+00:00" /><meta property="article:modified_time" content="2019-12-11T07:27:54+00:00" /><meta property="og:updated_time" content="2019-12-11T07:27:54+00:00" /><meta property="og:image" content="https://vitux.com/wp-content/uploads/2019/12/guake-dropdown-terminal.jpg" /><meta property="og:image:secure_url" content="https://vitux.com/wp-content/uploads/2019/12/guake-dropdown-terminal.jpg" /><meta property="og:image:width" content="1024" /><meta property="og:image:height" content="512" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Although Debian users these days get to perform various operations through programs having high-end GUIs, there are multiple reasons to use the Linux command line called the Terminal. Through Terminal, you can access many powerful native Linux commands as well" /><meta name="twitter:title" content="Install and Use Guake - A drop-down Terminal Emulator for Debian 10" /><meta name="twitter:site" content="@vituxcom" /><meta name="twitter:image" content="https://vitux.com/wp-content/uploads/2019/12/guake-dropdown-terminal.jpg" /><meta name="twitter:creator" content="@vituxcom" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://vitux.com/#website","url":"https://vitux.com/","name":"VITUX","description":"Linux Compendium","publisher":{"@id":"https://vitux.com/#/schema/person/"},"potentialAction":{"@type":"SearchAction","target":"https://vitux.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/#primaryimage","url":"https://vitux.com/wp-content/uploads/2019/12/guake-dropdown-terminal.jpg","width":1024,"height":512,"caption":"Debian Guake Dropdown Terminal"},{"@type":"WebPage","@id":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/#webpage","url":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/","inLanguage":"en-US","name":"Install and Use Guake - A drop-down Terminal Emulator for Debian 10","isPartOf":{"@id":"https://vitux.com/#website"},"primaryImageOfPage":{"@id":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/#primaryimage"},"datePublished":"2019-12-11T07:24:05+00:00","dateModified":"2019-12-11T07:27:54+00:00"},{"@type":"Article","@id":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/#article","isPartOf":{"@id":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/#webpage"},"author":{"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1"},"headline":"Install and Use Guake &#8211; A drop-down Terminal Emulator for Debian 10","datePublished":"2019-12-11T07:24:05+00:00","dateModified":"2019-12-11T07:27:54+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/#webpage"},"publisher":{"@id":"https://vitux.com/#/schema/person/"},"image":{"@id":"https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/#primaryimage"},"articleSection":"Debian,Desktop,Shell"},{"@type":["Person"],"@id":"https://vitux.com/#/schema/person/d22013a52cb8122b01cb50f7647be2f1","name":"Karim Buzdar","sameAs":[]}]}</script> <link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Feed" href="https://vitux.com/feed/" /><link rel="alternate" type="application/rss+xml" title="VITUX &raquo; Comments Feed" href="https://vitux.com/comments/feed/" /><link rel='stylesheet' id='a3a3_lazy_load-css'  href='//vitux.com/wp-content/uploads/sass/a3_lazy_load.min.css' type='text/css' media='all' /> <script type='text/javascript'>/*  */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/vitux.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"7579","token":"de8075fc6f","debug":""};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1576005493/out/header-b69312bd.min.js'></script><!--[if lte IE 8]> <script type='text/javascript' src='https://vitux.com/wp-content/themes/spacious/js/html5shiv.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://vitux.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://vitux.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://vitux.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3" /><link rel='shortlink' href='https://vitux.com/?p=7579' /><link rel="alternate" type="application/json+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Finstall-and-use-guake-a-drop-down-terminal-emulator-for-debian%2F" /><link rel="alternate" type="text/xml+oembed" href="https://vitux.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fvitux.com%2Finstall-and-use-guake-a-drop-down-terminal-emulator-for-debian%2F&#038;format=xml" /><script data-cfasync="false" id="ao_optimized_gfonts_webfontloader" type="text/javascript">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body class="post-template-default single single-post postid-7579 single-format-standard  better-responsive-menu"><div id="page" class="hfeed site"> <a class="skip-link screen-reader-text" href="#main">Skip to content</a><header id="masthead" class="site-header clearfix spacious-header-display-one"><div id="header-text-nav-container" class=""><div class="inner-wrap" id="spacious-header-display-one"><div id="header-text-nav-wrap" class="clearfix"><div id="header-left-section"><div id="header-text" class=""><h3 id="site-title"> <a href="https://vitux.com/"
title="VITUX"
rel="home">VITUX</a></h3><p id="site-description">Linux Compendium</p></div></div><div id="header-right-section"><div class="header-action"></div><nav id="site-navigation" class="main-navigation clearfix   " role="navigation"><p class="menu-toggle">Menu</p><div class="menu-primary-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-18" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-18"><a href="https://vitux.com/">Home</a></li><li id="menu-item-1018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1018"><a href="https://vitux.com/linux/">Linux</a></li><li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://vitux.com/centos/">CentOS</a></li><li id="menu-item-109" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-109"><a href="https://vitux.com/debian/">Debian</a></li><li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://vitux.com/ubuntu/">Ubuntu</a></li><li id="menu-item-1017" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1017"><a href="https://vitux.com/shell/">Shell</a></li></ul></div></nav></div></div></div></div><div class="header-post-title-container clearfix"><div class="inner-wrap"><div class="post-title-wrapper"><h1 class="header-post-title-class">Install and Use Guake &#8211; A drop-down Terminal Emulator for Debian 10</h1></div></div></div></header><div id="main" class="clearfix"><div class="inner-wrap"><div id="primary"><div id="content" class="clearfix"><article id="post-7579" class="post-7579 post type-post status-publish format-standard has-post-thumbnail hentry category-debian category-desktop category-shell"><div class="entry-content clearfix"><p>Although Debian users these days get to perform various operations through programs having high-end GUIs, there are multiple reasons to use the Linux command line called the Terminal. Through Terminal, you can access many powerful native Linux commands as well as the empowering command-line features of many desktop applications. You can install software to your Debian much more easily through the Command Line, than the graphical installation alternative. You might have seen that many online-help guides will tell you how to resolve a problem through the Command Line. No matter which desktop environment you are using or which version of Linux you are on, the Terminal commands are usually the same.</p><p>If you are a true command line-savvy person like me, you might find that the Terminal application is mostly open on your Debian. Even if it’s not, you might find it a hassle to open the Terminal again and again for frequent use. If that’s the case, we would recommend you a drop-down console called Guake. Guake is a top-down terminal for Gnome (in the style of Yakuake for KDE, Tilda or the terminal used in Quake).</p><p>In this article, we will describe how to install Guake on your Debian through the command line. We will also describe how to perform some basic functions on Guake through the keyboard. We have run the commands and procedures mentioned in this article on a <strong>Debian 10 Buster</strong> system.</p><h2>Install Guake through the official Debian Repositories</h2><p>Guake is luckily available on the official Debian Stable Main repository and can be easily installed through the command line. We will be using the Debian command line, the Terminal, in order to install Guake on our system. You can open the Terminal bu first accessing the Application Launcher search bar by hitting the Super(Windows) key and then searching for Terminal as follows:</p><p><img class="lazy lazy-hidden aligncenter wp-image-7580" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-155.png" alt="Open Debian Terminal" width="226" height="214" /><noscript><img class="aligncenter wp-image-7580" src="https://vitux.com/wp-content/uploads/2019/09/word-image-155.png" alt="Open Debian Terminal" width="226" height="214" /></noscript> .</p><p>The next step is to update your system’s repository index through the following command:</p><pre>$ sudo apt-get update</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7581" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-156.png" alt="Update Package lists" width="731" height="228" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-156.png 731w, https://vitux.com/wp-content/uploads/2019/09/word-image-156-300x94.png 300w" sizes="(max-width: 731px) 100vw, 731px" /><noscript><img class="aligncenter wp-image-7581" src="https://vitux.com/wp-content/uploads/2019/09/word-image-156.png" alt="Update Package lists" width="731" height="228" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-156.png 731w, https://vitux.com/wp-content/uploads/2019/09/word-image-156-300x94.png 300w" sizes="(max-width: 731px) 100vw, 731px" /></noscript></p><p>Please note that only an authorized user can add, remove and configure software on Debian.</p><p>Now, enter the following command as sudo in order to install Guake to your Debian:</p><pre>$ sudo apt-get install guake</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7582" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-157.png" alt="Install Guake" width="649" height="265" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-157.png 649w, https://vitux.com/wp-content/uploads/2019/09/word-image-157-300x122.png 300w" sizes="(max-width: 649px) 100vw, 649px" /><noscript><img class="aligncenter wp-image-7582" src="https://vitux.com/wp-content/uploads/2019/09/word-image-157.png" alt="Install Guake" width="649" height="265" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-157.png 649w, https://vitux.com/wp-content/uploads/2019/09/word-image-157-300x122.png 300w" sizes="(max-width: 649px) 100vw, 649px" /></noscript></p><p>The system might prompt you with a Y/n option to continue installation. Enter Y and then hit enter; Guake will then be installed on your system.</p><p>You can check the version number of Guake and also verify that it is indeed installed on your system through the following command:</p><pre>$ guake --version</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7583" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-158.png" alt="Check Guake version" width="294" height="111" /><noscript><img class="aligncenter wp-image-7583" src="https://vitux.com/wp-content/uploads/2019/09/word-image-158.png" alt="Check Guake version" width="294" height="111" /></noscript></p><p>In order to check how you can use Guake through the Terminal, you can get help on it through the following command:</p><pre>$ guake --help</pre><p>For a more detailed manpage, you can make use of the following command:</p><pre>$ man guake</pre><h2>Launch and Use Guake</h2><p>Guake can be launched both through the UI and the command line. Run the following command in your Terminal to launch the application:</p><pre>$ guake</pre><p>Or else, you can enter relevant keywords in the Application Launcher search as follows to get to the Guake Terminal:</p><p><img class="lazy lazy-hidden aligncenter wp-image-7584" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-159.png" alt="Launch Guake" width="416" height="241" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-159.png 416w, https://vitux.com/wp-content/uploads/2019/09/word-image-159-300x174.png 300w" sizes="(max-width: 416px) 100vw, 416px" /><noscript><img class="aligncenter wp-image-7584" src="https://vitux.com/wp-content/uploads/2019/09/word-image-159.png" alt="Launch Guake" width="416" height="241" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-159.png 416w, https://vitux.com/wp-content/uploads/2019/09/word-image-159-300x174.png 300w" sizes="(max-width: 416px) 100vw, 416px" /></noscript></p><p>This is how your Guake terminal looks like by default.</p><p><img class="lazy lazy-hidden aligncenter wp-image-7585 size-large" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-160-1024x558.png" alt="Guake Dropdown Terminal Application" width="750" height="409" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-160-1024x558.png 1024w, https://vitux.com/wp-content/uploads/2019/09/word-image-160-300x164.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-160-768x419.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-160.png 1366w" sizes="(max-width: 750px) 100vw, 750px" /><noscript><img class="aligncenter wp-image-7585 size-large" src="https://vitux.com/wp-content/uploads/2019/09/word-image-160-1024x558.png" alt="Guake Dropdown Terminal Application" width="750" height="409" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-160-1024x558.png 1024w, https://vitux.com/wp-content/uploads/2019/09/word-image-160-300x164.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-160-768x419.png 768w, https://vitux.com/wp-content/uploads/2019/09/word-image-160.png 1366w" sizes="(max-width: 750px) 100vw, 750px" /></noscript></p><p>Here are some important things you can do after you have launched Guake in your current Debian session:</p><p><strong>Show/Hide Guake:</strong></p><p>Hit the F12 key in order to show/hide the terminal.</p><p>Alternatively, you can use the following commands in order to show and hide the Guake terminal:</p><pre>$ guake --show</pre><pre>$ guake --hide</pre><p><strong>Open New tab:</strong></p><p>You can open a new tab in Guake by using the following command syntax:</p><pre>$ guake -n [/path/to/folder]</pre><p>For example, the following command will open the tab with current location as the current user’s home folder:</p><pre>$ guake -n /usr/[username]/home</pre><p>This is the default location where your Terminal opens in Debian.</p><p><strong>Quit Guake:</strong></p><p>You can quit Gauke through the following command:</p><pre>$ guake -q</pre><p>Now, the Guake terminal will, of course, not open through the f12 key.</p><p><strong>Open Guake Preferences:</strong></p><p>The Guake Preferences UI lets you control the appearance and behavior of your Quake terminal to a great deal. Use the following command in order to view the Guake Preferences:</p><pre>$ guake -p</pre><p><img class="lazy lazy-hidden aligncenter wp-image-7586" src="//vitux.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://vitux.com/wp-content/uploads/2019/09/word-image-161.png" alt="Guake preferences" width="864" height="706" srcset="" data-srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-161.png 864w, https://vitux.com/wp-content/uploads/2019/09/word-image-161-300x245.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-161-768x628.png 768w" sizes="(max-width: 864px) 100vw, 864px" /><noscript><img class="aligncenter wp-image-7586" src="https://vitux.com/wp-content/uploads/2019/09/word-image-161.png" alt="Guake preferences" width="864" height="706" srcset="https://vitux.com/wp-content/uploads/2019/09/word-image-161.png 864w, https://vitux.com/wp-content/uploads/2019/09/word-image-161-300x245.png 300w, https://vitux.com/wp-content/uploads/2019/09/word-image-161-768x628.png 768w" sizes="(max-width: 864px) 100vw, 864px" /></noscript></p><h2>Remove Guake</h2><p>If you ever want to remove Guake, you can do so through the command line using the following command:</p><pre>$ sudo apt-get remove guake</pre><p>In order to remove the tool with all the configurations you might have made, use the following command as sudo:</p><pre>$ sudo apt-get purge guake</pre><p>With Guake, you always have a Terminal always available on your Debian desktop, only an F12 key away!</p><div class="extra-hatom-entry-title"><span class="entry-title">Install and Use Guake &#8211; A drop-down Terminal Emulator for Debian 10</span></div></div><footer class="entry-meta-bar clearfix"><div class="entry-meta clearfix"> <span class="by-author author vcard"><a class="url fn n"
href="https://vitux.com/author/karim/">Karim Buzdar</a></span><span class="date"><a href="https://vitux.com/install-and-use-guake-a-drop-down-terminal-emulator-for-debian/" title="7:24 am" rel="bookmark"><time class="entry-date published" datetime="2019-12-11T07:24:05+00:00">December 11, 2019</time><time class="updated" datetime="2019-12-11T07:27:54+00:00">December 11, 2019</time></a></span> <span class="category"><a href="https://vitux.com/debian/" rel="category tag">Debian</a>, <a href="https://vitux.com/desktop/" rel="category tag">Desktop</a>, <a href="https://vitux.com/shell/" rel="category tag">Shell</a></span></div></footer></article><ul class="default-wp-page clearfix"><li class="previous"><a href="https://vitux.com/how-to-view-saved-wifi-passwords-on-debian/" rel="prev"><span class="meta-nav">&larr;</span> How to View Saved WiFi Passwords on Debian 10</a></li><li class="next"></li></ul></div></div><div id="secondary"><aside id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><script async type="text/javascript" src="//cdn.carbonads.com/carbon.js?serve=CK7IVKQW&placement=vituxcom" id="_carbonads_js"></script></div></aside><aside id="search-3" class="widget widget_search"><h3 class="widget-title"><span>Search</span></h3><form action="https://vitux.com/" class="search-form searchform clearfix" method="get"><div class="search-wrap"> <input type="text" placeholder="Search" class="s field" name="s"> <button class="search-icon" type="submit"></button></div></form></aside><aside id="text-3" class="widget widget_text"><h3 class="widget-title"><span>About This Site</span></h3><div class="textwidget"><p>Vitux.com aims to become a Linux compendium with lots of unique and up to date tutorials.</p></div></aside><aside id="wpp-5" class="widget popular-posts"><h3 class="widget-title"><span>Most Popular</span></h3><ul class="wpp-list"><li> <a href="https://vitux.com/how-to-create-a-bootable-usb-stick-from-the-ubuntu-terminal/" class="wpp-post-title" target="_self">How to Create a Bootable USB Stick from the Ubuntu Terminal</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on August 19, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/get-linux-system-and-hardware-details-on-the-command-line/" class="wpp-post-title" target="_self">Get Linux System and Hardware Details on the Command Line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on August 7, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/centos/" class="category category-4">CentOS</a>, <a href="https://vitux.com/debian/" class="category category-6">Debian</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-xampp-on-your-ubuntu-18-04-lts-system/" class="wpp-post-title" target="_self">How to Install XAMPP on your Ubuntu 18.04 LTS System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 2, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-write-and-run-a-c-program-in-linux/" class="wpp-post-title" target="_self">How to Write and Run a C Program in Linux</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on October 17, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-and-configure-apache-web-server-on-ubuntu/" class="wpp-post-title" target="_self">How to Install and Configure Apache Web Server on Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 23, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-uninstall-programs-from-your-ubuntu-system/" class="wpp-post-title" target="_self">How to Uninstall Programs from your Ubuntu System</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 6, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-shut-down-ubuntu/" class="wpp-post-title" target="_self">How to Shut Down Ubuntu</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on January 21, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-find-files-on-the-ubuntu-command-line/" class="wpp-post-title" target="_self">How to find files on the Ubuntu command line</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on June 20, 2019</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-virtualbox-on-ubuntu/" class="wpp-post-title" target="_self">How to Install VirtualBox on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on November 5, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/desktop/" class="category category-10">Desktop</a>, <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/shell/" class="category category-8">Shell</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li><li> <a href="https://vitux.com/how-to-install-wine-on-ubuntu/" class="wpp-post-title" target="_self">How to Install Wine on Ubuntu 18.04 LTS</a> <span class="wpp-meta post-stats"><span class="wpp-date">posted on September 20, 2018</span> | <span class="wpp-category">under <a href="https://vitux.com/linux/" class="category category-9">Linux</a>, <a href="https://vitux.com/ubuntu/" class="category category-5">Ubuntu</a></span></span></li></ul></aside></div></div></div><footer id="colophon" class="clearfix"><div class="footer-socket-wrapper clearfix"><div class="inner-wrap"><div class="footer-socket-area"> Copyright &copy; <a href="https://vitux.com">vitux.com</a><nav class="small-menu clearfix"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-133"><a href="https://vitux.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-134"><a href="https://vitux.com/imprint/">Imprint</a></li></ul></div></nav></div></div></div></footer> <a href="#masthead" id="scroll-up"></a></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-2155872-5', 'auto');
			ga('set', 'anonymizeIp', true);
			ga('send', 'pageview');</script> <script type="text/javascript">(function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();</script> <script>var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });</script> <script type='text/javascript'>/*  */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_extend_params = {"edgeY":"0"};
/*  */</script> <script defer type='text/javascript' src='https://vitux.com/wp-content/uploads/cache/fvm/1576005493/out/footer-75e3307e.min.js'></script><script>/* loadCSS. [c]2017 Filament Group, Inc. MIT License */
(function(w){if(!w.loadCSS)w.loadCSS=function(){};var rp=loadCSS.relpreload={};rp.support=function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=false}return function(){return ret}}();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){if(link.addEventListener)link.removeEventListener("load",enableStylesheet);else if(link.attachEvent)link.detachEvent("onload",enableStylesheet);link.setAttribute("onload",null);link.media=finalMedia}if(link.addEventListener)link.addEventListener("load",enableStylesheet);else if(link.attachEvent)link.attachEvent("onload",enableStylesheet);setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3E3)};rp.poly=function(){if(rp.support())return;var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss", true);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener)w.addEventListener("load",function(){rp.poly();w.clearInterval(run)});else if(w.attachEvent)w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}if(typeof exports!=="undefined")exports.loadCSS=loadCSS;else w.loadCSS=loadCSS})(typeof global!=="undefined"?global:this);</script> </body></html>

<!-- Cachify | http://cachify.de
Memcached @ 11.12.2019 07:28:11 -->